Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » Error on succesful jet.transform Ant task
Error on succesful jet.transform Ant task [message #61842] Wed, 27 May 2009 04:51 Go to next message
fabio boldrini is currently offline fabio boldrini
Messages: 4
Registered: July 2009
Junior Member
i have this ant file

<project name="Jet" default="RunJet">
<property environment="env" />
<target name="RunJet" >
<jet.transform
transformid="JetPlugin"
source="SismMi/view/project.xml" taskname="test"
/>
</target>
</project>

I use this ant file as a builder when i save my model xml file.
The generation work well, but the jet.transform task exit with this
message:

Successful execution with messages

The problem is eclipse take this error message from ant and popup it and
it's not nice!

Some way to solve the problem on the JET side, or disable the error
message from Ant?

Ps. i search the string on google and i find this link
http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.m2t/org .eclipse.jet/plugins/org.eclipse.jet.core/src/org/eclipse/je t/internal/l10n/JET2Messages.properties?root=Modeling_Projec t&view=co

http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.m2t/org .eclipse.jet/plugins/org.eclipse.jet/src/org/eclipse/jet/int ernal/l10n/JET2Messages.properties?root=Modeling_Project& ;view=co
Re: Error on succesful jet.transform Ant task [message #61980 is a reply to message #61842] Thu, 28 May 2009 08:45 Go to previous messageGo to next message
Paul Elder is currently offline Paul Elder
Messages: 849
Registered: July 2009
Senior Member
Fabio:

I suggest you file a bugzilla:

https://bugs.eclipse.org/bugs/enter_bug.cgi?product=M2T& version=unspecified&component=Jet&rep_platform=PC&am p;op_sys=Windows%20XP&priority=P3&bug_severity=norma l&bug_status=NEW&bug_file_loc=http%3A%2F%2F&shor t_desc=&comment=&commentprivacy=0&keywords=& dependson=&blocked=&maketemplate=Remember%20values%2 0as%20bookmarkable%20template&form_name=enter_bug&as signed_to=m2t.jet-inbox%40eclipse.org&qa_contact=

JET is in shutdown mode for Galileo, so I'm not sure I could do anything
about this until Galileo SR1.

Paul
Re: Error on succesful jet.transform Ant task [message #62099 is a reply to message #61980] Fri, 29 May 2009 07:23 Go to previous messageGo to next message
fabio boldrini is currently offline fabio boldrini
Messages: 4
Registered: July 2009
Junior Member
i found a workaround.

the message successful execution with message was caused by <c:log>.

When i rip the log out, the tranformation ended with a Successful
Execution and ant exit without error.

I had submited the bug with this explanation.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=278368

Bye

Paul Elder wrote:

> Fabio:

> I suggest you file a bugzilla:

>
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=M2T& version=unspecified&component=Jet&rep_platform=PC&am p;op_sys=Windows%20XP&priority=P3&bug_severity=norma l&bug_status=NEW&bug_file_loc=http%3A%2F%2F&shor t_desc=&comment=&commentprivacy=0&keywords=& dependson=&blocked=&maketemplate=Remember%20values%2 0as%20bookmarkable%20template&form_name=enter_bug&as signed_to=m2t.jet-inbox%40eclipse.org&qa_contact=

> JET is in shutdown mode for Galileo, so I'm not sure I could do anything
> about this until Galileo SR1.

> Paul
Re: Error on succesful jet.transform Ant task [message #494235 is a reply to message #62099] Thu, 29 October 2009 12:47 Go to previous messageGo to next message
Miguel Angel Garcia de Dios is currently offline Miguel Angel Garcia de Dios
Messages: 22
Registered: July 2009
Junior Member
Hi everyone,
I have Eclipse Galileo with M2T(JET) updatedwith the latest stable
release and I have that problem even without any <c:log>. I mean,
independenly of my tampleates, I always obtain the same message of
"successful execution". I remember that a few months ago this problem
does not exist. For me, this is a problem because the message causes
that the exution of my Ant build file is interrupted and finished after
the "jet.transform" task so, obviously the subsecuent tasks and targets
are not executed.
Does anybody know anything about this?
Thank you in advance.

fabio boldrini wrote:
> i found a workaround.
>
> the message successful execution with message was caused by <c:log>.
>
> When i rip the log out, the tranformation ended with a Successful
> Execution and ant exit without error.
>
> I had submited the bug with this explanation.
>
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=278368
>
> Bye
>
> Paul Elder wrote:
>
>> Fabio:
>
>> I suggest you file a bugzilla:
>
>>
> https://bugs.eclipse.org/bugs/enter_bug.cgi?product=M2T& version=unspecified&component=Jet&rep_platform=PC&am p;op_sys=Windows%20XP&priority=P3&bug_severity=norma l&bug_status=NEW&bug_file_loc=http%3A%2F%2F&shor t_desc=&comment=&commentprivacy=0&keywords=& dependson=&blocked=&maketemplate=Remember%20values%2 0as%20bookmarkable%20template&form_name=enter_bug&as signed_to=m2t.jet-inbox%40eclipse.org&qa_contact=
>
>
>> JET is in shutdown mode for Galileo, so I'm not sure I could do
>> anything about this until Galileo SR1.
>
>> Paul
>
>
Re: Error on succesful jet.transform Ant task [message #646136 is a reply to message #494235] Wed, 22 December 2010 04:40 Go to previous message
Elias Balasis is currently offline Elias Balasis
Messages: 11
Registered: July 2009
Junior Member
On 10/29/2009 6:47 PM, Miguel Angel Garcia de Dios wrote:
> Hi everyone,
> I have Eclipse Galileo with M2T(JET) updatedwith the latest stable
> release and I have that problem even without any <c:log>. I mean,
> independenly of my tampleates, I always obtain the same message of
> "successful execution". I remember that a few months ago this problem
> does not exist. For me, this is a problem because the message causes
> that the exution of my Ant build file is interrupted and finished after
> the "jet.transform" task so, obviously the subsecuent tasks and targets
> are not executed.
> Does anybody know anything about this?
> Thank you in advance.
>
> fabio boldrini wrote:
>> i found a workaround.
>>
>> the message successful execution with message was caused by <c:log>.
>>
>> When i rip the log out, the tranformation ended with a Successful
>> Execution and ant exit without error.
>>
>> I had submited the bug with this explanation.
>>
>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=278368
>>
>> Bye
>>
>> Paul Elder wrote:
>>
>>> Fabio:
>>
>>> I suggest you file a bugzilla:
>>
>>>
>> https://bugs.eclipse.org/bugs/enter_bug.cgi?product=M2T& version=unspecified&component=Jet&rep_platform=PC&am p;op_sys=Windows%20XP&priority=P3&bug_severity=norma l&bug_status=NEW&bug_file_loc=http%3A%2F%2F&shor t_desc=&comment=&commentprivacy=0&keywords=& dependson=&blocked=&maketemplate=Remember%20values%2 0as%20bookmarkable%20template&form_name=enter_bug&as signed_to=m2t.jet-inbox%40eclipse.org&qa_contact=
>>
>>
>>> JET is in shutdown mode for Galileo, so I'm not sure I could do
>>> anything about this until Galileo SR1.
>>
>>> Paul
>>
>>

Same here, using Eclipse 3.5.2 and JET 1.0.2, success produces failure
with message "Successful completion" and build stops prematurely

I hope JET next release however compatible with Eclipse 3.6 functions
correctly. However, the set of tools I am using are not yet compliant
with Eclipse 3.6
Previous Topic:[Acceleo] Is there a good reason why query inheritance isn't supported
Next Topic:[Acceleo 3] derived metamodel - type not recognized - eProxyURI
Goto Forum:
  


Current Time: Thu Apr 24 14:47:42 EDT 2014

Powered by FUDForum. Page generated in 0.13122 seconds