Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Platform - User Assistance (UA) » Infocenter web app: configuring logging in JBoss 4.2.1
Infocenter web app: configuring logging in JBoss 4.2.1 [message #611138] Tue, 08 April 2008 00:08
Peter Desjardins is currently offline Peter Desjardins
Messages: 21
Registered: July 2009
Junior Member
I've been using the Infocenter web application in JBoss 4.0.1 for some
time now. I am required to also make it work under JBoss 4.2.1.
Unfortunately JBoss 4.2.1 will not run the web application because of
some incompatibility between log4j in JBoss and commons-logging in the
WAR file.

I see this error when I try to open the infocenter.

org.apache.commons.logging.LogConfigurationException:
org.apache.commons.logging.LogConfigurationException: No suitable Log
constructor [Ljava.lang.Class;@1cfc277 for
org.apache.commons.logging.impl.Log4JLogger (Caused by
java.lang.NoClassDefFoundError: org/apache/log4j/Category) (Caused by
org.apache.commons.logging.LogConfigurationException: No suitable Log
constructor [Ljava.lang.Class;@1cfc277 for
org.apache.commons.logging.impl.Log4JLogger (Caused by
java.lang.NoClassDefFoundError: org/apache/log4j/Category))

Has anyone else run the infocenter web application under JBoss 4.2 or
higher? Did you see this problem and were you able to fix it?

One developer I consulted suggested configuring the web application to
use Java logging instead of log4j. I am trying to try that but have not
succeeded yet.

Thanks for your help.

Peter Desjardins
Previous Topic:Asked on eclipse_tw group: any product customization way to disable display of bread crumbs?
Next Topic:Using standalone help system and displayHelp() method not displaying new browser
Goto Forum:
  


Current Time: Sat Aug 02 04:47:53 EDT 2014

Powered by FUDForum. Page generated in 0.01789 seconds