Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Platform - User Assistance (UA) » Using standalone help system and displayHelp() method not displaying new browser
Using standalone help system and displayHelp() method not displaying new browser [message #611132] Mon, 07 April 2008 18:42
Ted Lyons is currently offline Ted Lyons
Messages: 14
Registered: July 2009
Junior Member
Hello,

I am using the class org.eclipse.help.standalone.Help and trying to get
the displayHelp() method to work. If I use the command line, it works
fine and a new browser window appears displaying the page.

Using java code, I can see that the Help system does start, as I can
manually bring up a browser and enter the url and see the data. However,
using displayHelp() does not bring up a browser displaying the page
automatically like the command line API does.

Briefly, the code looks like this:
String[] args = new String[4];
args[0] = "-eclipseHome";
args[1] = "C:\\java samples\\eclipse";
args[2] = "-port";
args[3] = "59233";
System.out.println("about to init help");
Help helpSystem = new Help(args);
try {
helpSystem.start();
helpSystem.displayHelp();
System.out.println("Eclipse Help subsystem started");
return;
}
catch (Exception e) {
e.printStackTrace();
}
Previous Topic:Connecting web applications to standalone help
Next Topic:Asked on eclipse_tw group: any product customization way to disable display of bread crumbs?
Goto Forum:
  


Current Time: Mon Sep 22 12:14:06 GMT 2014

Powered by FUDForum. Page generated in 0.01603 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software