Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMT (Generative Modeling Technologies) » [AM3] Am3 installation problem
[AM3] Am3 installation problem [message #611112] Mon, 07 January 2008 13:42
Manu is currently offline Manu
Messages: 16
Registered: July 2009
Junior Member
Hi to all.
I've this problem with the installation of the org.eclipse.am3.core
plug-in:
when I try to export the plug-in I've this problem returned from the
process of installation in the log file:

7. ERROR in
H:\workspace\org.eclipse.am3.core\src\org\eclipse\am3\core\A M3CoreTools.java
(at line 1)
package org.eclipse.am3.core;
^
The type org.eclipse.m2m.atl.engine.vm.nativelib.ASMModel cannot be
resolved. It is indirectly referenced from required .class files
----------
8. ERROR in
H:\workspace\org.eclipse.am3.core\src\org\eclipse\am3\core\A M3CoreTools.java
(at line 20)
import org.eclipse.m2m.atl.engine.vm.nativelib.ASMModel;
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
The import org.eclipse.m2m.atl.engine.vm.nativelib.ASMModel cannot be
resolved


It looks like the org.eclipse.am3.core plug-in can't find the
org.eclipse.m2m.atl.engine. So, I've controlled about the presence of the
org.eclipse.m2m.atl.engine plug-in and there is no problem about it. The
plug-in is present in the eclipse\plug-in directory. So, I can't
understand which is the problem.

Thanks to all for the help

Manu
Previous Topic:am3 ant tasks outside eclipse workspace
Next Topic:[TCS] More than one syntax construction per class AND optional keywords
Goto Forum:
  


Current Time: Sat Apr 19 18:32:54 EDT 2014

Powered by FUDForum. Page generated in 0.06012 seconds