Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMT (Generative Modeling Technologies) » [TCS] Language Project example and dependent project's version
[TCS] Language Project example and dependent project's version [message #609301] Thu, 22 November 2007 14:08
Gustavo Cabral is currently offline Gustavo CabralFriend
Messages: 20
Registered: July 2009
Junior Member
Hi everyone,

I have tried the TCS/Language Project example
(http://wiki.eclipse.org/TCS/Language_Project) with metamodel and
syntax from the LOTOS example
(http://www.eclipse.org/m2m/atl/usecases/FIACRE2LOTOS/) but I just cant
make
it work!

I am using:
- the latest classic eclipse,
- updating with the EMF plugin,
- downloading the latest ATL plugin (I also install a build I
made from the CVS)

....but no success!

I think it is some major problem with the Eclipse X ATL X EMF versions. I
re-compiled and installed the latest version of ATL from the CVS
repository
but it didnt work. The classes:

org.eclipse.m2m.atl.engine.AtlEMFModelHandler;
org.eclipse.m2m.atl.engine.AtlModelHandler;
import org.eclipse.gmt.tcs.injector.TCSInjector;
org.eclipse.m2m.atl.engine.EnginePlugin;
org.eclipse.m2m.atl.engine.MarkerMaker;

cannot be found when I try to compile the "TCS Builder plugin" and the
"TCS Wizard plugin".

Through the ant approach, I get the following error:

-----------
.....

BUILD FAILED
/home/gustavo/Desktop/eclipseClassicX/workspace/AMMAScripts/ build.dsl.xml:55:
The following error occurred while executing this line:
/home/gustavo/Desktop/eclipseClassicX/workspace/AMMAScripts/ build.dsl.xml:78:
The following error occurred while executing this line:
/home/gustavo/Desktop/eclipseClassicX/workspace/AMMAScripts/ build.metamodel.xml:68:
Problem: failed to create task or type am3.loadModel
Cause: The name is undefined.
Action: Check the spelling.
Action: Check that any custom tasks/types have been declared.
Action: Check that any <presetdef>/<macrodef> declarations have taken
place.

------------

Can any one help me? What versions should I use?

Thank you for your time,
Gustavo Cabral
Previous Topic:Re: How build DD Model with UML metamodel
Next Topic:[MOFScript]
Goto Forum:
  


Current Time: Sun Nov 23 21:37:11 GMT 2014

Powered by FUDForum. Page generated in 0.04123 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software