Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » AJDT » Which version for Websphere WSAD
Which version for Websphere WSAD [message #61535] Wed, 01 February 2006 10:07 Go to next message
Eclipse User
Originally posted by: naeger.gmx.de

Hi,

our project uses Websphere Studio Application Developer (WSAD) V5.1.2 and
we would like to introduce AspectJ in our project.

As far as I understand, I have to use AJDT 1.1.4 as WSAD is based on
Eclipse 2.
Is this correct?

AJDT 1.1.4 includes an older version of AspectJ (which version by the
way?).
I am not sure if it is possible to use AJDT 1.1.4 with a newer version of
AspectJ. Is this possible?

If not, what are the major differences to the current version. Is it
advicable to use the old version?

If anyone elaborated on my options for using AspectJ with WSAD5.1.2 I
would be very grateful.

Regards, Chris
Re: Which version for Websphere WSAD [message #61590 is a reply to message #61535] Wed, 01 February 2006 12:17 Go to previous messageGo to next message
Matt Chapman is currently offline Matt Chapman
Messages: 429
Registered: July 2009
Senior Member
On Wed, 01 Feb 2006 10:07:09 +0000, Christian Naeger wrote:
> our project uses Websphere Studio Application Developer (WSAD) V5.1.2
> and we would like to introduce AspectJ in our project.
>
> As far as I understand, I have to use AJDT 1.1.4 as WSAD is based on
> Eclipse 2.
> Is this correct?

Yes.
(well to be more precise, it's based on Eclipse 2.1)

> AJDT 1.1.4 includes an older version of AspectJ (which version by the
> way?).

I believe it's AspectJ 1.1.1.

> I am not sure if it is possible to use AJDT 1.1.4 with a newer version
> of AspectJ. Is this possible?

No, not in the general case, as a newer version of AspectJ would come with
a newer version of the integration layer between the two, which would then
most likely to be incompatible with AJDT 1.1.4.

> If not, what are the major differences to the current version. Is it
> advicable to use the old version?

AJDT 1.1.4 and AspectJ 1.1.1 are nearly two and a half years old, and the
differences between those and the current releases of AJDT 1.3 and AspectJ
1.5 are huge, and therefore hard to summarise - essentially there have
been improvements across the board and many many new features.

> If anyone elaborated on my options for using AspectJ with WSAD5.1.2 I
> would be very grateful.

Your options are unfortunately fairly limited - either stick with the old
versions, or possibly use a more recent AspectJ and use an Ant build to
compile your projects instead of AJDT. You will of course lose all the
support AJDT gives you - maybe you could do some prototyping using the
latest AJDT in a separate environment (using say Eclipse 3.1.1) and then
import it into your WSAD environment.

Finally, this probably doesn't help you right now, but we have at least
made improvements since then to reduce subsequent issues like this. For
example when we released AJDT 1.3 for Eclipse 3.1, we were also able to
release AJDT 1.2.1 for Eclipse 3.0 (and therefore Rational
Application Developer 6) containing the same release of AspectJ 5, and
also almost all of the functionality from AJDT 1.3.

Regards,

Matt.
Re: Which version for Websphere WSAD [message #61800 is a reply to message #61590] Thu, 09 February 2006 09:26 Go to previous message
Eclipse User
Originally posted by: naeger.gmx.de

Thanks a lot for the clarification. We will go with the latest AspectJ and
the ant build.

Greetings, Chris

Matt Chapman wrote:
> Your options are unfortunately fairly limited - either stick with the old
> versions, or possibly use a more recent AspectJ and use an Ant build to
> compile your projects instead of AJDT. You will of course lose all the
> support AJDT gives you - maybe you could do some prototyping using the
> latest AJDT in a separate environment (using say Eclipse 3.1.1) and then
> import it into your WSAD environment.
Re: Which version for Websphere WSAD [message #592068 is a reply to message #61535] Wed, 01 February 2006 12:17 Go to previous message
Matt Chapman is currently offline Matt Chapman
Messages: 429
Registered: July 2009
Senior Member
On Wed, 01 Feb 2006 10:07:09 +0000, Christian Naeger wrote:
> our project uses Websphere Studio Application Developer (WSAD) V5.1.2
> and we would like to introduce AspectJ in our project.
>
> As far as I understand, I have to use AJDT 1.1.4 as WSAD is based on
> Eclipse 2.
> Is this correct?

Yes.
(well to be more precise, it's based on Eclipse 2.1)

> AJDT 1.1.4 includes an older version of AspectJ (which version by the
> way?).

I believe it's AspectJ 1.1.1.

> I am not sure if it is possible to use AJDT 1.1.4 with a newer version
> of AspectJ. Is this possible?

No, not in the general case, as a newer version of AspectJ would come with
a newer version of the integration layer between the two, which would then
most likely to be incompatible with AJDT 1.1.4.

> If not, what are the major differences to the current version. Is it
> advicable to use the old version?

AJDT 1.1.4 and AspectJ 1.1.1 are nearly two and a half years old, and the
differences between those and the current releases of AJDT 1.3 and AspectJ
1.5 are huge, and therefore hard to summarise - essentially there have
been improvements across the board and many many new features.

> If anyone elaborated on my options for using AspectJ with WSAD5.1.2 I
> would be very grateful.

Your options are unfortunately fairly limited - either stick with the old
versions, or possibly use a more recent AspectJ and use an Ant build to
compile your projects instead of AJDT. You will of course lose all the
support AJDT gives you - maybe you could do some prototyping using the
latest AJDT in a separate environment (using say Eclipse 3.1.1) and then
import it into your WSAD environment.

Finally, this probably doesn't help you right now, but we have at least
made improvements since then to reduce subsequent issues like this. For
example when we released AJDT 1.3 for Eclipse 3.1, we were also able to
release AJDT 1.2.1 for Eclipse 3.0 (and therefore Rational
Application Developer 6) containing the same release of AspectJ 5, and
also almost all of the functionality from AJDT 1.3.

Regards,

Matt.
Re: Which version for Websphere WSAD [message #592166 is a reply to message #61590] Thu, 09 February 2006 09:26 Go to previous message
Eclipse User
Originally posted by: naeger.gmx.de

Thanks a lot for the clarification. We will go with the latest AspectJ and
the ant build.

Greetings, Chris

Matt Chapman wrote:
> Your options are unfortunately fairly limited - either stick with the old
> versions, or possibly use a more recent AspectJ and use an Ant build to
> compile your projects instead of AJDT. You will of course lose all the
> support AJDT gives you - maybe you could do some prototyping using the
> latest AJDT in a separate environment (using say Eclipse 3.1.1) and then
> import it into your WSAD environment.
Previous Topic:compiler not copying .xml file to output folder
Next Topic:confused on how to setup projects
Goto Forum:
  


Current Time: Thu Sep 18 01:52:12 GMT 2014

Powered by FUDForum. Page generated in 0.02656 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software