Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Cannot launch product configuration
Cannot launch product configuration [message #606326] Mon, 26 July 2010 16:46 Go to next message
Anton is currently offline Anton
Messages: 23
Registered: July 2009
Junior Member
I get an error when I try to launch my "Product Configuration" created in
eclipse Helios on windows 7! I have tried to follow the below guides:

http://wiki.eclipse.org/FAQ_How_do_I_create_an_Eclipse_produ ct%3F
http://www.vogella.de/articles/EclipseRCP/article.html#produ ct_launch

but I still get an error. Here is what I do:

1) I have created a Plugin Project "test.pde" with Eclipse as taget
platform using the "Hello, World Command" template.

2) Next I have created a new Product Configuration and put it in the
"test.pde" project.

3) On the overview page in the "Product Definition" section I have selected
"New..." and selected the previous plugin as "product" and kept the
"org.eclipse.ant.core.antRunner" as the "Product Application". As a result
the "org.eclipse.core.runtime.products" extension is added to the "test.pde"
plugin MANIFEST file. I have updated the ID to "test.pde".

4) On the Dependencies pane I have added the "test.pde" plugin and clicked
"Add Required Plug-ins". Then I have added the "org.eclipse.ant.core" plugin
and clicked the "Add Required Plug-ins" again.

5) I then click "Launch an Eclipse application" but get the following error:

!ENTRY org.eclipse.osgi 4 0 2010-07-26 22:36:04.609
!MESSAGE Application error
!STACK 1
java.lang.NullPointerException
at
org.eclipse.ant.core.AntCorePreferences.findHighestAntVersio n(AntCorePreferences.java:491)
at
org.eclipse.ant.core.AntCorePreferences.getDefaultAntHomeEnt ries(AntCorePreferences.java:440)
at
org.eclipse.ant.core.AntCorePreferences.getDefaultAntHome(An tCorePreferences.java:304)
at
org.eclipse.ant.core.AntCorePreferences.restoreAntHome(AntCo rePreferences.java:292)
at
org.eclipse.ant.core.AntCorePreferences.restoreCustomObjects (AntCorePreferences.java:197)
at
org.eclipse.ant.core.AntCorePreferences.<init>(AntCorePreferences.java:163)
at
org.eclipse.ant.core.AntCorePlugin.setRunningHeadless(AntCor ePlugin.java:234)
at org.eclipse.ant.core.AntRunner.run(AntRunner.java:494)
at org.eclipse.ant.core.AntRunner.start(AntRunner.java:600)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:196)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:369)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 619)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
at org.eclipse.equinox.launcher.Main.main(Main.java:1383)


I am pretty stuck at this point any ideas on what I do wrong?
Re: Cannot launch product configuration [message #637171 is a reply to message #606326] Thu, 04 November 2010 09:12 Go to previous message
Mattias  is currently offline Mattias
Messages: 6
Registered: June 2010
Junior Member
I had the same problem. It was solved by adding the org.apache.ant plugin

[Updated on: Thu, 04 November 2010 09:13]

Report message to a moderator

Previous Topic:Custom compare
Next Topic:How to access the PluginBase
Goto Forum:
  


Current Time: Thu Aug 21 00:41:30 EDT 2014

Powered by FUDForum. Page generated in 0.01947 seconds