Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Not including root files in plug-ins
Not including root files in plug-ins [message #605707] Fri, 30 April 2010 15:36
No real name is currently offline No real name
Messages: 2
Registered: April 2010
Junior Member
Hello, I have searched high and low and there is very little on Google about this, so I figured I'd ask.

I looked at the documentation for adding root files here:

http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse .pde.doc.user/tasks/pde_rootfiles.htm

I have a plug-in project so I followed these steps:

Quote:
> Add a build.properties file containing absolute root properties to the automatically generated container feature:
>
> ${buildDirectory}/build.properties: generatedBuildProperties = ${buildDirectory}/root.properties
> ${buildDirectory/root.properties: root = absolute:${buildDirectory}/rootfiles
> ${buildDirectory}/rootfiles/*


So my plug-in project now has a build.properties file in its root that looks like this:

generatedBuildProperties = root.properties

And I have another file called root.properties in the same directory that contains this:

root = html/

(Yes the HTML directory exists in my projects root as well.) Now I go to my .product file and click on the "Eclipse Product export wizard" link and sure I get a package that works, but my html directory is there.

Can anyone tell me what I have done wrong? Thank you for your help.
Previous Topic:Not including root files in plug-ins
Next Topic:Line Highlighting in active eclipse source code editor
Goto Forum:
  


Current Time: Sat Jul 26 07:24:12 EDT 2014

Powered by FUDForum. Page generated in 0.04010 seconds