Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » launching JUnit plugin-test from command Prompt
launching JUnit plugin-test from command Prompt [message #605649] Wed, 21 April 2010 18:15 Go to next message
Ram  is currently offline Ram
Messages: 3
Registered: April 2010
Junior Member
Hi,

I have created a plugin and have a JUnit pluin-test code that will launch this plugin. This plugin, basically opens the eclipse, perform some tasks, collect data and close the eclipse instance. Couldn't find much help with the internet. Any help on this is appreciated.

I m using Eclipse 3.3.2.

I tried the equinox launcher to launch the application. The eclipse opens up, but then, it closes throwing an exception

Could not connect to: : 1564
java.net.ConnectException: Connection refused: connect
at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:352)
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.ja va:214)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:201)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:377)
at java.net.Socket.connect(Socket.java:530)
at java.net.Socket.connect(Socket.java:480)
at java.net.Socket.<init>(Socket.java:377)
at java.net.Socket.<init>(Socket.java:191)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.conne ct(RemoteTestRunner.java:560)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(R emoteTestRunner.java:377)
at org.eclipse.pde.internal.junit.runtime.RemotePluginTestRunne r.main(RemotePluginTestRunner.java:58)
at org.eclipse.pde.internal.junit.runtime.UITestApplication$1.r un(UITestApplication.java:122)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchr onizer.java:129)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3659)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3296)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2389)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2353)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:22 19)
at org.eclipse.ui.internal.Workbench$4.run(Workbench.java:466)
at org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:289)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:461)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start (IDEApplication.java:106)
at org.eclipse.pde.internal.junit.runtime.UITestApplication.sta rt(UITestApplication.java:52)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:169)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:106)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:76)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:363)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:176)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:37)
at java.lang.reflect.Method.invoke(Method.java:599)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 508)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
at org.eclipse.equinox.launcher.Main.main(Main.java:1148)
58777 [main] DEBUG AdoptionTrackingActivator - adoption tracking plugin stops


Should I set the port anywhere in the code or should I write a listener that will listen to this port? I need to get this resolved as soon as possible. Any help on this is appreciated.

Thanks
Ram
Re: launching JUnit plugin-test from command Prompt [message #605658 is a reply to message #605649] Thu, 22 April 2010 10:29 Go to previous message
Curtis Windatt is currently offline Curtis Windatt
Messages: 166
Registered: July 2009
Senior Member
A very quick search found others experiencing the same problem, but no solutions. Most people appeared to have this problem using Eclipse 3.3, but not using later versions of Eclipse.

http://stackoverflow.com/questions/424392/unable-to-run-juni t-tests-in-eclipse
http://dev.eclipse.org/newslists/news.eclipse.tools/msg28534 .html
Previous Topic:launching JUnit plugin-test from command Prompt
Next Topic:copy file by programming
Goto Forum:
  


Current Time: Wed Aug 27 09:20:29 EDT 2014

Powered by FUDForum. Page generated in 0.12363 seconds