Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Can't install exported plugin
Can't install exported plugin [message #604733] Thu, 18 February 2010 19:53 Go to next message
sheamus  is currently offline sheamus
Messages: 14
Registered: September 2009
Junior Member
Using eclipse 3.4. My plugin works fine when I launch it from eclipse. I do an export "Deployable plugins and fragments", to a dir or a zip file, everything seems fine. But when I go to Help->Install Updates and then add the directory to sites, there doesn't seem to be any features to install under it. What am I doing wrong here?
Re: Can't install exported plugin [message #604738 is a reply to message #604733] Thu, 18 February 2010 20:19 Go to previous message
Ankur Sharma is currently offline Ankur Sharma
Messages: 68
Registered: July 2009
Member
On 2/19/2010 1:23 AM, sheamus wrote:
> Using eclipse 3.4. My plugin works fine when I launch it from eclipse.
> I do an export "Deployable plugins and fragments", to a dir or a zip
> file, everything seems fine. But when I go to Help->Install Updates and
> then add the directory to sites, there doesn't seem to be any features
> to install under it. What am I doing wrong here?

You need to create a feature and export it too.

Create a feature project. Add your plug-ins to it. Now Export this feature. The Install shall
recognize the feature and install it to your Eclipse installation.

hth,
--
Ankur..
Eclipse PDE UI Committer | IBM India Software Lab, Bangalore
+91-99456-94011 | @ankur_sharma | http://blog.ankursharma.org
Previous Topic:How to authenticate contributing extension
Next Topic:Can't install exported plugin
Goto Forum:
  


Current Time: Thu Oct 23 10:25:49 GMT 2014

Powered by FUDForum. Page generated in 0.02152 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software