Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » PDE product build existing config.ini
PDE product build existing config.ini [message #604611] Wed, 10 February 2010 19:42
Amit  is currently offline Amit
Messages: 7
Registered: February 2010
Junior Member
I having some trouble getting the PDE headless build to use an existing
'config.ini', instead it generates a default one. I have created a product
configuration and invoke the productBuild.xml via AntRunner. The entire
build process works without errros. However, the final product output does
not contain the custom 'config.ini'.

<target name="pde-build">
<echo>Starting PDE Build Target</echo>
<echo>"ClassPath ${eclipseLocation}/plugins/org.eclipse.equinox.launcher_${eq uinoxLauncherPluginVersion}.jar "</echo>
<echo>"MAKING UPDATE PACKAGE: ${outputUpdateJars}</echo>
<java classname="org.eclipse.equinox.launcher.Main" fork="true" failonerror="true">
<arg value="-application" />
<arg value="org.eclipse.ant.core.antRunner" />
<arg value="-buildfile" />
<arg value=" ${eclipseLocation}/plugins/org.eclipse.pde.build_${pdeBuildP luginVersion}/scripts/productBuild/productBuild.xml " />
<arg value="-Dtimestamp=${timestamp}" />
<arg value="-DoutputUpdateJars=${outputUpdateJars}" />
<arg value="-DarchivesFormat=${archivesFormat}" />
<arg value="-DbuildDirectory=${buildDirectory}" />
<classpath>
<pathelement location=" ${eclipseLocation}/plugins/org.eclipse.equinox.launcher_${eq uinoxLauncherPluginVersion}.jar " />
</classpath>
</java>
<echo>"MAKING UPDATE PACKAGE: ${outputUpdateJars}"</echo>
</target>
Can anyone help???

Thanks
Amit
Previous Topic:PDE product build existing config.ini
Next Topic:Galileo's P2 doesn't recognize previously working plugin
Goto Forum:
  


Current Time: Fri Aug 22 00:12:49 EDT 2014

Powered by FUDForum. Page generated in 0.02446 seconds