Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » feature dependency error message
feature dependency error message [message #604455] Sat, 30 January 2010 18:24
No real name is currently offline No real name
Messages: 3
Registered: November 2009
Junior Member
Hi,

I'm building an update site with a lot of categories. Two features in different cagegories depend on another feature with additional graphical plugins.

If an user wants to install one of these features without having installed the required graphic feature they just get the following error message:

eXtremeDesign XD (0.8.5) requires plug-in "org.eclipse.gef"

This is accaptable as long as the graphical feature is listed in the same category as eXtremeDesign (in this example).

But it is not nice at all as soon as another feature in another category needs it as well.

How can I change this error message to something nice like: "Please install the features listed in graphical support before installing this feature"?

Or are there other ideas to deal with this?

Thanks a lot

Felix
Previous Topic:feature dependency error message
Next Topic:Triggering further build
Goto Forum:
  


Current Time: Sun Oct 26 06:08:24 GMT 2014

Powered by FUDForum. Page generated in 0.03909 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software