Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » NPE while exporting a product to multiple platforms
NPE while exporting a product to multiple platforms [message #604447] Fri, 29 January 2010 10:43
Victor Roldan Betancort is currently offline Victor Roldan Betancort
Messages: 524
Registered: July 2009
Senior Member
Hi all,

I'm trying to build an RCP application using Buckminster and Hudson, and
the first steps I've taken is to define a feature-based product. The
product definition validates correctly and even runs, and also exports
fine! I installed Eclipse Delta Pack for this purpose. However, when I
try to export any platform plus linux platform (i.e., win32 + linux,
macosx) at the same time, I get a NullPointerException:

C:\workspace_1.0.1\.metadata\.plugins\org.eclipse.pde.core\t emp\org.eclipse.pde.container.feature\assemble.org.eclipse.p de.container.feature.linux.gtk.x86.xml:97:
java.lang.NullPointerException

It's strange, because I can actually export to any of these platforms,
for instance, exporting Linux GTK x86 and x64 or win32 x86 + x64 + WPF
seems to work fine. The error comes when I export to different operative
systems, and one of them is Linux.

Has anyone experienced the same? Is it a known issue?

Comments are welcome.

Cheers,
VĂ­ctor.
Previous Topic:NPE while exporting a product to multiple platforms
Next Topic:how the i find the 'right' extension point?
Goto Forum:
  


Current Time: Thu Aug 28 23:39:43 EDT 2014

Powered by FUDForum. Page generated in 0.01466 seconds