Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [Acceleo] Platform URIs
[Acceleo] Platform URIs [message #61122] Tue, 12 May 2009 20:35 Go to next message
Ersin ER is currently offline Ersin ERFriend
Messages: 34
Registered: July 2009
Member
Hi,

Does Acceleo accept only registered metamodel URIs? (So can it not use
for example "platform:/resource/..." type of URIs in module
declaration?) If that's the case, are there any plans to introduce
support for other URI types?

Thanks.

--
Ersin
Re: [Acceleo] Platform URIs [message #61172 is a reply to message #61122] Wed, 13 May 2009 04:03 Go to previous messageGo to next message
Ersin ER is currently offline Ersin ERFriend
Messages: 34
Registered: July 2009
Member
Well, I have seen from a recent thread that it's the case. So I would
still like to know whether any enhancement planned for this matter.

Ersin ER wrote:
> Hi,
>
> Does Acceleo accept only registered metamodel URIs? (So can it not use
> for example "platform:/resource/..." type of URIs in module
> declaration?) If that's the case, are there any plans to introduce
> support for other URI types?
>
> Thanks.
>

Regards,
Ersin
Re: [Acceleo] Platform URIs [message #61363 is a reply to message #61172] Mon, 18 May 2009 08:37 Go to previous messageGo to next message
Laurent Goubet is currently offline Laurent GoubetFriend
Messages: 1638
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------030000020603040202010102
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit

Hi Ersin,

Sorry I let your question slip as I read it while doing something else
and forgot to answer :p.

As you mentionned in your second post, Acceleo doesn't accept platform
scheme URIs, it only accepts registered metamodel URIs ... yet. We plan
to take platform scheme URIs in the near future (i.e: not Galileo (our
0.8), but it will most probably be done for the next release). We do not
have bugzillas raised for this yet, don't hesitate to raise one of your
own for the record.

Laurent Goubet
Obeo

Ersin ER a
Re: [Acceleo] Platform URIs [message #667305 is a reply to message #61363] Wed, 27 April 2011 22:56 Go to previous messageGo to next message
radwane  is currently offline radwane Friend
Messages: 27
Registered: April 2011
Junior Member
acceleo accept file.xmi???
Re: [Acceleo] Platform URIs [message #668092 is a reply to message #61122] Tue, 03 May 2011 17:41 Go to previous message
Ed Staub is currently offline Ed StaubFriend
Messages: 16
Registered: April 2011
Junior Member
Just to close this off for other searchers for answers... the
platform:/eclipse-location
form of URI described earlier in this thread seems to work now (Helios).
Previous Topic:[ACCELEO] problem to run generator
Next Topic:Xtext
Goto Forum:
  


Current Time: Sat Nov 22 17:00:44 GMT 2014

Powered by FUDForum. Page generated in 0.02304 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software