Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » AJDT » Aspects not being weaved!?
Aspects not being weaved!? [message #61023] Tue, 17 January 2006 15:12 Go to next message
Tom Coupland is currently offline Tom CouplandFriend
Messages: 14
Registered: July 2009
Junior Member
Hidiho everybody

Was using Aspects a couple of weeks ago, when came to make a new one today
and now none of them are working at all!

I've reinstalled eclipse (i'm using JBoss-IDE 1.5RC2) and dloaded AspectJ
again, (used the auto update site
http://download.eclipse.org/technology/ajdt/31/update) and there still not
working....

The aspects are being reconised as aspects and all the options im familiar
with are availble, im using the aspect builder and running it in a aspect
config.

Can anyone help?? im getting quite frustrated here!

Cheers for any thoughts/ideas

Tom
Re: Aspects not being weaved!? [message #61048 is a reply to message #61023] Tue, 17 January 2006 16:31 Go to previous messageGo to next message
Tom Coupland is currently offline Tom CouplandFriend
Messages: 14
Registered: July 2009
Junior Member
Hi again,

Heres the AspectJ Trace (something i was not aware of!) for my project,
can anyone say whether hti si normal or?!


3:43:21 PM
============================================================ ===============================
3:43:21 PM Build kind = INCREMENTALBUILD
3:43:21 PM Project=Experiments kind of build requested
=Incremental AspectJ compilation
3:43:21 PM build: Examined delta - source file changes in required
project Experiments
3:43:22 PM Timer event: 609ms: Time to first compiled message
3:43:23 PM Timer event: 2005ms: Total time spent in AJDE
3:43:23 PM Timer event: 55ms: Create element map (10 rels in project:
Experiments)
3:43:23 PM Types affected during build = 51
3:43:23 PM Timer event: 0ms: Add markers (0 markers)
3:43:23 PM Timer event: 2243ms: Total time spent in AJBuilder.build()
4:03:08 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:03:28 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:03:51 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:11:28 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:11:31 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:14:47 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:14:51 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:18:52 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:18:55 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:19:04 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:21:47 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date


Looking forward to it......

Tom
Re: Aspects not being weaved!? [message #61072 is a reply to message #61048] Wed, 18 January 2006 09:26 Go to previous messageGo to next message
Sian January is currently offline Sian JanuaryFriend
Messages: 83
Registered: July 2009
Member
Hi Tom,

Would it be possible to post a copy of your aspect here and a class or
two that you would expect it to match against? If you do that then I
will try to reproduce the problem and find out what's going on.

Thanks,

Sian


Tom Coupland wrote:
> Hi again,
>
> Heres the AspectJ Trace (something i was not aware of!) for my project,
> can anyone say whether hti si normal or?!
>
>
> 3:43:21 PM
> ============================================================ ===============================
>
> 3:43:21 PM Build kind = INCREMENTALBUILD
> 3:43:21 PM Project=Experiments kind of build requested
> =Incremental AspectJ compilation
> 3:43:21 PM build: Examined delta - source file changes in required
> project Experiments
> 3:43:22 PM Timer event: 609ms: Time to first compiled message
> 3:43:23 PM Timer event: 2005ms: Total time spent in AJDE
> 3:43:23 PM Timer event: 55ms: Create element map (10 rels in
> project: Experiments)
> 3:43:23 PM Types affected during build = 51
> 3:43:23 PM Timer event: 0ms: Add markers (0 markers)
> 3:43:23 PM Timer event: 2243ms: Total time spent in AJBuilder.build()
> 4:03:08 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:03:28 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:03:51 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:11:28 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:11:31 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:14:47 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:14:51 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:18:52 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:18:55 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:19:04 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:21:47 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
>
>
> Looking forward to it......
> Tom
>
Re: Aspects not being weaved!? [message #61095 is a reply to message #61072] Wed, 18 January 2006 11:46 Go to previous messageGo to next message
Tom Coupland is currently offline Tom CouplandFriend
Messages: 14
Registered: July 2009
Junior Member
Hi Sian,

Thanks for the interest. Heres a little example i've knocked up....

package meta.experiments.aspects.basic;

public aspect Truer {

pointcut MethodCall() : call(public static boolean
AspectBasicTest.aMethod ());

boolean around() : MethodCall(){
return true;
}
}

package meta.experiments.aspects.basic;

public class AspectBasicTest {

public static boolean aMethod(){
return false;
}

public static void main(String[] args){
if(AspectBasicTest.aMethod()){
System.out.println("Hooray the aspects are working");
}else{
System.out.println("Rubbish aspects are broken");
}
}
}

Needless to say i get the rubbish message!! One thing i noticed was the
rels in the project have increased from 12 to 14 when i made this....

11:35:20 AM Timer event: 62ms: Create element map (14 rels in project:
Experiments)

Heres some verison info..

11:14:32 AM AJDT Plugin Startup
AJDT version: 1.3.0 for Eclipse 3.1
AspectJ Compiler version: 1.5.0
org.aspectj.ajdt.core.compiler.BuildOptions.showweavemessage s = true

Eclipse SDK

Version: 3.1.0
Build id: I20050627-1435

One thing i've jst noticed is that if i look in the plugin details for my
eclipse some of the aspectj components are labeled as 1.3 where as others
are 1.5, is this normal?? I did jst dload this using the update site

http://download.eclipse.org/technology/ajdt/31/update

Which i did after unpacking JBossIDE-1.5RC2-Bundle-linux-gtk.tar.gz and
unzipping JBossIDE-1.5RC2-ALL.zip in the eclipse dir.

I've also taken the procaution of deleting all aspectjrt.jar's that dont
live in the eclipse plugins dir.

Hope you can help me find a solution!!

Yours gratefully

Tom
Re: Aspects not being weaved!? [message #61119 is a reply to message #61095] Wed, 18 January 2006 13:30 Go to previous messageGo to next message
Sian January is currently offline Sian JanuaryFriend
Messages: 83
Registered: July 2009
Member
Hi Tom,

Ok - your test program worked for me straight away. The 1.3 and 1.5
version numbers are correct - 1.5 is the compiler version and 1.3 is
AJDT. Can I ask you a few more questions about your setup?

1. Is the project an AspectJ project and does the aspect have a
filled-in AJ icon?
2. What did you mean about deleting aspectjrt.jar? Does your project
still have aspectjrt.jar on the classpath?
3. Are there any messages in the error log view that might be relevant?
4. Does your project have any compile errors in other packages that
could be causing the build to finish early?

Thanks,

Sian


Tom Coupland wrote:
> Hi Sian,
>
> Thanks for the interest. Heres a little example i've knocked up....
>
> package meta.experiments.aspects.basic;
>
> public aspect Truer {
>
> pointcut MethodCall() : call(public static boolean
> AspectBasicTest.aMethod ());
>
> boolean around() : MethodCall(){
> return true;
> }
> }
>
> package meta.experiments.aspects.basic;
>
> public class AspectBasicTest {
>
> public static boolean aMethod(){
> return false;
> }
>
> public static void main(String[] args){
> if(AspectBasicTest.aMethod()){
> System.out.println("Hooray the aspects are working");
> }else{
> System.out.println("Rubbish aspects are broken");
> }
> }
> }
>
> Needless to say i get the rubbish message!! One thing i noticed was the
> rels in the project have increased from 12 to 14 when i made this....
>
> 11:35:20 AM Timer event: 62ms: Create element map (14 rels in
> project: Experiments)
>
> Heres some verison info..
>
> 11:14:32 AM AJDT Plugin Startup
> AJDT version: 1.3.0 for Eclipse 3.1
> AspectJ Compiler version: 1.5.0
> org.aspectj.ajdt.core.compiler.BuildOptions.showweavemessage s = true
>
> Eclipse SDK
>
> Version: 3.1.0
> Build id: I20050627-1435
>
> One thing i've jst noticed is that if i look in the plugin details for
> my eclipse some of the aspectj components are labeled as 1.3 where as
> others are 1.5, is this normal?? I did jst dload this using the update site
> http://download.eclipse.org/technology/ajdt/31/update
>
> Which i did after unpacking JBossIDE-1.5RC2-Bundle-linux-gtk.tar.gz and
> unzipping JBossIDE-1.5RC2-ALL.zip in the eclipse dir.
>
> I've also taken the procaution of deleting all aspectjrt.jar's that dont
> live in the eclipse plugins dir.
>
> Hope you can help me find a solution!!
>
> Yours gratefully
>
> Tom
>
Re: Aspects not being weaved!? [message #61143 is a reply to message #61119] Wed, 18 January 2006 17:20 Go to previous messageGo to next message
Tom Coupland is currently offline Tom CouplandFriend
Messages: 14
Registered: July 2009
Junior Member
Hi Sian,

Thanks for trying that out, nice to be sure!

Answers to quesitons

1. Yes to both. Got a little 'AJ' on the project and on the class too.
2. I had aspectJ in my boxes java installation, eclipse has its own, was
worried there might hav been some mix up so deleted it.
3. Far from getting any errors im seeing messages like this...

0 Join point 'method-call(boolean
meta.experiments.aspects.basic.AspectBasicTest.aMethod())' in Type
'meta.experiments.aspects.basic.AspectBasicTest' (AspectBasicTest.java:10)
advised by around advice from 'meta.experiments.aspects.basic.Truer'
(Truer.aj:7) Experiments January 18, 2006 5:10:25 PM

Got 1 of these 'info' messages in the Problems log for each of my aspect
joins. Theres no mention of a problem in the errLog view.

4. Was just about to answer this one with there was, but i got rid of
it.....

Checked and now its all working, feel abit sheepish now..........


Had no idea that having an error in a complete unrelated package wld cause
it to do that. Sounds abit troppy i know, but won't some sort of message
like "Theres an error in package X, aspectJ will not work at all" be
helpful? Am constantly running my proj with errors in (is quite large
now), so did'nt think it was a issue at all!

Owell, thanks allot Sian for working though something as trivial as this
with me.

Thanks allot!

Tom :)
Re: Aspects not being weaved!? [message #61167 is a reply to message #61143] Thu, 19 January 2006 10:54 Go to previous message
Sian January is currently offline Sian JanuaryFriend
Messages: 83
Registered: July 2009
Member
Hi Tom,

I'm glad you got it sorted in the end. The suggestion you made about
having some kind of error if the project hasn't been woven does make
sense. A compiler error would probably be best (in the problems view)
rather than a pop-up or anything else. Why don't you raise an AspectJ
enhancement - https://bugs.eclipse.org/bugs/enter_bug.cgi?product=AspectJ

Sian


Tom Coupland wrote:
> Hi Sian,
>
> Thanks for trying that out, nice to be sure!
>
> Answers to quesitons
>
> 1. Yes to both. Got a little 'AJ' on the project and on the class too.
> 2. I had aspectJ in my boxes java installation, eclipse has its own, was
> worried there might hav been some mix up so deleted it.
> 3. Far from getting any errors im seeing messages like this...
>
> 0 Join point 'method-call(boolean
> meta.experiments.aspects.basic.AspectBasicTest.aMethod())' in Type
> 'meta.experiments.aspects.basic.AspectBasicTest'
> (AspectBasicTest.java:10) advised by around advice from
> 'meta.experiments.aspects.basic.Truer' (Truer.aj:7)
> Experiments January 18, 2006 5:10:25 PM
>
> Got 1 of these 'info' messages in the Problems log for each of my aspect
> joins. Theres no mention of a problem in the errLog view.
>
> 4. Was just about to answer this one with there was, but i got rid of
> it.....
> Checked and now its all working, feel abit sheepish now..........
>
> Had no idea that having an error in a complete unrelated package wld
> cause it to do that. Sounds abit troppy i know, but won't some sort of
> message like "Theres an error in package X, aspectJ will not work at
> all" be helpful? Am constantly running my proj with errors in (is quite
> large now), so did'nt think it was a issue at all!
>
> Owell, thanks allot Sian for working though something as trivial as this
> with me.
>
> Thanks allot!
>
> Tom :)
>
>
Re: Aspects not being weaved!? [message #591858 is a reply to message #61023] Tue, 17 January 2006 16:31 Go to previous message
Tom Coupland is currently offline Tom CouplandFriend
Messages: 14
Registered: July 2009
Junior Member
Hi again,

Heres the AspectJ Trace (something i was not aware of!) for my project,
can anyone say whether hti si normal or?!


3:43:21 PM
============================================================ ===============================
3:43:21 PM Build kind = INCREMENTALBUILD
3:43:21 PM Project=Experiments kind of build requested
=Incremental AspectJ compilation
3:43:21 PM build: Examined delta - source file changes in required
project Experiments
3:43:22 PM Timer event: 609ms: Time to first compiled message
3:43:23 PM Timer event: 2005ms: Total time spent in AJDE
3:43:23 PM Timer event: 55ms: Create element map (10 rels in project:
Experiments)
3:43:23 PM Types affected during build = 51
3:43:23 PM Timer event: 0ms: Add markers (0 markers)
3:43:23 PM Timer event: 2243ms: Total time spent in AJBuilder.build()
4:03:08 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:03:28 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:03:51 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:11:28 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:11:31 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:14:47 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:14:51 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:18:52 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:18:55 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:19:04 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date
4:21:47 PM AJDTContentProvider.selectionChanged(): Marking visualiser
content as out of date


Looking forward to it......

Tom
Re: Aspects not being weaved!? [message #591865 is a reply to message #61048] Wed, 18 January 2006 09:26 Go to previous message
Sian January is currently offline Sian JanuaryFriend
Messages: 83
Registered: July 2009
Member
Hi Tom,

Would it be possible to post a copy of your aspect here and a class or
two that you would expect it to match against? If you do that then I
will try to reproduce the problem and find out what's going on.

Thanks,

Sian


Tom Coupland wrote:
> Hi again,
>
> Heres the AspectJ Trace (something i was not aware of!) for my project,
> can anyone say whether hti si normal or?!
>
>
> 3:43:21 PM
> ============================================================ ===============================
>
> 3:43:21 PM Build kind = INCREMENTALBUILD
> 3:43:21 PM Project=Experiments kind of build requested
> =Incremental AspectJ compilation
> 3:43:21 PM build: Examined delta - source file changes in required
> project Experiments
> 3:43:22 PM Timer event: 609ms: Time to first compiled message
> 3:43:23 PM Timer event: 2005ms: Total time spent in AJDE
> 3:43:23 PM Timer event: 55ms: Create element map (10 rels in
> project: Experiments)
> 3:43:23 PM Types affected during build = 51
> 3:43:23 PM Timer event: 0ms: Add markers (0 markers)
> 3:43:23 PM Timer event: 2243ms: Total time spent in AJBuilder.build()
> 4:03:08 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:03:28 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:03:51 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:11:28 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:11:31 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:14:47 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:14:51 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:18:52 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:18:55 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:19:04 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
> 4:21:47 PM AJDTContentProvider.selectionChanged(): Marking
> visualiser content as out of date
>
>
> Looking forward to it......
> Tom
>
Re: Aspects not being weaved!? [message #591871 is a reply to message #61072] Wed, 18 January 2006 11:46 Go to previous message
Tom Coupland is currently offline Tom CouplandFriend
Messages: 14
Registered: July 2009
Junior Member
Hi Sian,

Thanks for the interest. Heres a little example i've knocked up....

package meta.experiments.aspects.basic;

public aspect Truer {

pointcut MethodCall() : call(public static boolean
AspectBasicTest.aMethod ());

boolean around() : MethodCall(){
return true;
}
}

package meta.experiments.aspects.basic;

public class AspectBasicTest {

public static boolean aMethod(){
return false;
}

public static void main(String[] args){
if(AspectBasicTest.aMethod()){
System.out.println("Hooray the aspects are working");
}else{
System.out.println("Rubbish aspects are broken");
}
}
}

Needless to say i get the rubbish message!! One thing i noticed was the
rels in the project have increased from 12 to 14 when i made this....

11:35:20 AM Timer event: 62ms: Create element map (14 rels in project:
Experiments)

Heres some verison info..

11:14:32 AM AJDT Plugin Startup
AJDT version: 1.3.0 for Eclipse 3.1
AspectJ Compiler version: 1.5.0
org.aspectj.ajdt.core.compiler.BuildOptions.showweavemessage s = true

Eclipse SDK

Version: 3.1.0
Build id: I20050627-1435

One thing i've jst noticed is that if i look in the plugin details for my
eclipse some of the aspectj components are labeled as 1.3 where as others
are 1.5, is this normal?? I did jst dload this using the update site

http://download.eclipse.org/technology/ajdt/31/update

Which i did after unpacking JBossIDE-1.5RC2-Bundle-linux-gtk.tar.gz and
unzipping JBossIDE-1.5RC2-ALL.zip in the eclipse dir.

I've also taken the procaution of deleting all aspectjrt.jar's that dont
live in the eclipse plugins dir.

Hope you can help me find a solution!!

Yours gratefully

Tom
Re: Aspects not being weaved!? [message #591878 is a reply to message #61095] Wed, 18 January 2006 13:30 Go to previous message
Sian January is currently offline Sian JanuaryFriend
Messages: 83
Registered: July 2009
Member
Hi Tom,

Ok - your test program worked for me straight away. The 1.3 and 1.5
version numbers are correct - 1.5 is the compiler version and 1.3 is
AJDT. Can I ask you a few more questions about your setup?

1. Is the project an AspectJ project and does the aspect have a
filled-in AJ icon?
2. What did you mean about deleting aspectjrt.jar? Does your project
still have aspectjrt.jar on the classpath?
3. Are there any messages in the error log view that might be relevant?
4. Does your project have any compile errors in other packages that
could be causing the build to finish early?

Thanks,

Sian


Tom Coupland wrote:
> Hi Sian,
>
> Thanks for the interest. Heres a little example i've knocked up....
>
> package meta.experiments.aspects.basic;
>
> public aspect Truer {
>
> pointcut MethodCall() : call(public static boolean
> AspectBasicTest.aMethod ());
>
> boolean around() : MethodCall(){
> return true;
> }
> }
>
> package meta.experiments.aspects.basic;
>
> public class AspectBasicTest {
>
> public static boolean aMethod(){
> return false;
> }
>
> public static void main(String[] args){
> if(AspectBasicTest.aMethod()){
> System.out.println("Hooray the aspects are working");
> }else{
> System.out.println("Rubbish aspects are broken");
> }
> }
> }
>
> Needless to say i get the rubbish message!! One thing i noticed was the
> rels in the project have increased from 12 to 14 when i made this....
>
> 11:35:20 AM Timer event: 62ms: Create element map (14 rels in
> project: Experiments)
>
> Heres some verison info..
>
> 11:14:32 AM AJDT Plugin Startup
> AJDT version: 1.3.0 for Eclipse 3.1
> AspectJ Compiler version: 1.5.0
> org.aspectj.ajdt.core.compiler.BuildOptions.showweavemessage s = true
>
> Eclipse SDK
>
> Version: 3.1.0
> Build id: I20050627-1435
>
> One thing i've jst noticed is that if i look in the plugin details for
> my eclipse some of the aspectj components are labeled as 1.3 where as
> others are 1.5, is this normal?? I did jst dload this using the update site
> http://download.eclipse.org/technology/ajdt/31/update
>
> Which i did after unpacking JBossIDE-1.5RC2-Bundle-linux-gtk.tar.gz and
> unzipping JBossIDE-1.5RC2-ALL.zip in the eclipse dir.
>
> I've also taken the procaution of deleting all aspectjrt.jar's that dont
> live in the eclipse plugins dir.
>
> Hope you can help me find a solution!!
>
> Yours gratefully
>
> Tom
>
Re: Aspects not being weaved!? [message #591888 is a reply to message #61119] Wed, 18 January 2006 17:20 Go to previous message
Tom Coupland is currently offline Tom CouplandFriend
Messages: 14
Registered: July 2009
Junior Member
Hi Sian,

Thanks for trying that out, nice to be sure!

Answers to quesitons

1. Yes to both. Got a little 'AJ' on the project and on the class too.
2. I had aspectJ in my boxes java installation, eclipse has its own, was
worried there might hav been some mix up so deleted it.
3. Far from getting any errors im seeing messages like this...

0 Join point 'method-call(boolean
meta.experiments.aspects.basic.AspectBasicTest.aMethod())' in Type
'meta.experiments.aspects.basic.AspectBasicTest' (AspectBasicTest.java:10)
advised by around advice from 'meta.experiments.aspects.basic.Truer'
(Truer.aj:7) Experiments January 18, 2006 5:10:25 PM

Got 1 of these 'info' messages in the Problems log for each of my aspect
joins. Theres no mention of a problem in the errLog view.

4. Was just about to answer this one with there was, but i got rid of
it.....

Checked and now its all working, feel abit sheepish now..........


Had no idea that having an error in a complete unrelated package wld cause
it to do that. Sounds abit troppy i know, but won't some sort of message
like "Theres an error in package X, aspectJ will not work at all" be
helpful? Am constantly running my proj with errors in (is quite large
now), so did'nt think it was a issue at all!

Owell, thanks allot Sian for working though something as trivial as this
with me.

Thanks allot!

Tom :)
Re: Aspects not being weaved!? [message #591897 is a reply to message #61143] Thu, 19 January 2006 10:54 Go to previous message
Sian January is currently offline Sian JanuaryFriend
Messages: 83
Registered: July 2009
Member
Hi Tom,

I'm glad you got it sorted in the end. The suggestion you made about
having some kind of error if the project hasn't been woven does make
sense. A compiler error would probably be best (in the problems view)
rather than a pop-up or anything else. Why don't you raise an AspectJ
enhancement - https://bugs.eclipse.org/bugs/enter_bug.cgi?product=AspectJ

Sian


Tom Coupland wrote:
> Hi Sian,
>
> Thanks for trying that out, nice to be sure!
>
> Answers to quesitons
>
> 1. Yes to both. Got a little 'AJ' on the project and on the class too.
> 2. I had aspectJ in my boxes java installation, eclipse has its own, was
> worried there might hav been some mix up so deleted it.
> 3. Far from getting any errors im seeing messages like this...
>
> 0 Join point 'method-call(boolean
> meta.experiments.aspects.basic.AspectBasicTest.aMethod())' in Type
> 'meta.experiments.aspects.basic.AspectBasicTest'
> (AspectBasicTest.java:10) advised by around advice from
> 'meta.experiments.aspects.basic.Truer' (Truer.aj:7)
> Experiments January 18, 2006 5:10:25 PM
>
> Got 1 of these 'info' messages in the Problems log for each of my aspect
> joins. Theres no mention of a problem in the errLog view.
>
> 4. Was just about to answer this one with there was, but i got rid of
> it.....
> Checked and now its all working, feel abit sheepish now..........
>
> Had no idea that having an error in a complete unrelated package wld
> cause it to do that. Sounds abit troppy i know, but won't some sort of
> message like "Theres an error in package X, aspectJ will not work at
> all" be helpful? Am constantly running my proj with errors in (is quite
> large now), so did'nt think it was a issue at all!
>
> Owell, thanks allot Sian for working though something as trivial as this
> with me.
>
> Thanks allot!
>
> Tom :)
>
>
Previous Topic:Aspects not being weaved!?
Next Topic:Can ajdt works with product's export?
Goto Forum:
  


Current Time: Fri Dec 19 06:46:21 GMT 2014

Powered by FUDForum. Page generated in 0.13269 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software