Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » Mylyn 3.4 Ganymede apache.logging dep problem
Mylyn 3.4 Ganymede apache.logging dep problem [message #601557] Wed, 30 June 2010 04:56 Go to next message
Warwick Baker is currently offline Warwick Baker
Messages: 16
Registered: June 2010
Junior Member
I use Mylyn within an ganymede eclipse installation. Have been using 3.3.3 happily. Tried to do an update seeing that 3.4 is available.

Fails to install with an unsatisfied dependency on apache.logging ...

Quote:
> Cannot find a solution satisfying the following requirements org.apache.commons.logging [1.0.4.v201005080501].


For the life of me I can't figure out how to fix this dependency problem (including just downloading the jar and putting it in the eclipse plugins dir).

Any help appreciated ...
Re: Mylyn 3.4 Ganymede apache.logging dep problem [message #601569 is a reply to message #601557] Wed, 30 June 2010 22:39 Go to previous messageGo to next message
Warwick Baker is currently offline Warwick Baker
Messages: 16
Registered: June 2010
Junior Member
Is this comment from the 3.4RC1 announcement still applicable ...?

Quote:
> Eclipse 3.4 users, please note that the weekly site is now a composite site
> which is not supported on Eclipse 3.4. You can use the archive site
> directly:
>
> download.eclipse.org/tools/mylyn/update-archive/3.4.0/I20100 604-2200/e3.4/
Re: Mylyn 3.4 Ganymede apache.logging dep problem [message #601578 is a reply to message #601557] Thu, 01 July 2010 00:35 Go to previous message
Steffen Pingel is currently offline Steffen Pingel
Messages: 706
Registered: July 2009
Senior Member
It is very likely that the error is not directly related to
org.apache.commons.logging but caused by a conflict or failed resolution of
other bundles.

Which repository are you using to install Mylyn?

Steffen


Warwick Baker wrote:

> I use Mylyn within an ganymede eclipse installation. Have been using 3.3.3
> happily. Tried to do an update seeing that 3.4 is available.
>
> Fails to install with an unsatisfied dependency on apache.logging ...
>
> Quote:
>> Cannot find a solution satisfying the following requirements
>> org.apache.commons.logging [1.0.4.v201005080501].
>
>
> For the life of me I can't figure out how to fix this dependency problem
> (including just downloading the jar and putting it in the eclipse plugins
> dir).
>
> Any help appreciated ...

--
Steffen Pingel
Committer, http://eclipse.org/mylyn
Senior Developer, http://tasktop.com
Previous Topic:New versions do not show up in Bugzilla editor
Next Topic:Missing component?
Goto Forum:
  


Current Time: Tue Sep 30 19:53:02 GMT 2014

Powered by FUDForum. Page generated in 0.02454 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software