Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » [Mediawiki] Errors with mediawiki-to-eclipse-help
[Mediawiki] Errors with mediawiki-to-eclipse-help [message #601287] Wed, 28 April 2010 15:43 Go to next message
Nicolas Guyomar is currently offline Nicolas Guyomar
Messages: 29
Registered: February 2010
Location: Nantes (France)
Junior Member
Hi,

I'm getting the following error for each templates on our wiki pages using template, like : http://wiki.eclipse.org/MoDisco/Components/ModelBrowser
( the tabItems : Overview, Documentation 0.7, 0.8 ... )


[mediawiki-to-eclipse-help] 28 avr. 2010 17:32:55 org.eclipse.mylyn.internal.wikitext.mediawiki.core.WikiTempl ateResolver resolveTemplate
[mediawiki-to-eclipse-help] ATTENTION: Cannot read from http://wiki.eclipse.org/index.php?title=Template%3Amodiscoja vatabs&action=raw: http://wiki.eclipse.org/index.php?title=Template%3Amodiscoja vatabs&action=raw
[mediawiki-to-eclipse-help] java.io.FileNotFoundException: http://wiki.eclipse.org/index.php?title=Template%3Amodiscoja vatabs&action=raw
[mediawiki-to-eclipse-help] at sun.net.www.protocol.http.HttpURLConnection.getInputStream(U nknown Source)

and so on ....


This error is not a problem for my help content generation, but quite annoying because it fills the log file.

I had a quick look on the Eclipse wiki, it seems like not a lot a projects are using those templates.

Could it be ignore ? I insist on the fact that the help content is very well generated.

Regards

Nicolas


Re: [Mediawiki] Errors with mediawiki-to-eclipse-help [message #601305 is a reply to message #601287] Thu, 29 April 2010 05:49 Go to previous message
David Green is currently offline David Green
Messages: 96
Registered: July 2009
Member
On 10-04-28 8:43 AM, Nicolas Guyomar wrote:
> Hi,
>
> I'm getting the following error for each templates on our wiki pages
> using template, like :
> http://wiki.eclipse.org/MoDisco/Components/ModelBrowser
> ( the tabItems : Overview, Documentation 0.7, 0.8 ... )
>
>
> [mediawiki-to-eclipse-help] 28 avr. 2010 17:32:55
> org.eclipse.mylyn.internal.wikitext.mediawiki.core.WikiTempl ateResolver
> resolveTemplate
> [mediawiki-to-eclipse-help] ATTENTION: Cannot read from
> http://wiki.eclipse.org/index.php?title=Template%3Amodiscoja vatabs&action=raw:
> http://wiki.eclipse.org/index.php?title=Template%3Amodiscoja vatabs&action=raw
>
> [mediawiki-to-eclipse-help] java.io.FileNotFoundException:
> http://wiki.eclipse.org/index.php?title=Template%3Amodiscoja vatabs&action=raw
>
> [mediawiki-to-eclipse-help] at
> sun.net.www.protocol.http.HttpURLConnection.getInputStream(U nknown Source)
>
> and so on ....
>
>
> This error is not a problem for my help content generation, but quite
> annoying because it fills the log file.

You can exclude template content by adding the following to your Ant build script:

<mediawiki-to-eclipse-help
templateExcludes="*modiscojavatabs*"

Templates that are excluded using this mechanism produce no output. From the documentation:

Indicate MediaWiki template names to exclude. A comma-delimited list of names, may include ‘*’ wildcards. Defaults to
null. Example: bug, navigationHeader

Please let me know if that works for you.

Regards,

David

> I had a quick look on the Eclipse wiki, it seems like not a lot a
> projects are using those templates.
>
> Could it be ignore ? I insist on the fact that the help content is very
> well generated.
>
> Regards
>
> Nicolas
Previous Topic:[wikitext] Embedding links, etc..
Next Topic:weekly update site broken?
Goto Forum:
  


Current Time: Sat Oct 25 15:19:59 GMT 2014

Powered by FUDForum. Page generated in 0.02153 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software