Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » Re: How to install new Version of Jet (aka Jet2) ?
Re: How to install new Version of Jet (aka Jet2) ? [message #60555] Sun, 10 May 2009 21:38 Go to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 26289
Registered: July 2009
Senior Member
Usal,

Best to ask about it on the M2T newsgroup, which I've added to the "to"
list of the reply, so no need to repost.


Usul wrote:
> Hi,
>
> as I understand, there are two versions of JET. There is the old one,
> and the new one, called JET2 which for example has some kind of
> protected regions,can work with an EMF-metamodel and has tags like
> c:get or c:iterate.
>
> But I cant seem to find that version. I tried installing JET from the
> Eclipse EMF-project Update-Manager:
> http://download.eclipse.org/modeling/m2t/updates/milestones/ . But I
> still dont have File > New > Other > EMFT JET Transformations.
>
>
> thank you for any hint
>
Re: How to install new Version of Jet (aka Jet2) ? [message #60912 is a reply to message #60555] Mon, 11 May 2009 12:51 Go to previous messageGo to next message
Paul Elder is currently offline Paul ElderFriend
Messages: 849
Registered: July 2009
Senior Member
>
> Usul wrote:
>> Hi,
>>
>> as I understand, there are two versions of JET. There is the old one,
>> and the new one, called JET2 which for example has some kind of
>> protected regions,can work with an EMF-metamodel and has tags like
>> c:get or c:iterate.
>>
>> But I cant seem to find that version. I tried installing JET from the
>> Eclipse EMF-project Update-Manager:
>> http://download.eclipse.org/modeling/m2t/updates/milestones/ . But I
>> still dont have File > New > Other > EMFT JET Transformations.
>>

First, try the new project wizard instead of the new file wizard. Do
File > New > Project from the menu.

Also, a couple of releases ago, EMFT JET (aka JET2) moved from the EMFT
project to the M2T (model-to-text) project. At that point, I removed the
EMFT prefix from strings (rather that force yet another meaningless
acronym (M2T) on users). So, look for JET Transformation Project.


Also, be aware the Galileo co-ordinated release has started using
'capabilities' to restrict the amount of UI elements you initially see.
You may have to check the 'Show All Wizards' box on the New Project
wizard to see JET transformations.

>>
>> thank you for any hint
>>

Hope this help,

Paul
Re: How to install new Version of Jet (aka Jet2) ? [message #60933 is a reply to message #60912] Mon, 11 May 2009 17:07 Go to previous message
No real name is currently offline No real nameFriend
Messages: 61
Registered: July 2009
Member
thank you - I feel stupid ;-)
Previous Topic:Correct use of workaround for namespace handling?
Next Topic:c:include troubles
Goto Forum:
  


Current Time: Mon Dec 22 21:26:12 GMT 2014

Powered by FUDForum. Page generated in 0.02640 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software