Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » AJDT » How to get Java 1.5, maven 1.0.2 and aspectj 1.5 to work together
How to get Java 1.5, maven 1.0.2 and aspectj 1.5 to work together [message #60505] Wed, 11 January 2006 14:41 Go to next message
Eclipse User
Originally posted by: skuo.eharmony.com

I have an maven 1.0.2 based project that is compiling well under jdk
1.4.2_07 and aspectj 1.5. However, when I changed the java compiler to
jdk 1.5.0_04, I got the following errors. The interesting part was that
eclipse 3.1.1 was perfectly happy with these files but they would not
compile under maven 1.0.2. I have a bunch of jelly code in maven.xml that
would have to change to work under maven 2.0 that I perfer not to do right
now. It's also not clear whether aspectj plugin works for maven 2.0.

Thanks in advance for all your help.


java:prepare-filesystem:
[mkdir] Created dir: /home/skuo/sandbox/matchmaker/target/classes
warning couldn't find aspectjrt.jar on classpath, checked:

/home/skuo/sandbox/matchmaker/src/java/com/eharmony/matchmak er/common/jms/JMSQueueStats.java:354
error Unhandled exception type IOException
outputBuffer.append(c);
^^^^^^^^^^^^^
/home/skuo/sandbox/matchmaker/src/java/com/eharmony/matchmak er/common/hibernate/HibernateUtils.java:79
error The type AbstractStringBuilder is not visible
StringBuffer logMessage = new StringBuffer().append("Overriding Hibernate
properties with contents of ")

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ ^^^^^
Re: How to get Java 1.5, maven 1.0.2 and aspectj 1.5 to work together [message #60525 is a reply to message #60505] Wed, 11 January 2006 16:18 Go to previous messageGo to next message
Eclipse User
Originally posted by: skuo.eharmony.com

After more research, I read the problem with AbstractStringBuilder is
caused by the comipler being 1.4. In this case, the compiler in question
the the <ant:iajc/> compiler which only support 1.3 and 1.4.

Is there anyway to download the apsectj-1.5.0.jar and have <ant:iajc/> use
this instead?
Re: How to get Java 1.5, maven 1.0.2 and aspectj 1.5 to work together [message #60541 is a reply to message #60525] Wed, 11 January 2006 20:14 Go to previous message
Eclipse User
Originally posted by: skuo.eharmony.com

The easiest way to get around this is to:

(1) modify ~/.maven/cache/maven-aspectj-plugin-3.2/project.xml as followed

<dependency>
<groupId>aspectj</groupId>
<artifactId>aspectjrt</artifactId>
<version>1.5.0</version>
</dependency>
<dependency>
<groupId>aspectj</groupId>
<artifactId>aspectjtools</artifactId>
<version>1.5.0</version>
</dependency>

(2) copy aspectjrt-1.5.0.jar and aspectjtools-1.5.0.jar to
~/.maven/respository/aspectj/jars.

(3) Add

maven.aspectj.source=1.4 in project.properties
Re: How to get Java 1.5, maven 1.0.2 and aspectj 1.5 to work together [message #591771 is a reply to message #60505] Wed, 11 January 2006 16:18 Go to previous message
Steve Kuo is currently offline Steve Kuo
Messages: 14
Registered: July 2009
Junior Member
After more research, I read the problem with AbstractStringBuilder is
caused by the comipler being 1.4. In this case, the compiler in question
the the <ant:iajc/> compiler which only support 1.3 and 1.4.

Is there anyway to download the apsectj-1.5.0.jar and have <ant:iajc/> use
this instead?
Re: How to get Java 1.5, maven 1.0.2 and aspectj 1.5 to work together [message #591785 is a reply to message #60525] Wed, 11 January 2006 20:14 Go to previous message
Steve Kuo is currently offline Steve Kuo
Messages: 14
Registered: July 2009
Junior Member
The easiest way to get around this is to:

(1) modify ~/.maven/cache/maven-aspectj-plugin-3.2/project.xml as followed

<dependency>
<groupId>aspectj</groupId>
<artifactId>aspectjrt</artifactId>
<version>1.5.0</version>
</dependency>
<dependency>
<groupId>aspectj</groupId>
<artifactId>aspectjtools</artifactId>
<version>1.5.0</version>
</dependency>

(2) copy aspectjrt-1.5.0.jar and aspectjtools-1.5.0.jar to
~/.maven/respository/aspectj/jars.

(3) Add

maven.aspectj.source=1.4 in project.properties
Previous Topic:How to get Java 1.5, maven 1.0.2 and aspectj 1.5 to work together
Next Topic:AJCompilationUnit question.
Goto Forum:
  


Current Time: Tue Jul 22 17:46:59 EDT 2014

Powered by FUDForum. Page generated in 0.03197 seconds