Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » [Epsilon - EOL] Cloning model elements
[Epsilon - EOL] Cloning model elements [message #593386] Wed, 01 September 2010 03:47 Go to next message
ModelingNewbie is currently offline ModelingNewbie
Messages: 7
Registered: August 2010
Junior Member
Hi,

I'm using EOL to modify GMF tool, graph and mapping model generated by Eugenia. In the graph model I want to copy a FigureDescriptor including all containment references.

For this purpose, I tried to use the clone functionality from the clone example ( http://www.eclipse.org/gmt/epsilon/examples/index.php?exampl e=org.eclipse.epsilon.examples.clone) but it does not work because there is a runtime error at the first line of the EOL script:

var emfTool = new Native("org.eclipse.epsilon.emc.emf.tools.EmfTool");
var ecoreUtil = emfTool.ecoreUtil;


I get the following error messeage:
Type 'org.eclipse.epsilon.emc.emf.tools.EmfTool' not found (...)

Any ideas what the problem is?
The class EmfTool is available in the plugin folder (plugin version 0.8.9.201004151115)!

Many Thanks
Re: [Epsilon - EOL] Cloning model elements [message #593398 is a reply to message #593386] Wed, 01 September 2010 06:03 Go to previous message
Dimitrios Kolovos is currently offline Dimitrios Kolovos
Messages: 1776
Registered: July 2009
Senior Member
Hi,

This appears to be a bug. Could you please file a bug report using the
link below and we'll fix this and roll out a new interim release shortly.

https://bugs.eclipse.org/bugs/enter_bug.cgi?product=GMT& component=Epsilon

Cheers,
Dimitris


On 01/09/2010 08:47, ModelingNewbie wrote:
> Hi,
>
> I'm using EOL to modify GMF tool, graph and mapping model generated by
> Eugenia. In the graph model I want to copy a FigureDescriptor including
> all containment references.
>
> For this purpose, I tried to use the clone functionality from the clone
> example
> ( http://www.eclipse.org/gmt/epsilon/examples/index.php?exampl e=org.eclipse.epsilon.examples.clone)
> but it does not work because there is a runtime error at the first line
> of the EOL script:
>
> var emfTool = new Native("org.eclipse.epsilon.emc.emf.tools.EmfTool");
> var ecoreUtil = emfTool.ecoreUtil;
>
>
> I get the following error messeage:
> Type 'org.eclipse.epsilon.emc.emf.tools.EmfTool' not found (...)
>
> Any ideas what the problem is?
> The class EmfTool is available in the plugin folder (plugin version
> 0.8.9.201004151115)!
>
> Many Thanks
>
>
Previous Topic:[Epsilon - EOL] Cloning model elements
Next Topic:Validation problems.
Goto Forum:
  


Current Time: Wed Apr 16 03:25:34 EDT 2014

Powered by FUDForum. Page generated in 0.02672 seconds