Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Uses constraint when adding org.springframework.spring
Uses constraint when adding org.springframework.spring [message #592823] Thu, 29 July 2010 18:09
Anthony is currently offline Anthony
Messages: 38
Registered: July 2010
Member
Hi,

I'm trying to get my project into OSGI. I'm going through the tutorials on the DM server docs and have come up with issue as soon as I add the org.springframework.spring jar.


Resolver report:
Uses violation: <Import-Package: org.springframework.web.servlet.view.freemarker; version="0.0.0"> in bundle <org.springframework.showcase.formtags-shared-libs_0.0.0>
Resolver reported uses conflict for import constrained to bundle <org.springframework.web.servlet> constrained bundle version range "[3.0.0.RELEASE,3.0.0.RELEASE]"
com.springsource.kernel.osgi.framework.UnableToSatisfyBundle DependenciesException: Unable to satisfy dependencies of bundle 'org.springframework.showcase.formtags-shared-libs' at version '0.0.0': Cannot resolve: org.springframework.showcase.formtags-shared-libs
Resolver report:
Uses violation: <Import-Package: org.springframework.web.servlet.view.freemarker; version="0.0.0"> in bundle <org.springframework.showcase.formtags-shared-libs_0.0.0>
Resolver reported uses conflict for import constrained to bundle <org.springframework.web.servlet> constrained bundle version range "[3.0.0.RELEASE,3.0.0.RELEASE]"


I don't understand why this issue would be occuring, this is a package that is being exported by the jar, so why is there a uses constraint and how can I get rid of it, it's driving me up the wall.
Previous Topic:STS and PAR deployment
Next Topic:Uses constraint when adding org.springframework.spring
Goto Forum:
  


Current Time: Mon Jul 28 16:43:59 EDT 2014

Powered by FUDForum. Page generated in 0.01563 seconds