Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » AJDT » J2ME
J2ME [message #592434] Fri, 03 March 2006 21:09
John Hunt is currently offline John Hunt
Messages: 2
Registered: July 2009
Junior Member
I am having difficulty getting aspectj to work with a J2ME project. I
have tried a number of ways. The way that came the closest was:
Start with a working J2ME project
Right click on project and select convert to aspectj project

The result seems to build correctly.
If I run the J2ME code without making changes it comes up correctly in the
emulator.
If a create a sample aspectj app in the same project as the J2ME code, it
builds and runs correctly.

BUT, when I add an aspect to my J2ME code it:
Builds although it does indicate a problem with the project by showing a
red X on the project folder, but does not flag any of the files making up
the project with an X.
It runs the app in the emulator.
It recognizes a match specified by the pointcut.
When it attempts to execute the advice associated with the pointcut it
gives a runtime error:
java.lang.NoClassDefFoundError: org/aspectj/lang/NoAspectBoundException

Interestingly if I leave the pointcut but comment out the advice the
application runs fine in the emulator.

This is creating a major crimp in progress on my dissertation. Would
greatly appreciate advice on how to get J2ME and AspectJ to work together
in Eclipse.
BTW: I updated all the Eclipse packages in my enviroment yesterday. So I
believe I am latest and greatest for my Eclipse environment
Previous Topic:Multi-dirrectory output
Next Topic:Using weaved plugin in eclipse
Goto Forum:
  


Current Time: Sat Apr 19 13:09:19 EDT 2014

Powered by FUDForum. Page generated in 0.03014 seconds