Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Amalgam » Problem while building 'Requirements DSL Sample Project' from DSLTK
Problem while building 'Requirements DSL Sample Project' from DSLTK [message #589268] Fri, 23 July 2010 12:45
Pablo  uñoz is currently offline Pablo uñoz
Messages: 4
Registered: July 2010
Junior Member
Hi,

I'm trying to follow the examples of the Eclipse Modeling Project book and I've found several errors while building the 'Requirements DSL Sample Project'.

The first one is that at the end of the compilation I receive an error dialog with the following text:


'Building workspace' has encountered a problem.
Errors ocurred during the build.


Errors running builder 'QVT Operational Builder' on project 'org.eclipse.amalgam.examples.dsl.bpmn'.
Operational QVT: Unexisting source container
Unexisting source container
Operational QVT: Unexisting source container
Unexisting source container
Errors running builder 'QVT Operational Builder' on project 'org.eclipse.amalgam.examples.dsl.oocore'.
Operational QVT: Unexisting source container
Unexisting source container
Operational QVT: Unexisting source container
Unexisting source container


Later there are several errors in the 'org.eclipse.amalgam.examples.dsl.dnc' and 'org.eclipse.amalgam.examples.dsl.mindmap' projects of the workspace, concretely in the following files:

/org.eclipse.amalgam.examples.dsl.dnc/templates-deploy/dnc2j ava.xpt
/org.eclipse.amalgam.examples.dsl.dnc/templates-diagram/aspe cts/diagram/editparts/NodeEditPart.xpt
/org.eclipse.amalgam.examples.dsl.dnc/templates-diagram/aspe cts/xpt/Externalizer.xpt
/org.eclipse.amalgam.examples.dsl.dnc/templates-diagram/xpt/ diagram/preferences/AppearancePreferencePage.xpt
/org.eclipse.amalgam.examples.dsl.dnc/templates-diagram/xpt/ diagram/preferences/PreferenceInitializer.xpt
/org.eclipse.amalgam.examples.dsl.mindmap/transformations/mi ndmap2xhtml.qvto

I'm using the DSLTK distribution downloaded from here: http://www.eclipse.org/modeling/amalgam/downloads/oldpackage s.php

Is there any solution to solve this?


I've seen another similar post in the forum withouth any reply here:
http://www.eclipse.org/forums/index.php?t=msg&goto=52519 8&

Thanks,
Pablo
Previous Topic:Modeling Survey 2010
Next Topic:DSL-Toolkit components in Helios Modeling Package?
Goto Forum:
  


Current Time: Thu Aug 21 08:23:39 EDT 2014

Powered by FUDForum. Page generated in 0.01951 seconds