Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Amalgam » Re: Problem installing DSL Toolkit
Re: Problem installing DSL Toolkit [message #587283] Sun, 28 February 2010 06:41
Ed Merks is currently offline Ed Merks
Messages: 25917
Registered: July 2009
Senior Member
Ryan,

It sounds like the modeling package likely wasn't updated for SR2 yet
has a hard version dependency (strict upper limit) on something in SR1
that has been updated in SR2. The Amalgam folks will need to have a
look, so I'll add that newsgroup/forum to the "to" list of the reply.


Ryan wrote:
> I'm trying to install the Galileo DSL Toolkit from the update link
> given on this page:
> http://download.eclipse.org/modeling/amalgam/dsltk/downloads /drops/S20090703-0844/index.php
>
>
> However, the update fails becuase of dependencies:
> Cannot complete the install because of a conflicting dependency.
> Software being installed: DSL Toolkit 1.0.0.v200907030844
> (org.eclipse.amalgam.dsltk.product 1.0.0.v200907030844)
> Software currently installed: Eclipse Modeling Tools
> 1.2.1.20090918-0703 (epp.package.modeling 1.2.1.20090918-0703)
> Only one of the following can be installed at once:
> org.eclipse.platform_root
> 3.5.0.v20090611a-9gEeG1HFtQcmRThO4O3aR_fqSMvJR2sJ
> org.eclipse.platform_root
> 3.5.2.R35x_v20100210-0800-9hEiFzmFst-TiEn9hNYgDWg1XN8ulH_JvC NGB
> org.eclipse.platform_root
> 3.5.1.R35x_v20090910-9gEeG1_FthkNDSP2odXdThaOu9GFDPn83DGB7
> Cannot satisfy dependency:
> From: Eclipse Modeling Tools 1.2.1.20090918-0703
> (epp.package.modeling 1.2.1.20090918-0703)
> To: org.eclipse.epp.package.modeling.feature.feature.group
> [1.2.1.20090918-0703]
> Cannot satisfy dependency:
> From: DSL Toolkit 1.0.0.v200907030844
> (org.eclipse.amalgam.dsltk.product 1.0.0.v200907030844)
> To: org.eclipse.platform.feature.group
> [3.5.0.v20090611a-9gEeG1HFtQcmRThO4O3aR_fqSMvJR2sJ]
> Cannot satisfy dependency:
> From: EPP Modeling Feature 1.2.1.20090918-0703
> (org.eclipse.epp.package.modeling.feature.feature.group
> 1.2.1.20090918-0703)
> To: org.eclipse.platform.feature.group
> [3.5.1.R35x_v20090910-9gEeG1_FthkNDSP2odXdThaOu9GFDPn83DGB7]
> Cannot satisfy dependency:
> From: Eclipse Platform
> 3.5.0.v20090611a-9gEeG1HFtQcmRThO4O3aR_fqSMvJR2sJ
> (org.eclipse.platform.feature.group
> 3.5.0.v20090611a-9gEeG1HFtQcmRThO4O3aR_fqSMvJR2sJ)
> To: org.eclipse.platform_root
> [3.5.0.v20090611a-9gEeG1HFtQcmRThO4O3aR_fqSMvJR2sJ]
> Cannot satisfy dependency:
> From: Eclipse Platform
> 3.5.1.R35x_v20090910-9gEeG1_FthkNDSP2odXdThaOu9GFDPn83DGB7
> (org.eclipse.platform.feature.group
> 3.5.1.R35x_v20090910-9gEeG1_FthkNDSP2odXdThaOu9GFDPn83DGB7)
> To: org.eclipse.platform_root
> [3.5.1.R35x_v20090910-9gEeG1_FthkNDSP2odXdThaOu9GFDPn83DGB7]
>
> Could this just be an issue of the dependency list not being
> up-to-date on the DSL Toolkit?
Previous Topic:[Announce] Eclipse/OMG Symposium 2010
Next Topic:Re: Problem installing DSL Toolkit
Goto Forum:
  


Current Time: Thu Jul 24 06:55:00 EDT 2014

Powered by FUDForum. Page generated in 0.16733 seconds