Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Amalgam » DSL toolkit book - problem when running tranformations
DSL toolkit book - problem when running tranformations [message #587233] Thu, 31 December 2009 11:26
Martin Baez is currently offline Martin Baez
Messages: 12
Registered: July 2009
Junior Member
I am developing a dsl toolkit and trying to give support for running
some atl, qvto and xpand tranformations programatically.
I am a bit lost when trying to understand how invokations must be done
and found some problems when running the transformations:

1) The m2t tranformation(TransformMindmap2Csv class) was not running
beacuse the code is commented, I uncommented the code and used the
org.eclipse.emf.mwe plugins in order to compile the uncommented code,
but when I try to export a mindmap diagram to cvs nothing happens, after
some debug I found this issue reported for the WorkflowRunner

[ERROR]: Class not found: 'org.eclipse.xpand2.Generator'

What bundle am I missing?, I understood that the dsl sample must be used
with the ganymede version, but what version of xpand should I use?

2) I cannot run the transformations(mindmap to requirementes for
example) because the wizard reported this error:

"Cannot find imported module
'/org.eclipse.amalgam.examples.dnc.TransformDnc2Java.transfo rmationId' "




Any clue?, by the way the book is great!!


thanks in advance

colo
Previous Topic:errors in building the examples
Next Topic:DSL toolkit book - problem when running tranformations
Goto Forum:
  


Current Time: Thu Jul 31 07:41:03 EDT 2014

Powered by FUDForum. Page generated in 0.01471 seconds