Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Does any one have the basic steps to setup TPTP with Eclipse
Does any one have the basic steps to setup TPTP with Eclipse [message #59143] Sat, 18 March 2006 18:58 Go to next message
Eclipse UserFriend
Originally posted by: pmohanan.sbcglobal.net

Hi...All,

Does anyone have the basic steps to configure the eclipse with TPTP?
I tried following the instructions as per the website , but finally end
up some of the components not working.

Rehards.
Re: Does any one have the basic steps to setup TPTP with Eclipse [message #59176 is a reply to message #59143] Sat, 18 March 2006 19:01 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: pmohanan.sbcglobal.net

Actually, here the error messages when I run the test :

Missing :

org.eclipse.hyades.logging.core_4.1.01.\nl1.jar
org.eclipse.hyades.logging.core_4.1.01.\nl2.jar
org.eclipse.hyades.logging.core_4.1.01.\nlBidi.jar


Praveen Mohanan wrote:
> Hi...All,
>
> Does anyone have the basic steps to configure the eclipse with TPTP?
> I tried following the instructions as per the website , but finally end
> up some of the components not working.
>
> Rehards.
Re: Does any one have the basic steps to setup TPTP with Eclipse [message #59200 is a reply to message #59176] Sun, 19 March 2006 01:01 Go to previous messageGo to next message
Randy D. Smith is currently offline Randy D. SmithFriend
Messages: 394
Registered: July 2009
Senior Member
That looks suspiciously like a bug in our 4.1.0.1 configuration
information somewhere (01 instead of 0.1 at end of version). Looking at
the download release of that runtime shows me no files with 4.1.01 in
the name (still, such could be in a jarfile somewhere). Something
POSSIBLY has been built with incorrect information somewhere.

So you went to the TPTP site, then to its downloads, the latest release
shows as 4.1.0.1, you made sure the Requirements at the bottom of the
page were met (versions of Java, Eclipse, and EMF/XSD)?

If so, I'd file a bugzilla, as I'm sure we want the "Latest Release" not
to be DOA!

If, on the other hand, you don't have all the requirements set up as
specified, tell me where you deviated. (E.g., I'm not expecting any
problems if you're using Java 1.5 instead of 1.4 ... but I'd expect such
problems if you have a 3.2 Eclipse or the wrong EMF/XSD package.)
--
RDS

Praveen Mohanan wrote:
> Actually, here the error messages when I run the test :
>
> Missing :
>
> org.eclipse.hyades.logging.core_4.1.01.\nl1.jar
> org.eclipse.hyades.logging.core_4.1.01.\nl2.jar
> org.eclipse.hyades.logging.core_4.1.01.\nlBidi.jar
>
>
> Praveen Mohanan wrote:
>
>> Hi...All,
>>
>> Does anyone have the basic steps to configure the eclipse with
>> TPTP? I tried following the instructions as per the website , but
>> finally end up some of the components not working.
>>
>> Rehards.
Re: Does any one have the basic steps to setup TPTP with Eclipse [message #59224 is a reply to message #59200] Mon, 20 March 2006 01:48 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: nospam.nospam.com

Hi..Randy,

I just followed the steps provided at this URL :

http://eclipse.org/tptp/home/downloads/installguide/InstallG uide41.html

I will erase all the current installations & try once again & note down
the steps this time. If it still fails. I will post it here.

Secondly, do I have to start the agent controller to record the tests?

Randy D. Smith wrote:
> That looks suspiciously like a bug in our 4.1.0.1 configuration
> information somewhere (01 instead of 0.1 at end of version). Looking at
> the download release of that runtime shows me no files with 4.1.01 in
> the name (still, such could be in a jarfile somewhere). Something
> POSSIBLY has been built with incorrect information somewhere.
>
> So you went to the TPTP site, then to its downloads, the latest release
> shows as 4.1.0.1, you made sure the Requirements at the bottom of the
> page were met (versions of Java, Eclipse, and EMF/XSD)?
>
> If so, I'd file a bugzilla, as I'm sure we want the "Latest Release" not
> to be DOA!
>
> If, on the other hand, you don't have all the requirements set up as
> specified, tell me where you deviated. (E.g., I'm not expecting any
> problems if you're using Java 1.5 instead of 1.4 ... but I'd expect such
> problems if you have a 3.2 Eclipse or the wrong EMF/XSD package.)
> --
> RDS
>
> Praveen Mohanan wrote:
>> Actually, here the error messages when I run the test :
>>
>> Missing :
>>
>> org.eclipse.hyades.logging.core_4.1.01.\nl1.jar
>> org.eclipse.hyades.logging.core_4.1.01.\nl2.jar
>> org.eclipse.hyades.logging.core_4.1.01.\nlBidi.jar
>>
>>
>> Praveen Mohanan wrote:
>>
>>> Hi...All,
>>>
>>> Does anyone have the basic steps to configure the eclipse with
>>> TPTP? I tried following the instructions as per the website , but
>>> finally end up some of the components not working.
>>>
>>> Rehards.
Re: Does any one have the basic steps to setup TPTP with Eclipse [message #59248 is a reply to message #59224] Mon, 20 March 2006 04:32 Go to previous messageGo to next message
Randy D. Smith is currently offline Randy D. SmithFriend
Messages: 394
Registered: July 2009
Senior Member
The agent controller is generally only needed for remote tasks... but by
"record the tests" if you mean the automated GUI recorder... that's a
bit out of my experience so I can't really comment on that specifically
.... sorry. I'm an AC person, who mostly pops up for monitoring and
profiling if I pop up higher at all!
--
RDS


Praveen Mohanan wrote:
> Hi..Randy,
>
> I just followed the steps provided at this URL :
>
> http://eclipse.org/tptp/home/downloads/installguide/InstallG uide41.html
>
> I will erase all the current installations & try once again & note down
> the steps this time. If it still fails. I will post it here.
>
> Secondly, do I have to start the agent controller to record the tests?
>
> Randy D. Smith wrote:
>
>> That looks suspiciously like a bug in our 4.1.0.1 configuration
>> information somewhere (01 instead of 0.1 at end of version). Looking
>> at the download release of that runtime shows me no files with 4.1.01
>> in the name (still, such could be in a jarfile somewhere). Something
>> POSSIBLY has been built with incorrect information somewhere.
>>
>> So you went to the TPTP site, then to its downloads, the latest
>> release shows as 4.1.0.1, you made sure the Requirements at the bottom
>> of the page were met (versions of Java, Eclipse, and EMF/XSD)?
>>
>> If so, I'd file a bugzilla, as I'm sure we want the "Latest Release"
>> not to be DOA!
>>
>> If, on the other hand, you don't have all the requirements set up as
>> specified, tell me where you deviated. (E.g., I'm not expecting any
>> problems if you're using Java 1.5 instead of 1.4 ... but I'd expect
>> such problems if you have a 3.2 Eclipse or the wrong EMF/XSD package.)
>> --
>> RDS
>>
>> Praveen Mohanan wrote:
>>
>>> Actually, here the error messages when I run the test :
>>>
>>> Missing :
>>>
>>> org.eclipse.hyades.logging.core_4.1.01.\nl1.jar
>>> org.eclipse.hyades.logging.core_4.1.01.\nl2.jar
>>> org.eclipse.hyades.logging.core_4.1.01.\nlBidi.jar
>>>
>>>
>>> Praveen Mohanan wrote:
>>>
>>>> Hi...All,
>>>>
>>>> Does anyone have the basic steps to configure the eclipse with
>>>> TPTP? I tried following the instructions as per the website , but
>>>> finally end up some of the components not working.
>>>>
>>>> Rehards.
Re: Does any one have the basic steps to setup TPTP with Eclipse [message #59348 is a reply to message #59248] Mon, 20 March 2006 15:46 Go to previous message
Eclipse UserFriend
Originally posted by: nospam.nospam.com

Hi..Randy,

I redid the whole installation& now this is the error message I get
once I stop recording,

org.eclipse.ui.PartInitException: Invalid editor input.
at
org.eclipse.hyades.test.ui.internal.editor.BaseEditorPart.id entifyEditorDescriptor(BaseEditorPart.java:121)
at
org.eclipse.hyades.ui.internal.editor.HyadesEditorPart.init( HyadesEditorPart.java:388)
at org.eclipse.ui.internal.EditorManager.createSite(EditorManag er.java:773)
at
org.eclipse.ui.internal.EditorReference.createPartHelper(Edi torReference.java:572)
at
org.eclipse.ui.internal.EditorReference.createPart(EditorRef erence.java:365)
at
org.eclipse.ui.internal.WorkbenchPartReference.getPart(Workb enchPartReference.java:552)
at org.eclipse.ui.internal.PartPane.setVisible(PartPane.java:28 3)
at
org.eclipse.ui.internal.presentations.PresentablePart.setVis ible(PresentablePart.java:126)
at
org.eclipse.ui.internal.presentations.util.PresentablePartFo lder.select(PresentablePartFolder.java:268)
at
org.eclipse.ui.internal.presentations.util.LeftToRightTabOrd er.select(LeftToRightTabOrder.java:65)
at
org.eclipse.ui.internal.presentations.util.TabbedStackPresen tation.selectPart(TabbedStackPresentation.java:391)
at
org.eclipse.ui.internal.PartStack.refreshPresentationSelecti on(PartStack.java:1102)
at org.eclipse.ui.internal.PartStack.setSelection(PartStack.jav a:1051)
at org.eclipse.ui.internal.PartStack.showPart(PartStack.java:12 56)
at org.eclipse.ui.internal.PartStack.add(PartStack.java:442)
at org.eclipse.ui.internal.EditorStack.add(EditorStack.java:109 )
at
org.eclipse.ui.internal.EditorSashContainer.addEditor(Editor SashContainer.java:60)
at
org.eclipse.ui.internal.EditorAreaHelper.addToLayout(EditorA reaHelper.java:212)
at
org.eclipse.ui.internal.EditorAreaHelper.addEditor(EditorAre aHelper.java:202)
at
org.eclipse.ui.internal.EditorManager.createEditorTab(Editor Manager.java:753)
at
org.eclipse.ui.internal.EditorManager.openEditorFromDescript or(EditorManager.java:665)
at org.eclipse.ui.internal.EditorManager.openEditor(EditorManag er.java:628)
at
org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched( WorkbenchPage.java:2323)
at
org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(Workben chPage.java:2258)
at org.eclipse.ui.internal.WorkbenchPage.access$9(WorkbenchPage .java:2250)
at org.eclipse.ui.internal.WorkbenchPage$9.run(WorkbenchPage.ja va:2236)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:69)
at
org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPa ge.java:2231)
at
org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPa ge.java:2212)
at org.eclipse.ui.ide.IDE.openEditor(IDE.java:371)
at org.eclipse.ui.ide.IDE.openEditor(IDE.java:334)
at
org.eclipse.hyades.internal.execution.testgen.ui.TestgenUIUt ility.openEditor(TestgenUIUtility.java:331)
at
org.eclipse.hyades.test.internal.testgen.ui.TestgenUIWrapper $2.run(TestgenUIWrapper.java:116)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)
at
org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchr onizer.java:123)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3057)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :2716)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:1699)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1663)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:367)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:143)
at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplicatio n.java:103)
at
org.eclipse.core.internal.runtime.PlatformActivator$1.run(Pl atformActivator.java:226)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:376)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:163)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334 )
at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
at org.eclipse.core.launcher.Main.run(Main.java:973)
at org.eclipse.core.launcher.Main.main(Main.java:948)


Randy D. Smith wrote:
> The agent controller is generally only needed for remote tasks... but by
> "record the tests" if you mean the automated GUI recorder... that's a
> bit out of my experience so I can't really comment on that specifically
> ... sorry. I'm an AC person, who mostly pops up for monitoring and
> profiling if I pop up higher at all!
> --
> RDS
>
>
> Praveen Mohanan wrote:
>> Hi..Randy,
>>
>> I just followed the steps provided at this URL :
>>
>> http://eclipse.org/tptp/home/downloads/installguide/InstallG uide41.html
>>
>> I will erase all the current installations & try once again & note
>> down the steps this time. If it still fails. I will post it here.
>>
>> Secondly, do I have to start the agent controller to record the tests?
>>
>> Randy D. Smith wrote:
>>
>>> That looks suspiciously like a bug in our 4.1.0.1 configuration
>>> information somewhere (01 instead of 0.1 at end of version). Looking
>>> at the download release of that runtime shows me no files with 4.1.01
>>> in the name (still, such could be in a jarfile somewhere). Something
>>> POSSIBLY has been built with incorrect information somewhere.
>>>
>>> So you went to the TPTP site, then to its downloads, the latest
>>> release shows as 4.1.0.1, you made sure the Requirements at the
>>> bottom of the page were met (versions of Java, Eclipse, and EMF/XSD)?
>>>
>>> If so, I'd file a bugzilla, as I'm sure we want the "Latest Release"
>>> not to be DOA!
>>>
>>> If, on the other hand, you don't have all the requirements set up as
>>> specified, tell me where you deviated. (E.g., I'm not expecting any
>>> problems if you're using Java 1.5 instead of 1.4 ... but I'd expect
>>> such problems if you have a 3.2 Eclipse or the wrong EMF/XSD package.)
>>> --
>>> RDS
>>>
>>> Praveen Mohanan wrote:
>>>
>>>> Actually, here the error messages when I run the test :
>>>>
>>>> Missing :
>>>>
>>>> org.eclipse.hyades.logging.core_4.1.01.\nl1.jar
>>>> org.eclipse.hyades.logging.core_4.1.01.\nl2.jar
>>>> org.eclipse.hyades.logging.core_4.1.01.\nlBidi.jar
>>>>
>>>>
>>>> Praveen Mohanan wrote:
>>>>
>>>>> Hi...All,
>>>>>
>>>>> Does anyone have the basic steps to configure the eclipse with
>>>>> TPTP? I tried following the instructions as per the website , but
>>>>> finally end up some of the components not working.
>>>>>
>>>>> Rehards.
Previous Topic:Finding all objects that were created
Next Topic:unable to load class org.eclipse.hyades.trace.internal.ui.PDProjectExplorer error
Goto Forum:
  


Current Time: Tue Nov 25 23:48:25 GMT 2014

Powered by FUDForum. Page generated in 0.07303 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software