Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » AJDT » Newbie has Eclipse 3.1.1 - which version of AJDT ??
Newbie has Eclipse 3.1.1 - which version of AJDT ?? [message #59109] Wed, 14 December 2005 09:27 Go to next message
Eclipse User
Originally posted by: shale.web.de

Hi!

I have Eclipse 3.1.1 running on XP Professional.
Which version of AJDT should I install that is compatible with this
Eclipse version?
Should I use the internal Eclipse installer and point it to
http://download.eclipse.org/technology/ajdt/31/update/ ??
Would someone please tell me if that will even work?
Or is there a better, more stable way of installing the AspectJ components
into this Eclipse environment?

Best,
Kevin
Re: Newbie has Eclipse 3.1.1 - which version of AJDT ?? [message #59135 is a reply to message #59109] Wed, 14 December 2005 09:40 Go to previous messageGo to next message
Matt Chapman is currently offline Matt Chapman
Messages: 429
Registered: July 2009
Senior Member
Kevin wrote:
> I have Eclipse 3.1.1 running on XP Professional.
> Which version of AJDT should I install that is compatible with this
> Eclipse version?
> Should I use the internal Eclipse installer and point it to
> http://download.eclipse.org/technology/ajdt/31/update/ ??
> Would someone please tell me if that will even work?
> Or is there a better, more stable way of installing the AspectJ components
> into this Eclipse environment?

Hi Kevin,

There isn't quite a stable AJDT release for Eclipse 3.1.1 yet - it's
waiting on the final release of AspectJ 5. Until then you can point the
installer at:
http://download.eclipse.org/technology/ajdt/31/dev/update/
and pick up the latest AJDT development build. As we are so close to
release, these builds should be stable. In fact AspectJ 5 RC1 has just
been released today, so there should also be an AJDT 1.3.0 RC1 released
within a day.

Regards,

Matt.
Re: Newbie has Eclipse 3.1.1 - which version of AJDT ?? [message #59160 is a reply to message #59135] Wed, 14 December 2005 10:33 Go to previous messageGo to next message
Eclipse User
Originally posted by: shale.web.de

Thanks, Matt.

I pointed the installer to the URL in my first message and when Eclipse
restarted it sort of freaked out.

Any project I now click on shows on dumps error messages in the log, for
example:

Caused by: java.lang.NullPointerException
at
org.eclipse.ajdt.ui.AspectJUIPlugin.checkProblemMarkersVisib le(AspectJUIPlugin.java:491)
at
org.eclipse.ajdt.ui.AspectJUIPlugin.checkAspectJVersion(Aspe ctJUIPlugin.java:470)
at org.eclipse.ajdt.ui.AspectJUIPlugin.start(AspectJUIPlugin.ja va:674)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl$2 .run(BundleContextImpl.java:994)
at java.security.AccessController.doPrivileged(Native Method)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tartActivator(BundleContextImpl.java:988)
... 77 more

I will try your URL and see what happens next.
Best,
Kevin
Re: Newbie has Eclipse 3.1.1 - which version of AJDT ?? [message #59183 is a reply to message #59160] Wed, 14 December 2005 11:09 Go to previous messageGo to next message
Matt Chapman is currently offline Matt Chapman
Messages: 429
Registered: July 2009
Senior Member
Kevin wrote:
> I pointed the installer to the URL in my first message and when Eclipse
> restarted it sort of freaked out.

There appears to be a very old build there, but there shouldn't be
anything there as yet (until we release RC1). Where did you get that URL
from? It's not listed on the AJDT download page here:
http://www.eclipse.org/ajdt/downloads/

> I will try your URL and see what happens next.

I'm sure a current build will work much better!

Regards,

Matt.
Re: Newbie has Eclipse 3.1.1 - which version of AJDT ?? [message #59209 is a reply to message #59135] Wed, 14 December 2005 11:12 Go to previous messageGo to next message
Eclipse User
Originally posted by: shale.web.de

Hi Matt,

This could be a simple project configuration mistake of mine, but when
after I add the aspect nature to an existing project and then add a new
aspect construct, I get the following exception. Why can't the mail.jar in
my Java Build Path not be opened?

Best,
Kevin



org.aspectj.weaver.BCException
at
org.aspectj.weaver.bcel.ClassPathManager$ZipFileEntry.ensure Open(ClassPathManager.java:253)
at
org.aspectj.weaver.bcel.ClassPathManager$ZipFileEntry.find(C lassPathManager.java:225)
at org.aspectj.weaver.bcel.ClassPathManager.find(ClassPathManag er.java:92)
at org.aspectj.weaver.bcel.BcelWorld.lookupJavaClass(BcelWorld. java:272)
at org.aspectj.weaver.bcel.BcelWorld.resolveDelegate(BcelWorld. java:247)
at org.aspectj.weaver.World.resolveToReferenceType(World.java:3 00)
at org.aspectj.weaver.World.resolve(World.java:217)
at org.aspectj.weaver.World.resolve(World.java:137)
at org.aspectj.weaver.World.resolve(World.java:265)
at
org.aspectj.ajdt.internal.core.builder.AjBuildManager.initBc elWorld(AjBuildManager.java:670)
at
org.aspectj.ajdt.internal.core.builder.AjBuildManager.doBuil d(AjBuildManager.java:209)
at
org.aspectj.ajdt.internal.core.builder.AjBuildManager.batchB uild(AjBuildManager.java:156)
at
org.aspectj.ajde.internal.CompilerAdapter.compile(CompilerAd apter.java:122)
at
org.aspectj.ajde.internal.AspectJBuildManager$CompilerThread .run(AspectJBuildManager.java:191)

BCException thrown: Can't open archive: mail.jar
when batch building
BuildConfig[C:\development\workspace\.metadata\.plugins\org. eclipse.ajdt.core\trading.generated.lst]
#Files=32
Re: Newbie has Eclipse 3.1.1 - which version of AJDT ?? [message #59232 is a reply to message #59183] Wed, 14 December 2005 11:14 Go to previous messageGo to next message
Eclipse User
Originally posted by: shale.web.de

Matt Chapman wrote:

> There appears to be a very old build there, but there shouldn't be
> anything there as yet (until we release RC1). Where did you get that URL
> from? It's not listed on the AJDT download page here:
> http://www.eclipse.org/ajdt/downloads/

I guessed the URL. Sorry.
Re: Newbie has Eclipse 3.1.1 - which version of AJDT ?? [message #59256 is a reply to message #59183] Wed, 14 December 2005 11:23 Go to previous messageGo to next message
Eclipse User
Originally posted by: shale.web.de

Matt Chapman wrote:

> I'm sure a current build will work much better!

> Regards,

> Matt.

Perhaps. I am assuming first that my Java Project in Eclipse is wrongly
configured.

It has been a long time since I have checked out sources from cvs and
compiled them locally, so I think I will wait for that RC you mentioned.

Unless you can point me to an URL which covers this process using Eclipse
and your pserver?

Many Thanks,
Kevin
Re: Newbie has Eclipse 3.1.1 - which version of AJDT ?? [message #59280 is a reply to message #59209] Wed, 14 December 2005 11:31 Go to previous messageGo to next message
Eclipse User
Originally posted by: shale.web.de

Kevin wrote:

> Hi Matt,

> Why can't the mail.jar in my Java Build Path not be opened?


I can answer that now. Three jars from the customer's repository are empty
- 0 bytes. They probably aren't even real jars.

I feel like a foolish spammer now.

Regards,
Kevin
Re: Newbie has Eclipse 3.1.1 - which version of AJDT ?? [message #59386 is a reply to message #59280] Thu, 15 December 2005 03:58 Go to previous message
Matt Chapman is currently offline Matt Chapman
Messages: 429
Registered: July 2009
Senior Member
Hi Kevin,

As you've no doubt seen, RC1 has now been released, and your guessed URL
is now valid!

Regards,

Matt.
Re: Newbie has Eclipse 3.1.1 - which version of AJDT ?? [message #591161 is a reply to message #59109] Wed, 14 December 2005 09:40 Go to previous message
Matt Chapman is currently offline Matt Chapman
Messages: 429
Registered: July 2009
Senior Member
Kevin wrote:
> I have Eclipse 3.1.1 running on XP Professional.
> Which version of AJDT should I install that is compatible with this
> Eclipse version?
> Should I use the internal Eclipse installer and point it to
> http://download.eclipse.org/technology/ajdt/31/update/ ??
> Would someone please tell me if that will even work?
> Or is there a better, more stable way of installing the AspectJ components
> into this Eclipse environment?

Hi Kevin,

There isn't quite a stable AJDT release for Eclipse 3.1.1 yet - it's
waiting on the final release of AspectJ 5. Until then you can point the
installer at:
http://download.eclipse.org/technology/ajdt/31/dev/update/
and pick up the latest AJDT development build. As we are so close to
release, these builds should be stable. In fact AspectJ 5 RC1 has just
been released today, so there should also be an AJDT 1.3.0 RC1 released
within a day.

Regards,

Matt.
Re: Newbie has Eclipse 3.1.1 - which version of AJDT ?? [message #591186 is a reply to message #59135] Wed, 14 December 2005 10:33 Go to previous message
Kevin is currently offline Kevin
Messages: 34
Registered: July 2009
Member
Thanks, Matt.

I pointed the installer to the URL in my first message and when Eclipse
restarted it sort of freaked out.

Any project I now click on shows on dumps error messages in the log, for
example:

Caused by: java.lang.NullPointerException
at
org.eclipse.ajdt.ui.AspectJUIPlugin.checkProblemMarkersVisib le(AspectJUIPlugin.java:491)
at
org.eclipse.ajdt.ui.AspectJUIPlugin.checkAspectJVersion(Aspe ctJUIPlugin.java:470)
at org.eclipse.ajdt.ui.AspectJUIPlugin.start(AspectJUIPlugin.ja va:674)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl$2 .run(BundleContextImpl.java:994)
at java.security.AccessController.doPrivileged(Native Method)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tartActivator(BundleContextImpl.java:988)
... 77 more

I will try your URL and see what happens next.
Best,
Kevin
Re: Newbie has Eclipse 3.1.1 - which version of AJDT ?? [message #591191 is a reply to message #59160] Wed, 14 December 2005 11:09 Go to previous message
Matt Chapman is currently offline Matt Chapman
Messages: 429
Registered: July 2009
Senior Member
Kevin wrote:
> I pointed the installer to the URL in my first message and when Eclipse
> restarted it sort of freaked out.

There appears to be a very old build there, but there shouldn't be
anything there as yet (until we release RC1). Where did you get that URL
from? It's not listed on the AJDT download page here:
http://www.eclipse.org/ajdt/downloads/

> I will try your URL and see what happens next.

I'm sure a current build will work much better!

Regards,

Matt.
Re: Newbie has Eclipse 3.1.1 - which version of AJDT ?? [message #591203 is a reply to message #59135] Wed, 14 December 2005 11:12 Go to previous message
Kevin is currently offline Kevin
Messages: 34
Registered: July 2009
Member
Hi Matt,

This could be a simple project configuration mistake of mine, but when
after I add the aspect nature to an existing project and then add a new
aspect construct, I get the following exception. Why can't the mail.jar in
my Java Build Path not be opened?

Best,
Kevin



org.aspectj.weaver.BCException
at
org.aspectj.weaver.bcel.ClassPathManager$ZipFileEntry.ensure Open(ClassPathManager.java:253)
at
org.aspectj.weaver.bcel.ClassPathManager$ZipFileEntry.find(C lassPathManager.java:225)
at org.aspectj.weaver.bcel.ClassPathManager.find(ClassPathManag er.java:92)
at org.aspectj.weaver.bcel.BcelWorld.lookupJavaClass(BcelWorld. java:272)
at org.aspectj.weaver.bcel.BcelWorld.resolveDelegate(BcelWorld. java:247)
at org.aspectj.weaver.World.resolveToReferenceType(World.java:3 00)
at org.aspectj.weaver.World.resolve(World.java:217)
at org.aspectj.weaver.World.resolve(World.java:137)
at org.aspectj.weaver.World.resolve(World.java:265)
at
org.aspectj.ajdt.internal.core.builder.AjBuildManager.initBc elWorld(AjBuildManager.java:670)
at
org.aspectj.ajdt.internal.core.builder.AjBuildManager.doBuil d(AjBuildManager.java:209)
at
org.aspectj.ajdt.internal.core.builder.AjBuildManager.batchB uild(AjBuildManager.java:156)
at
org.aspectj.ajde.internal.CompilerAdapter.compile(CompilerAd apter.java:122)
at
org.aspectj.ajde.internal.AspectJBuildManager$CompilerThread .run(AspectJBuildManager.java:191)

BCException thrown: Can't open archive: mail.jar
when batch building
BuildConfig[C:\development\workspace\.metadata\.plugins\org. eclipse.ajdt.core\trading.generated.lst]
#Files=32
Re: Newbie has Eclipse 3.1.1 - which version of AJDT ?? [message #591215 is a reply to message #59183] Wed, 14 December 2005 11:14 Go to previous message
Kevin is currently offline Kevin
Messages: 34
Registered: July 2009
Member
Matt Chapman wrote:

> There appears to be a very old build there, but there shouldn't be
> anything there as yet (until we release RC1). Where did you get that URL
> from? It's not listed on the AJDT download page here:
> http://www.eclipse.org/ajdt/downloads/

I guessed the URL. Sorry.
Re: Newbie has Eclipse 3.1.1 - which version of AJDT ?? [message #591227 is a reply to message #59183] Wed, 14 December 2005 11:23 Go to previous message
Kevin is currently offline Kevin
Messages: 34
Registered: July 2009
Member
Matt Chapman wrote:

> I'm sure a current build will work much better!

> Regards,

> Matt.

Perhaps. I am assuming first that my Java Project in Eclipse is wrongly
configured.

It has been a long time since I have checked out sources from cvs and
compiled them locally, so I think I will wait for that RC you mentioned.

Unless you can point me to an URL which covers this process using Eclipse
and your pserver?

Many Thanks,
Kevin
Re: Newbie has Eclipse 3.1.1 - which version of AJDT ?? [message #591237 is a reply to message #59209] Wed, 14 December 2005 11:31 Go to previous message
Kevin is currently offline Kevin
Messages: 34
Registered: July 2009
Member
Kevin wrote:

> Hi Matt,

> Why can't the mail.jar in my Java Build Path not be opened?


I can answer that now. Three jars from the customer's repository are empty
- 0 bytes. They probably aren't even real jars.

I feel like a foolish spammer now.

Regards,
Kevin
Re: Newbie has Eclipse 3.1.1 - which version of AJDT ?? [message #591272 is a reply to message #59280] Thu, 15 December 2005 03:58 Go to previous message
Matt Chapman is currently offline Matt Chapman
Messages: 429
Registered: July 2009
Senior Member
Hi Kevin,

As you've no doubt seen, RC1 has now been released, and your guessed URL
is now valid!

Regards,

Matt.
Previous Topic:AJDT 1.2.1RC1 and 1.3.0RC1 now available
Next Topic:AJDT 1.2.1RC1 and 1.3.0RC1 now available
Goto Forum:
  


Current Time: Fri Apr 18 04:14:45 EDT 2014

Powered by FUDForum. Page generated in 0.02323 seconds