Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » OHF » PDQ query result missing DOB and sex
PDQ query result missing DOB and sex [message #584642] Thu, 14 February 2008 18:35
Jesse Pangburn is currently offline Jesse Pangburn
Messages: 166
Registered: July 2009
Senior Member
Hi,
I noticed in some testing today using the bridge that when I searched for
a patient using PDQ, I got back a result and the DOB and sex where missing
in the data the bridge sent back. I checked the log and it seems that the
server I'm querying is returning it, but it's not going into the bridge
result (19990101 is the DOB, and you can see it in the HL7 response):

- *** Response from 72.214.26.5 on port 2200 was:
MSH|^~\&|WS_SWPARTNERS|SWPARTNERS|MSGROUTERQUOVADX|QUOVA DX|20080214||RSP^K22|833
QPD|Q22^Find
Candidates^HL7|0119664092661646927227416445405|@PID.5.1.1^GU Y~@PID.
PID|1||JESSE001^^^QUMS&1.3.6.1.4.1.21367.2008.1.2.327&am p;ISO^PI||GUY^TEST||19990101
|M|||123 TEST HOUSE^^TEST^CA^92027^USA|
[DEBUG][10:31:02][he.common.mllp.MLLPDestination] MLLPDestination:
sendMessage -
Exit
[DEBUG][10:31:02][common.hl7v2.mllpclient.Client] Client: send - Exit
SEND_MLLP_
DEST
[DEBUG][10:31:02][common.hl7v2.mllpclient.Client] Client: send - Exit
[DEBUG][10:31:02][common.hl7v2.mllpclient.Client] Client: sendMsg - Exit
[DEBUG][10:31:02][f.ihe.pdq.consumer.PdqConsumer] PdqConsumer: sendQuery -
Exit
controlId: 8333012359458730303
[DEBUG][10:31:02][ixpdq.IhePatientConsumerBridge] Retrieved a new patient
ID for
index 0 JESSE001:QUMS:1.3.6.1.4.1.21367.2008.1.2.327:ISO
[DEBUG][10:31:02][ixpdq.IhePatientConsumerBridge] Adding a new patient Id
with P
atientIdType ( idNumber=[JESSE001]
assigningAuthority=[AssigningAuthority ( n
amespaceId=[QUMS] universalId=[1.3.6.1.4.1.21367.2008.1.2.327]
universalId
Type=[ISO] useDefaultAssigningAuthority=[false]
universalIdTypeCode=[]
)] )
[DEBUG][10:31:02][clipse.ohf.bridge.ws.OHFBridge] returning response:
ResponseTy
pe ( response=[0] ) SearchPatientResponseType (
patient=[PatientInfoType ( p
atientIdentifier=[PatientIdType ( idNumber=[JESSE001]
assigningAuthority=[Ass
igningAuthority ( namespaceId=[QUMS]
universalId=[1.3.6.1.4.1.21367.2008.1.2.
327] universalIdType=[ISO] useDefaultAssigningAuthority=[false]
univers
alIdTypeCode=[] )] )] patientName=[PatientNameType (
familyName=[GUY]
givenName=[TEST] otherName=[] suffix=[] prefix=[] )]
patient
DateOfBirth=[] patientSex=[] patientAddress=[AddressType (
streetAddress=[
123 TEST HOUSE] otherDesignation=[] city=[TEST]
stateOrProvince=[CA]
zipOrPostalCode=[92027] country=[USA] countyParishCode=[] )]
patie
ntPhoneHome=[PhoneType ( unformattedTelephoneNumber=[] )]
patientPhoneBus
iness=[PhoneType ( unformattedTelephoneNumber=[] )]
genericAdtValues=[]
)] )

In the bridge response fields, you can see the sex and DOB are both empty.
Any idea why this is?

thanks,
Jesse
Previous Topic:Thanks to the OHF team
Next Topic:PDQ query result missing DOB and sex
Goto Forum:
  


Current Time: Mon Sep 22 08:12:31 GMT 2014

Powered by FUDForum. Page generated in 0.09446 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software