Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » Question about using enumerated types!
Question about using enumerated types! [message #583163] Tue, 24 November 2009 16:28
Lucas Schubert is currently offline Lucas SchubertFriend
Messages: 11
Registered: July 2009
Junior Member
Hey,

I'm new in this group, so if it is a newbie question, sorry! :p

I'm trying to set a enumerated type value to a property in my target model (ECore) but it is not working.

I've tried to do it like it is written in the Epsilon Book and also using ".instance" at the end. But it is still not working.

The code line:

aMetricResult.type := QueryResult!MetricTypes#mtNumberOfChildren.instance;

The error Msg:

EXCEPTION: Cannot find enumeration literal MetricTypes#mtNumberOfChildren in model QueryResult.


If I don't set this field, the transformation works fine.

I've registered the Ecore model. (Magic Draw (UML) converted to eCore model).
I'm executing the transformation using an ant file.
The Epsilon Version is : 0.8.8

So I would like to ask if some of you knows what I may be doing wrong! :p

Thanks a lot in advance!

Lucas
Previous Topic:[Eugenia] Subdiagrams
Next Topic:Re: Question about using enumerated types!
Goto Forum:
  


Current Time: Mon Nov 24 01:23:47 GMT 2014

Powered by FUDForum. Page generated in 0.02077 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software