Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Communications Framework (ECF) » About the compatibility between Eclipse3.02 and ECF
About the compatibility between Eclipse3.02 and ECF [message #582006] Mon, 06 June 2005 01:16 Go to next message
Eclipse User
Originally posted by: seariver.citiz.net

Hi, all

In the ECF documentation,
It is required eclipse 3.1M7

Can ECF runs on Eclipse3.0x?
Thank you very much!


Seariver
Re: About the compatibility between Eclipse3.02 and ECF [message #582030 is a reply to message #582006] Mon, 06 June 2005 05:53 Go to previous messageGo to next message
Scott Lewis is currently offline Scott Lewis
Messages: 971
Registered: July 2009
Senior Member
Hi Seariver,

There are multiple plugins that make up ECF. Some of them should run OK
on eclipse 3.0.X, others require 3.1 API. Specifically, the core
plugins org.eclipse.ecf, org.eclipse.ecf.provider should run OK on 3.0.X
(although we have not tested them on 3.0.X for some time), but the
example plugins (org.eclipse.ecf.example.collab, etc) have UI changes
that are dependent upon the 3.1 API additions/changes.

Scott


seariver wrote:
> Hi, all
>
> In the ECF documentation,
> It is required eclipse 3.1M7
>
> Can ECF runs on Eclipse3.0x?
> Thank you very much!
>
>
> Seariver
>
>
Re: About the compatibility between Eclipse3.02 and ECF [message #607701 is a reply to message #582006] Fri, 10 November 2006 20:30 Go to previous message
Scott Lewis is currently offline Scott Lewis
Messages: 971
Registered: July 2009
Senior Member
Hi Seariver,

We haven't been doing building and testing on Eclipse 3.0x for some
time, and so I wouldn't bet that it will work properly for all parts of ECF.

OTOH, for the refactoring effort just completed, I think the core
plugins are fairly likely to be able to run on 3.0x...but I would
suspect that the example apps would still be unlikely to run on 3.0X
(because of the changes in the Eclipse 3.1+ UI code).

So we can't make any guarantees RE: 3.0x as it depends upon which parts
of ECF you would want to use.

Scott


seariver wrote:
> Hi, all
>
> In the ECF documentation,
> It is required eclipse 3.1M7
>
> Can ECF runs on Eclipse3.0x?
> Thank you very much!
>
>
> Seariver
>
>
Previous Topic:0.9.3 release imminent -- please review
Next Topic:ECF & CORBA
Goto Forum:
  


Current Time: Sat Oct 25 17:05:09 GMT 2014

Powered by FUDForum. Page generated in 0.01858 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software