Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » OHF » MESA test 11350 bridge problem
MESA test 11350 bridge problem [message #581929] Wed, 10 October 2007 19:41
Jesse Pangburn is currently offline Jesse PangburnFriend
Messages: 166
Registered: July 2009
Senior Member
Hi,
I'm having trouble with MESA test 11350 using the bridge. It's a patient
demographics query where you're supposed to query on the patient's last
name and their date of birth. In the web service request I send to the
bridge, here's the relevant portions:

<tns2:patientDateOfBirth>19380224</tns2:patientDateOfBirth >
and
<tns2:patientName>
<tns2:familyName>MOORE</tns2:familyName>

In the QPD-3 "demographics field" of the HL7 message the bridge sends,
there is the value:
@PID.5.1^MOORE~@PID.7.1^19380224
The MESA eval script says this is wrong, that the value should be:
@PID.5.1^MOORE~@PID.7^19380224

In the HL7 2.5 spec, the PID segment's Date Of Birth field has two
subcomponents. The time and the precision. So I think the message the
bridge is sending is correct, but I think you could also write it as the
MESA test does since the second subcomponent is not specified. I'm not
very knowledgeable about HL7 though, so does anyone know if one or both
are correct?

thanks,
Jesse
Previous Topic:OHF's 2008 IHE Connectathon wiki
Next Topic:STEM - GIS Plugin(s) for Eclipse
Goto Forum:
  


Current Time: Fri Dec 19 04:11:34 GMT 2014

Powered by FUDForum. Page generated in 0.01502 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software