Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Mobile Tools for Java (MTJ) » MTJ and Java SDK 3: bullshit
MTJ and Java SDK 3: bullshit [message #580933] Mon, 21 June 2010 07:38 Go to next message
bastard_troll  is currently offline bastard_troll
Messages: 2
Registered: June 2010
Junior Member
Man, these tools are awful, specially MTJ.
I was used to eclipse ME and WTK and managed to do things, but with the new MTJ, eclipse pulsar and Java ME Platform SDK 3.0 is simply impossible.
I've received all kinds of stupid error messages and suffered from emulator misconfiguration. E.g.:
-Now you don't have CLDC 1.1. (Don't bother setting it, will be ignored)
-Jar file is corrupted
-Problems connecting to device emulator, etc.
The worst environment for Java ME programming by far. Now I'm moving to netbeans.
Next time you launch some stuff, ensure it's easy to use and user-friendly.
Re: MTJ and Java SDK 3: bullshit [message #580966 is a reply to message #580933] Thu, 24 June 2010 07:22 Go to previous messageGo to next message
Eclipse User
Originally posted by: news.s237965939.online.de

Am 21.06.2010 13:38, schrieb bastard_troll:

> -Now you don't have CLDC 1.1. (Don't bother setting it, will be ignored)
> -Jar file is corrupted
> -Problems connecting to device emulator, etc.

Same problems here. I used some classes/methods from CLDC 1.1 without
knowing, and some floating point too, but the Motorola test device only
had CLDC 1.0. Eclipse/MTJ was set up to CLDC 1.0 but the errors remained
undiscoverd. That was the cause of most other problems I described in my
earlier postings. How did I find that out? I ported the project to
NetBeans, which found the errors right away. Nuff' said.

Hans
Re: MTJ and Java SDK 3: bullshit [message #581203 is a reply to message #580933] Fri, 09 July 2010 06:37 Go to previous message
Eclipse User
Originally posted by: krischik.users.sourceforge.net

Am 21.06.2010, 13:38 Uhr, schrieb bastard_troll <a1018486@bofthew.com>:

> The worst environment for Java ME programming by far.

I thought the one before was even worse - but after using the new version
for a while I am not so sure any more. If you want to continue using
eclipse you can give maven a try. Personally I think they should scrap MTJ
and work on integrating then java me from maven into eclipse instead. It
is clear they lack the manpower to do it all them-self.

Martin

--
Martin Krischik
mailto://krischik@users.sourceforge.net
https://sourceforge.net/users/krischik
Previous Topic:Invalid Preverifier file
Next Topic:Using midp_2.0 library in Eclipse
Goto Forum:
  


Current Time: Sat Aug 02 04:55:18 EDT 2014

Powered by FUDForum. Page generated in 0.02032 seconds