Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EPF » Migration to newever library version
Migration to newever library version [message #580816] Wed, 25 July 2007 13:28
Roman Smirak is currently offline Roman SmirakFriend
Messages: 136
Registered: July 2009
Senior Member
Hi,

I have just downloaded latest version of OpenUP library and tried to
migrate my plugin to this.

My plugin has been developed on OpenUP 0.9 distributed with Composer 1.2 M3
(I guess - can I check it somewhere? Plugin.xml, etc.)

I started EPF with OpenUP 1.0-RC3-20070720 and imported my plugin; and it
didn't work - workspace/.metadata/.log shows:
java.lang.NullPointerException
at
org.eclipse.epf.authoring.ui.forms.ConfigurationPage.updateC heckStates(Unknown
Source)
at org.eclipse.epf.authoring.ui.forms.ConfigurationPage.setInpu t(Unknown
Source)
at
org.eclipse.epf.authoring.ui.forms.ConfigurationPage.createF ormContent(Unknown
Source)
at org.eclipse.ui.forms.editor.FormPage$1.run(FormPage.java:151 )
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:67)
at
org.eclipse.ui.forms.editor.FormPage.createPartControl(FormP age.java:149)
at org.eclipse.ui.forms.editor.FormEditor.pageChange(FormEditor .java:484)
at
org.eclipse.epf.authoring.ui.editors.MethodElementEditor.pag eChange(Unknown
Source)
at
org.eclipse.ui.part.MultiPageEditorPart$2.widgetSelected(Mul tiPageEditorPart.java:239)
at
org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListe ner.java:227)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :66)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:938)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:962)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:947)
at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:7 06)
at org.eclipse.swt.custom.CTabFolder.setSelection(CTabFolder.ja va:3206)
at org.eclipse.swt.custom.CTabFolder.onMouse(CTabFolder.java:19 88)
at org.eclipse.swt.custom.CTabFolder$1.handleEvent(CTabFolder.j ava:308)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :66)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:938)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.ja va:3673)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3284)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2337)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2301)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:21 76)
at org.eclipse.ui.internal.Workbench$4.run(Workbench.java:463)
at
org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:289)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:458)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at org.eclipse.epf.rcp.ui.MainApplication.createWorkbenchAdviso r(Unknown
Source)
at org.eclipse.epf.rcp.ui.MainApplication.start(Unknown Source)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:146)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:106)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:76)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:356)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:171)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 476)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:416)
at org.eclipse.equinox.launcher.Main.run(Main.java:1141)

However, next time it worked (I just deleted workspace, copied library and
imported my plugin again) and so I cannot reproduce it. I'm putting it here
just FYI.

Now I see couple of errors telling me:
Severity and Description Path Resource Location Creation Time Id
Could not resolve proxy
'uma://_0TLvwMlgEdmt3adZL5Dmdw#_h15dULCxEdujaOuld2kPdg'
OpenUP/configurations OpenUP_TS.xmi
C:\workbench\workspaces\workspace-epf2\OpenUP\configurations \OpenUP_TS.xmi
1185369789419 17
Could not resolve proxy
'uma://_0TLvwMlgEdmt3adZL5Dmdw#_XIwYQPTYEduDKIuqTXQ8SA'
OpenUP/configurations OpenUP_TS.xmi
C:\workbench\workspaces\workspace-epf2\OpenUP\configurations \OpenUP_TS.xmi
1185369789520 18
Could not resolve proxy
'uma://_WCUhAO8KEdmKSqa_gSYthg#_AejKAMadEduMlb2cQZNTYw'
OpenUP/configurations OpenUP_TS.xmi
C:\workbench\workspaces\workspace-epf2\OpenUP\configurations \OpenUP_TS.xmi
1185369789209 16

Does it mean that my plugin contributes to some elements which have changed
or don't exist anymore?

Question: what are your suggestions/recommended practices for the migration?

Roman
Previous Topic:Problem with a method specification
Next Topic:OpenUP/DSDM
Goto Forum:
  


Current Time: Thu Dec 18 22:23:42 GMT 2014

Powered by FUDForum. Page generated in 0.01427 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software