Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Databinding: tableviewer does not refresh automatically
Databinding: tableviewer does not refresh automatically [message #580348] Tue, 10 August 2010 10:06 Go to next message
Mo P. is currently offline Mo P.Friend
Messages: 24
Registered: July 2010
Junior Member
Hello,

there are two employees in the TableViewer_MasterDetail_Edit test from package e4.xwt.tests.jface.tableviewer.master.detail.

When I select one in the table, his name is displayed in the text field. When I change the text in the textfield, the objects attribute changes obviously (because when I deselect the employee and then select it again, the name in the text field is changed) but the text of the tableitem doesn't change at all. I think it is not refreshing properly.

Thank you very much for all your help

Regards
Moritz
Re: Databinding: tableviewer does not refresh automatically [message #580375 is a reply to message #580348] Tue, 10 August 2010 11:07 Go to previous messageGo to next message
Yves YANG is currently offline Yves YANGFriend
Messages: 687
Registered: July 2009
Senior Member
Please fill a bug. Thanks for the report.

Best regards
Yves YANG
"Mo P." <moritzpavlik@gmx.de> wrote in message
news:i3r8aa$f0p$1@build.eclipse.org...
> Hello,
>
> there are two employees in the TableViewer_MasterDetail_Edit test from
> package e4.xwt.tests.jface.tableviewer.master.detail.
>
> When I select one in the table, his name is displayed in the text field.
> When I change the text in the textfield, the objects attribute changes
> obviously (because when I deselect the employee and then select it again,
> the name in the text field is changed) but the text of the tableitem
> doesn't change at all. I think it is not refreshing properly.
>
> Thank you very much for all your help
>
> Regards
> Moritz
Re: Databinding: tableviewer does not refresh automatically [message #580448 is a reply to message #580348] Tue, 10 August 2010 12:39 Go to previous message
Mo P. is currently offline Mo P.Friend
Messages: 24
Registered: July 2010
Junior Member
Hi,

bug report has been created:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=322221

thanks a lot for your replies.
you want me to file a bug everytime I discover such things?
often i'm not sure if its a bug or wanted ;)
Previous Topic:e4: Find a placeholder
Next Topic:MPart vs. MPartDescriptor
Goto Forum:
  


Current Time: Wed Nov 26 16:48:15 GMT 2014

Powered by FUDForum. Page generated in 0.01550 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software