Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Egit failing to install for Eclipse 3.4.2
Egit failing to install for Eclipse 3.4.2 [message #579809] Tue, 27 April 2010 20:55 Go to next message
Jeff  is currently offline Jeff
Messages: 2
Registered: April 2010
Junior Member
When using the Software Updates manager to install the Egit plugin (0.8.0) on Eclipse 3.4.2 for windows I get dependency errors. I'm not sure what the problem is... any suggestions?

Cannot complete the request. See the details.
Unsatisfied dependency: [org.eclipse.egit.feature.group 0.7.1] requiredCapability: org.eclipse.equinox.p2.iu/com.jcraft.jsch/[0.1.41,1.0.0)
Unsatisfied dependency: [org.eclipse.jgit 0.7.1] requiredCapability: java.package/com.jcraft.jsch/[0.1.41,0.2.0)
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/com.jcraft.jsch/[0.1.41,0.2.0)
Cannot find a solution where both "com.jcraft.jsch [0.1.41,1.0.0)" and "com.jcraft.jsch [0.1.37.v200803061811]" are satisfied.
Unsatisfied dependency: [org.eclipse.jgit 0.7.1] requiredCapability: java.package/com.jcraft.jsch/[0.1.41,0.2.0)
Cannot find a solution where both "com.jcraft.jsch [0.1.41,1.0.0)" and "com.jcraft.jsch [0.1.37.v200803061811]" are satisfied.
Cannot find a solution where both "com.jcraft.jsch [0.1.41,1.0.0)" and "com.jcraft.jsch [0.1.37.v200803061811]" are satisfied.
Cannot find a solution where both "com.jcraft.jsch [0.1.41,1.0.0)" and "com.jcraft.jsch [0.1.37.v200803061811]" are satisfied.
Cannot find a solution where both "com.jcraft.jsch [0.1.41,1.0.0)" and "com.jcraft.jsch [0.1.37.v200803061811]" are satisfied.
Unsatisfied dependency: [org.eclipse.jgit 0.7.1] requiredCapability: java.package/com.jcraft.jsch/[0.1.41,0.2.0)
Unsatisfied dependency: [org.eclipse.egit.core 0.7.1] requiredCapability: java.package/org.eclipse.jgit.revwalk/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.core 0.7.1] requiredCapability: java.package/org.eclipse.jgit.dircache/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.core 0.7.1] requiredCapability: java.package/org.eclipse.jgit.treewalk/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.core 0.7.1] requiredCapability: java.package/org.eclipse.jgit.util/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.core 0.7.1] requiredCapability: java.package/org.eclipse.jgit.lib/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.core 0.7.1] requiredCapability: java.package/org.eclipse.jgit.transport/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.core 0.7.1] requiredCapability: java.package/org.eclipse.jgit.errors/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.core 0.7.1] requiredCapability: java.package/org.eclipse.jgit.treewalk.filter/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.feature.group 0.7.1] requiredCapability: org.eclipse.equinox.p2.iu/com.jcraft.jsch/[0.1.41,1.0.0)
Unsatisfied dependency: [org.eclipse.egit.feature.group 0.7.1] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.egit.core/0.0.0
Unsatisfied dependency: [org.eclipse.egit.feature.group 0.7.1] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.egit.ui/0.0.0
Unsatisfied dependency: [org.eclipse.egit.feature.group 0.7.1] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jgit.feature.group/[0. 7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.errors/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.diff/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.patch/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.egit.core.internal.storage/[0.7.1,0 .8.0)
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/com.jcraft.jsch/[0.1.41,0.2.0)
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.revwalk/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.revwalk.filter/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.merge/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.transport/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.revplot/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.lib/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.egit.core.project/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.egit.core/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.util/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.egit.core.op/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.treewalk/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.treewalk.filter/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.fnmatch/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.egit.core.internal.util/[0.7.1,0.8. 0)
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.util.io/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.dircache/0.6.0
Unsatisfied dependency: [org.eclipse.jgit.feature.group 0.7.1] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jgit/0.0.0
Re: Egit failing to install for Eclipse 3.4.2 [message #579821 is a reply to message #579809] Wed, 28 April 2010 18:29 Go to previous messageGo to next message
Robin Rosenberg is currently offline Robin Rosenberg
Messages: 331
Registered: July 2009
Senior Member
Jeff wrote:

> When using the Software Updates manager to install the Egit plugin
> (0.8.0) on Eclipse 3.4.2 for windows I get dependency errors. I'm not
> sure what the problem is... any suggestions?
>
> Cannot complete the request. See the details.
> Unsatisfied dependency: [org.eclipse.egit.feature.group 0.7.1]
> requiredCapability:

As this messages says, this is an error from trying to install 0.7.1
not 0.8.something.

-- robin
Re: Egit failing to install for Eclipse 3.4.2 [message #640430 is a reply to message #579821] Mon, 22 November 2010 04:08 Go to previous messageGo to next message
Kohei Sugimoto is currently offline Kohei Sugimoto
Messages: 2
Registered: November 2010
Junior Member
I realise this is a old thread, but was there a resolution to this issue? I would like to install EGit in Rational Software Architect 7.5.5, but am running into the same issues.

I have tried the nightly (0.10.0) and stable (0.9.3) update sites.

Thanks.
Re: Egit failing to install for Eclipse 3.4.2 [message #640634 is a reply to message #579809] Mon, 22 November 2010 16:29 Go to previous messageGo to next message
Chris Aniszczyk is currently offline Chris Aniszczyk
Messages: 674
Registered: July 2009
Senior Member
As of EGit 0.9, we only support back to Eclipse 3.5...

I'm not sure what RSA 7.5 is based on...

Also, any reason why you're using Eclipse 3.4.2? That's 3 years old now...
Re: Egit failing to install for Eclipse 3.4.2 [message #640728 is a reply to message #640634] Mon, 22 November 2010 22:45 Go to previous message
Kohei Sugimoto is currently offline Kohei Sugimoto
Messages: 2
Registered: November 2010
Junior Member
Ok, I suspected that may be the case. I am not choosing to use eclipse 3.4 (which RSA7.5 is based on), it is just a requirement. It is old, but I am not able to upgrade my RSA license at this stage. Thanks for the reply.

Are there repositories for pre-0.9 artifacts?
Previous Topic:Isn't there an "add" command line in jgit shell?
Next Topic:Buckminster Materialization and Decorations
Goto Forum:
  


Current Time: Sat Oct 25 16:50:23 GMT 2014

Powered by FUDForum. Page generated in 0.01630 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software