Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Unable to Update to EGit 0.7.1 from EGit 0.6 -- Ganymede 3.4.2
Unable to Update to EGit 0.7.1 from EGit 0.6 -- Ganymede 3.4.2 [message #578560] Wed, 24 March 2010 18:54 Go to next message
Dalmazio Brisinda is currently offline Dalmazio Brisinda
Messages: 4
Registered: March 2010
Junior Member
Hi all,

Was wondering if anyone has encountered this issue? I can't seem to upgrade to EGit 0.7.1 from a 0.6 installation on a Mac 10.6.2 running Eclipse Ganymede 3.4.2. This is the message I get when trying to update via the update site:

Cannot find a solution satisfying the following requirements org.eclipse.swt.carbon.macosx [3.4.0.v3448f].

Checking the eclipse plugins folder, there is a 3.4.2 SWT version installed:

org.eclipse.swt_3.4.2.v3452b.jar

Does EGit require a 3.4.0 version of SWT or is this a bug? If not a bug, does anyone know where can I find this? I can't seem to find it anywhere.

Any help would be appreciated.

Best,
Dalmazio
Re: Unable to Update to EGit 0.7.1 from EGit 0.6 -- Ganymede 3.4.2 [message #579414 is a reply to message #578560] Tue, 13 April 2010 18:57 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias Sohn
Messages: 556
Registered: July 2009
Senior Member
That's bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=307522 which has been fixed recently. You may try installing the latest dev build from http://download.eclipse.org/egit/updates-nightly
Re: Unable to Update to EGit 0.7.1 from EGit 0.6 -- Ganymede 3.4.2 [message #579965 is a reply to message #579414] Mon, 03 May 2010 20:45 Go to previous message
Dalmazio Brisinda is currently offline Dalmazio Brisinda
Messages: 4
Registered: March 2010
Junior Member
Thanks for your response. I'll grab the build.

However, I've noticed this exact problem on a number of other Eclipse softwares, including Visual Eclipse 1.4, the PTP parallel tools platform, Egit, and others. The error message is always the same, and so I'm wondering if there's something I can do by modifying some sort of dependency somewhere manually?

Perhaps it's time to upgrade to Galileo.

Best,
Dalmazio
Previous Topic:Unable to Update to EGit 0.7.1 from EGit 0.6 -- Ganymede 3.4.2
Next Topic:EGit seems to lock the index too aggressively (Windows)
Goto Forum:
  


Current Time: Thu Aug 21 04:16:02 EDT 2014

Powered by FUDForum. Page generated in 0.02239 seconds