Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Mobile Tools for Java (MTJ) » Build state machine has not been initialized
Build state machine has not been initialized [message #577850] Sat, 17 October 2009 10:45 Go to next message
Ugo Chirico is currently offline Ugo Chirico
Messages: 10
Registered: July 2009
Junior Member
Hi All,

I was using MTJ dsdp-mtj-runtime-incubation-1.0M7 and all was working fine,
I udpdated to the last version of MTJ 1.0.1 and now I'm not able to build all all of my J2ME applications.
I'm blocked now with all of my projects and I'm very irritated:

Please, help me!

The error is:

Errors during build.
Errors running builder 'Preprocessor Builder' on project 'miabo'.
Build state machine has not been initialized.
Errors running builder 'Preprocessor Builder' on project 'miabo'.
Build state machine has not been initialized.
Errors running builder 'Preverification Builder' on project 'miabo'.
Build state machine has not been initialized.

In the error log I see:

!ENTRY org.eclipse.mtj.core 4 0 2009-10-17 12:42:06.286
!MESSAGE Build state machine has not been initialized.
!STACK 1
org.eclipse.core.runtime.CoreException: Build state machine has not been initialized.
at org.eclipse.mtj.internal.core.build.BuildStateMachine.change State(Unknown Source)
at org.eclipse.mtj.internal.core.build.MTJCompilationParticipan t.aboutToBuild(Unknown Source)
at org.eclipse.jdt.internal.core.builder.JavaBuilder.initialize Builder(JavaBuilder.java:583)
at org.eclipse.jdt.internal.core.builder.JavaBuilder.clean(Java Builder.java:286)
at org.eclipse.core.internal.events.BuildManager$2.run(BuildMan ager.java:635)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:170)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:201)
at org.eclipse.core.internal.events.BuildManager$1.run(BuildMan ager.java:253)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:256)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:218)
at org.eclipse.core.internal.events.BuildManager.build(BuildMan ager.java:360)
at org.eclipse.core.internal.resources.Project.internalBuild(Pr oject.java:516)
at org.eclipse.core.internal.resources.Project.build(Project.ja va:94)
at org.eclipse.ui.internal.ide.dialogs.CleanDialog.doClean(Clea nDialog.java:305)
at org.eclipse.ui.internal.ide.dialogs.CleanDialog$1.runInWorks pace(CleanDialog.java:147)
at org.eclipse.core.internal.resources.InternalWorkspaceJob.run (InternalWorkspaceJob.java:38)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
!SUBENTRY 1 org.eclipse.mtj.core 4 999 2009-10-17 12:42:06.286
!MESSAGE Build state machine has not been initialized.

!ENTRY org.eclipse.core.resources 4 2 2009-10-17 12:42:06.879
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.core.resources".
!STACK 1
org.eclipse.core.runtime.CoreException: Build state machine has not been initialized.
at org.eclipse.mtj.internal.core.build.BuildStateMachine.change State(Unknown Source)
at org.eclipse.mtj.internal.core.build.MTJIncrementalProjectBui lder.onStateEnter(Unknown Source)
at org.eclipse.mtj.internal.core.build.MTJIncrementalProjectBui lder.build(Unknown Source)
at org.eclipse.core.internal.events.BuildManager$2.run(BuildMan ager.java:633)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:170)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:201)
at org.eclipse.core.internal.events.BuildManager$1.run(BuildMan ager.java:253)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:256)
at org.eclipse.core.internal.events.BuildManager.basicBuildLoop (BuildManager.java:309)
at org.eclipse.core.internal.events.BuildManager.build(BuildMan ager.java:341)
at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBu ildJob.java:140)
at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJ ob.java:238)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
!SUBENTRY 1 org.eclipse.mtj.core 4 999 2009-10-17 12:42:06.879
!MESSAGE Build state machine has not been initialized.
!SUBENTRY 1 org.eclipse.mtj.core 4 999 2009-10-17 12:42:06.879
!MESSAGE Build state machine has not been initialized.

!ENTRY org.eclipse.core.resources 4 2 2009-10-17 12:42:06.879
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.core.resources".
!STACK 1
org.eclipse.core.runtime.CoreException: Build state machine has not been initialized.
at org.eclipse.mtj.internal.core.build.BuildStateMachine.change State(Unknown Source)
at org.eclipse.mtj.internal.core.build.MTJIncrementalProjectBui lder.onStateEnter(Unknown Source)
at org.eclipse.mtj.internal.core.build.MTJIncrementalProjectBui lder.build(Unknown Source)
at org.eclipse.core.internal.events.BuildManager$2.run(BuildMan ager.java:633)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:170)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:201)
at org.eclipse.core.internal.events.BuildManager$1.run(BuildMan ager.java:253)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:256)
at org.eclipse.core.internal.events.BuildManager.basicBuildLoop (BuildManager.java:309)
at org.eclipse.core.internal.events.BuildManager.build(BuildMan ager.java:341)
at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBu ildJob.java:140)
at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJ ob.java:238)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
!SUBENTRY 1 org.eclipse.mtj.core 4 999 2009-10-17 12:42:06.879
!MESSAGE Build state machine has not been initialized.
!SUBENTRY 1 org.eclipse.mtj.core 4 999 2009-10-17 12:42:06.879
!MESSAGE Build state machine has not been initialized.

!ENTRY org.eclipse.mtj.core 4 0 2009-10-17 12:42:06.879
!MESSAGE Build state machine has not been initialized.
!STACK 1
org.eclipse.core.runtime.CoreException: Build state machine has not been initialized.
at org.eclipse.mtj.internal.core.build.BuildStateMachine.change State(Unknown Source)
at org.eclipse.mtj.internal.core.build.MTJCompilationParticipan t.aboutToBuild(Unknown Source)
at org.eclipse.jdt.internal.core.builder.JavaBuilder.initialize Builder(JavaBuilder.java:583)
at org.eclipse.jdt.internal.core.builder.JavaBuilder.build(Java Builder.java:167)
at org.eclipse.core.internal.events.BuildManager$2.run(BuildMan ager.java:633)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:170)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:201)
at org.eclipse.core.internal.events.BuildManager$1.run(BuildMan ager.java:253)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:256)
at org.eclipse.core.internal.events.BuildManager.basicBuildLoop (BuildManager.java:309)
at org.eclipse.core.internal.events.BuildManager.build(BuildMan ager.java:341)
at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBu ildJob.java:140)
at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJ ob.java:238)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
!SUBENTRY 1 org.eclipse.mtj.core 4 999 2009-10-17 12:42:06.879
!MESSAGE Build state machine has not been initialized.

!ENTRY org.eclipse.mtj.core 4 0 2009-10-17 12:42:08.020
!MESSAGE Build state machine has not been initialized.
!STACK 1
org.eclipse.core.runtime.CoreException: Build state machine has not been initialized.
at org.eclipse.mtj.internal.core.build.BuildStateMachine.change State(Unknown Source)
at org.eclipse.mtj.internal.core.build.MTJCompilationParticipan t.buildFinished(Unknown Source)
at org.eclipse.jdt.internal.core.builder.JavaBuilder.build(Java Builder.java:233)
at org.eclipse.core.internal.events.BuildManager$2.run(BuildMan ager.java:633)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:170)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:201)
at org.eclipse.core.internal.events.BuildManager$1.run(BuildMan ager.java:253)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:256)
at org.eclipse.core.internal.events.BuildManager.basicBuildLoop (BuildManager.java:309)
at org.eclipse.core.internal.events.BuildManager.build(BuildMan ager.java:341)
at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBu ildJob.java:140)
at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJ ob.java:238)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
!SUBENTRY 1 org.eclipse.mtj.core 4 999 2009-10-17 12:42:08.020
!MESSAGE Build state machine has not been initialized.

!ENTRY org.eclipse.core.resources 4 2 2009-10-17 12:42:08.020
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.core.resources".
!STACK 1
org.eclipse.core.runtime.CoreException: Build state machine has not been initialized.
at org.eclipse.mtj.internal.core.build.BuildStateMachine.change State(Unknown Source)
at org.eclipse.mtj.internal.core.build.MTJIncrementalProjectBui lder.onStateEnter(Unknown Source)
at org.eclipse.mtj.internal.core.build.MTJIncrementalProjectBui lder.build(Unknown Source)
at org.eclipse.core.internal.events.BuildManager$2.run(BuildMan ager.java:633)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:170)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:201)
at org.eclipse.core.internal.events.BuildManager$1.run(BuildMan ager.java:253)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:256)
at org.eclipse.core.internal.events.BuildManager.basicBuildLoop (BuildManager.java:309)
at org.eclipse.core.internal.events.BuildManager.build(BuildMan ager.java:341)
at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBu ildJob.java:140)
at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJ ob.java:238)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
!SUBENTRY 1 org.eclipse.mtj.core 4 999 2009-10-17 12:42:08.020
!MESSAGE Build state machine has not been initialized.
!SUBENTRY 1 org.eclipse.mtj.core 4 999 2009-10-17 12:42:08.020
!MESSAGE Build state machine has not been initialized.

!ENTRY org.eclipse.core.resources 4 75 2009-10-17 12:42:08.067
!MESSAGE Errors during build.
!SUBENTRY 1 org.eclipse.mtj.core 2 75 2009-10-17 12:42:08.067
!MESSAGE Errors running builder 'Preprocessor Builder' on project 'miabo'.
!SUBENTRY 1 org.eclipse.mtj.core 4 999 2009-10-17 12:42:08.067
!MESSAGE Build state machine has not been initialized.
!SUBENTRY 1 org.eclipse.mtj.core 2 75 2009-10-17 12:42:08.067
!MESSAGE Errors running builder 'Preprocessor Builder' on project 'miabo'.
!SUBENTRY 1 org.eclipse.mtj.core 4 999 2009-10-17 12:42:08.067
!MESSAGE Build state machine has not been initialized.
!SUBENTRY 1 org.eclipse.mtj.core 2 75 2009-10-17 12:42:08.067
!MESSAGE Errors running builder 'Preverification Builder' on project 'miabo'.
!SUBENTRY 1 org.eclipse.mtj.core 4 999 2009-10-17 12:42:08.067
!MESSAGE Build state machine has not been initialized.
Re: Build state machine has not been initialized [message #577929 is a reply to message #577850] Thu, 22 October 2009 12:06 Go to previous messageGo to next message
Diego Madruga Sandin is currently offline Diego Madruga Sandin
Messages: 59
Registered: July 2009
Member
Hi,

This problem was fixed during the 1.0.1 release. Could you try to import your projects into a clean workspace and report if the issue still occurs?

Thanks
Diego
Re: Build state machine has not been initialized [message #578030 is a reply to message #577929] Fri, 23 October 2009 08:12 Go to previous messageGo to next message
Ugo Chirico is currently offline Ugo Chirico
Messages: 10
Registered: July 2009
Junior Member
I already made as you suggest.
I spent 1 day to create a new project importing all sources, settings and cofigurations and now it works.
But I spent 1 day to do that (I waste 1 day for that work). :x
Without considering the SVN related issues to link the new project to old one.
And now I have to do that with all other projects. :x

Time is money and it isn't accetable that upgrading to the new version I have to waste so much time.

When Craig Setera was working on eclipseme this kind of issues never happend. Craig worked very well.
Now that MTJ is taking care of eclipsme I experimenting al lot of issues but this one is the worst till now.

Regards,

Ugo Chirico
http://www.cryptware.it
Re: Build state machine has not been initialized [message #578056 is a reply to message #578030] Fri, 23 October 2009 11:52 Go to previous messageGo to next message
Diego Madruga Sandin is currently offline Diego Madruga Sandin
Messages: 59
Registered: July 2009
Member
Hi,

we are NOT taking care of EclipseME. We used it as based to MTJ and evolved it a lot, with the help of Craig himself. MTJ is NOT EclipseME.

If you are not satisfied with the results, please, fell free to contribute on the discussions on the developer mailing list, post reports on bugs you found and request new features; This will help us improve MTJ.

Thanks,
Diego
Re: Build state machine has not been initialized [message #578798 is a reply to message #577929] Tue, 05 January 2010 10:25 Go to previous messageGo to next message
Eclipse User
Originally posted by: krischik.users.sourceforge.net

Diego Madruga Sandin schrieb:

> This problem was fixed during the 1.0.1 release. Could you try to import
> your projects into a clean workspace and report if the issue still occurs?

I have got the same problem and I must have created a half a dozed
"clean" workspaces today.

Honestly this is a real pain. Being a programmer myself: if the state
machine is not initialized: Why not initialize it instead of a useless
error message?

Note 1: All error messages without a proper course of action to rectify
the problem are useless.

Also a "clean" / "clean all" should initialize the state machine as well.

And why is this error message appearing when "automated build" is
switched off? If I did not request a build no preprocessing should
happen, shouldn't it?

Regards

Martin

--
mailto://krischik@users.sourceforge.net
Ada programming at: http://ada.krischik.com
Re: Build state machine has not been initialized [message #578996 is a reply to message #578798] Mon, 25 January 2010 19:16 Go to previous messageGo to next message
David Beers is currently offline David Beers
Messages: 17
Registered: July 2009
Location: Denver, CO
Junior Member

I'm experiencing this problem as well, first with 1.0 and then after updating to 1.0.1. For various reasons creating a new workspace is going to cost me a lot of time as well--enough that I would consider manually hacking the internal configuration of my workspace if I knew what to look for. If someone who knows the nature of the bug can suggest a way to give this a try, please do.

David Beers
MapQuest
Re: Build state machine has not been initialized [message #579005 is a reply to message #578996] Tue, 26 January 2010 20:07 Go to previous messageGo to next message
David Beers is currently offline David Beers
Messages: 17
Registered: July 2009
Location: Denver, CO
Junior Member

Follow-up: I checked out a fresh working copy from SVN, recreating the project in a new workspace and still get the same message.

Errors during build.
Errors running builder 'Preverification Builder' on project 'Midlet_MQ4M'.
Build state machine has not been initialized.

I've been using MTJ and the project in question daily for quite some time and can't fathom what suddenly caused this error to manifest.

Checking the Eclipse logs I see this entry prior to the error in question:
!ENTRY org.eclipse.mtj.core 4 0 2010-01-26 12:12:56.347
!MESSAGE Invalid MTJ Project.
!STACK 0
java.lang.IllegalArgumentException: Invalid MTJ Project.
at org.eclipse.mtj.internal.core.build.MTJBuildProperties.<init >(Unknown Source)
at org.eclipse.mtj.internal.core.build.MTJBuildProperties.getBu ildProperties(Unknown Source)
at org.eclipse.mtj.internal.core.util.MTJBuildPropertiesResourc eListener.updateBuildProperties(Unknown Source)
at org.eclipse.mtj.internal.core.util.MTJBuildPropertiesResourc eListener.resourceChanged(Unknown Source)
at org.eclipse.core.internal.events.NotificationManager$2.run(N otificationManager.java:288)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.core.internal.events.NotificationManager.notify( NotificationManager.java:282)
at org.eclipse.core.internal.events.NotificationManager.broadca stChanges(NotificationManager.java:148)
at org.eclipse.core.internal.resources.Workspace.broadcastPostC hange(Workspace.java:313)
at org.eclipse.core.internal.resources.Workspace.endOperation(W orkspace.java:1022)
at org.eclipse.core.internal.resources.Resource.refreshLocal(Re source.java:1497)
at org.eclipse.core.internal.resources.Project.open(Project.jav a:891)
at org.eclipse.core.internal.resources.Project.open(Project.jav a:911)
at org.eclipse.jdt.internal.ui.wizards.buildpaths.BuildPathsBlo ck.createProject(BuildPathsBlock.java:694)
at org.eclipse.jdt.ui.wizards.JavaCapabilityConfigurationPage.c reateProject(JavaCapabilityConfigurationPage.java:251)
at org.eclipse.jdt.ui.wizards.NewJavaProjectWizardPageTwo.updat eProject(NewJavaProjectWizardPageTwo.java:233)
at org.eclipse.jdt.ui.wizards.NewJavaProjectWizardPageTwo.acces s$2(NewJavaProjectWizardPageTwo.java:200)
at org.eclipse.jdt.ui.wizards.NewJavaProjectWizardPageTwo$1$Upd ateRunnable.run(NewJavaProjectWizardPageTwo.java:161)
at org.eclipse.ui.actions.WorkspaceModifyDelegatingOperation.ex ecute(WorkspaceModifyDelegatingOperation.java:69)
at org.eclipse.ui.actions.WorkspaceModifyOperation$1.run(Worksp aceModifyOperation.java:104)
at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1800)
at org.eclipse.ui.actions.WorkspaceModifyOperation.run(Workspac eModifyOperation.java:116)
at org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:121)


How can I help the developers characterize and resolve this critical bug? Until a fix is found I'm unable to build and run/debug our app in Eclipse. Were it not for dependencies on another project that is Maven-managed and links to stuff in a private repository, I would share it for someone to inspect. But if I'm able to reproduce it in a simpler sample project I'll certainly do so. Again, suggestions on

David Beers
MapQuest
Re: Build state machine has not been initialized [message #579023 is a reply to message #579005] Tue, 26 January 2010 20:14 Go to previous messageGo to next message
Ugo Chirico is currently offline Ugo Chirico
Messages: 10
Registered: July 2009
Junior Member
Hi David,

I solved the problem by creating a new project and importing all sources in such a new project.
After that I made some work to relink the new project to the old one on SVN.
I spent a lot of time on that but after the work was done all worked and I was able to compile my project again.

Unfortunately I had to do the same for all of my J2ME projects :(

Hoping this help.

Regards,
Ugo Chirico
http://www.ugosweb.com
Re: Build state machine has not been initialized [message #579041 is a reply to message #579023] Tue, 26 January 2010 22:43 Go to previous messageGo to next message
David Beers is currently offline David Beers
Messages: 17
Registered: July 2009
Location: Denver, CO
Junior Member

I took a stab at your suggestion, Ugo, but for for reasons peculiar to our build configuration it will be an extremely painful option to carry out. Reverting to MTJ v0.9.1 required a little fiddling around but it didn't take too long and seems to solve the problem, so that's what I have done for the time being.

David Beers
MapQuest
Re: Build state machine has not been initialized [message #579814 is a reply to message #577850] Thu, 18 March 2010 10:34 Go to previous messageGo to next message
Mario Balaban is currently offline Mario Balaban
Messages: 5
Registered: July 2009
Junior Member
Hello, I have the same issue, suddenly one day, I'm not able to create the midlet packages. (I am working on Ubuntu 9.10, with Eclipse Galileo, jdk6) To reproduce the poblem I have created a new workspace, set the device configuration to WTK 2.5.2_01, then a new midlet project, then a new midlet (splash screen from templates). Initially it compiled, the package was created and it ran on the emulator. Then I restarted eclipse with the same workspace, made a modification to the source (modified a comment) and tried to recreate the package. And voila !
Build state machine has not been initialized !

This is a piece of the .log file from the workspace:

!SESSION 2010-03-18 11:21:21.808 -----------------------------------------------
eclipse.buildId=
java.version=1.6.0_14
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=it_IT
Framework arguments: -product org.eclipse.epp.package.jee.product -showlocation
Command-line arguments: -os linux -ws gtk -arch x86 -product org.eclipse.epp.package.jee.product -clean -showlocation

!ENTRY org.eclipse.core.resources 4 2 2010-03-18 11:23:24.249
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.core.resources".
!STACK 1
org.eclipse.core.runtime.CoreException: Build state machine has not been initialized.
at org.eclipse.mtj.internal.core.build.BuildStateMachine.change State(Unknown Source)
at org.eclipse.mtj.internal.core.build.MTJIncrementalProjectBui lder.onStateEnter(Unknown Source)
at org.eclipse.mtj.internal.core.build.MTJIncrementalProjectBui lder.build(Unknown Source)
at org.eclipse.core.internal.events.BuildManager$2.run(BuildMan ager.java:627)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:170)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:201)
at org.eclipse.core.internal.events.BuildManager$1.run(BuildMan ager.java:253)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:256)
at org.eclipse.core.internal.events.BuildManager.basicBuild(Bui ldManager.java:218)
at org.eclipse.core.internal.events.BuildManager.build(BuildMan ager.java:360)
at org.eclipse.core.internal.resources.Project$1.run(Project.ja va:523)
at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1800)
at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1782)
at org.eclipse.core.internal.resources.Project.internalBuild(Pr oject.java:502)
at org.eclipse.core.internal.resources.Project.build(Project.ja va:94)
at org.eclipse.mtj.internal.core.project.midp.MidletSuiteProjec t.createPackage(Unknown Source)
at org.eclipse.mtj.internal.ui.actions.packaging.AbstractCreate PackageAction.createPackageForProject(Unknown Source)
at org.eclipse.mtj.internal.ui.actions.packaging.AbstractCreate PackageAction.access$0(Unknown Source)
at org.eclipse.mtj.internal.ui.actions.packaging.AbstractCreate PackageAction$1.run(Unknown Source)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.mtj.internal.ui.actions.packaging.AbstractCreate PackageAction.doPackageCreation(Unknown Source)
at org.eclipse.mtj.internal.ui.actions.packaging.AbstractCreate PackageAction.run(Unknown Source)
at org.eclipse.ui.internal.PluginAction.runWithEvent(PluginActi on.java:251)
at org.eclipse.jface.action.ActionContributionItem.handleWidget Selection(ActionContributionItem.java:584)
at org.eclipse.jface.action.ActionContributionItem.access$2(Act ionContributionItem.java:501)
at org.eclipse.jface.action.ActionContributionItem$5.handleEven t(ActionContributionItem.java:411)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1176)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.ja va:3493)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3112)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2405)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2369)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:22 21)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)
at org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:493)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start (IDEApplication.java:113)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:194)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
at org.eclipse.equinox.launcher.Main.main(Main.java:1287)
!SUBENTRY 1 org.eclipse.mtj.core 4 999 2010-03-18 11:23:24.251
!MESSAGE Build state machine has not been initialized.
!SUBENTRY 1 org.eclipse.mtj.core 4 999 2010-03-18 11:23:24.251
!MESSAGE Build state machine has not been initialized.


Any solutions?
Re: Build state machine has not been initialized [message #579877 is a reply to message #579814] Mon, 22 March 2010 19:16 Go to previous messageGo to next message
Eclipse User
Originally posted by: krischik.users.sourceforge.net

Am 18.03.2010, 11:34 Uhr, schrieb Mario Balaban <extremepredator@mail.ru>:

> Then I restarted eclipse with the same workspace, made a modification to
> the source (modified a comment) and tried to recreate the package. And
> voila ! Build state machine has not been initialized !

This is a painful and persistent one. I for once changed to Maven based
builds in the end and never looked back.

Regards

Martin
--
Martin Krischik
Re: Build state machine has not been initialized [message #579898 is a reply to message #579814] Mon, 22 March 2010 19:20 Go to previous message
Eclipse User
Originally posted by: krischik.users.sourceforge.net

Am 18.03.2010, 11:34 Uhr, schrieb Mario Balaban <extremepredator@mail.ru>:

> Then I restarted eclipse with the same workspace, made a modification to
> the source (modified a comment) and tried to recreate the package. And
> voila ! Build state machine has not been initialized !

This is a painful and persisted one.

> Any solutions?

I for one changed to Maven based builds in the end and I never looked
back. The Maven plugin for Java ME works great - I can even build on Mac
OS X.

Martin

--
Martin Krischik
Previous Topic:Local File History
Next Topic:Build state machine has not been initialized
Goto Forum:
  


Current Time: Sat Oct 25 09:37:57 GMT 2014

Powered by FUDForum. Page generated in 0.02280 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software