Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » InactiveProcessException when starting TPTP JUnit Plugin
InactiveProcessException when starting TPTP JUnit Plugin [message #58298] Wed, 15 March 2006 07:20 Go to next message
kiril mitov is currently offline kiril mitovFriend
Messages: 128
Registered: July 2009
Senior Member
I have followed the guide for creating a TPTP JUnit Plugin test that is
located
at:
http://help.eclipse.org/help31/index.jsp?topic=/org.eclipse. hyades.test.doc.user/concepts/cintro.htm

Finnaly I click on the testsuite file and select Run As -> Run..., and then
select the test suite and the deployment. When I click on the Run button a
progress monitor is shown wiht the task "Preparing and deploying". But the
task never ends - the following exception is thrown:

org.eclipse.hyades.internal.execution.local.control.Inactive ProcessException
at
org.eclipse.hyades.execution.harness.TestExecutionHarnessExe cutorStub.launch(TestExecutionHarnessExecutorStub.java:417)
at
org.eclipse.hyades.execution.harness.TestExecutionHarness.la unchTestExecution(TestExecutionHarness.java:2058)
at
org.eclipse.hyades.execution.harness.TestExecutionHarness.ac cess$2(TestExecutionHarness.java:1856)
at
org.eclipse.hyades.execution.harness.TestExecutionHarness$2. run(TestExecutionHarness.java:692)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)

The session data of the exception is:
eclipse.buildId=I20051215-1506
java.version=1.5.0_05
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=bg_BG
Command-line arguments: -data /home/kiril/work/workspace -os linux -ws gtk
-arch x86

I use eclipse3.2M5 and I have downloaded
http://www.eclipse.org/tptp/home/downloads/drops/TPTP-4.2.0- 200603140100.html

I use a remote Agent Controler.
Re: InactiveProcessException when starting TPTP JUnit Plugin [message #58689 is a reply to message #58298] Wed, 15 March 2006 22:04 Go to previous messageGo to next message
Randy D. Smith is currently offline Randy D. SmithFriend
Messages: 394
Registered: July 2009
Senior Member
Eclipse built on 12/15/2005 was 3.2M*4*. Again, to run with TPTP 4.2M5
(02/28 and beyond) you need 3.2M5a (built 02/23/2006).
--
RDS


kiril mitov wrote:
> I have followed the guide for creating a TPTP JUnit Plugin test that is
> located
> at:
> http://help.eclipse.org/help31/index.jsp?topic=/org.eclipse. hyades.test.doc.user/concepts/cintro.htm
>
>
> Finnaly I click on the testsuite file and select Run As -> Run..., and then
> select the test suite and the deployment. When I click on the Run button a
> progress monitor is shown wiht the task "Preparing and deploying". But
> the task never ends - the following exception is thrown:
>
> org.eclipse.hyades.internal.execution.local.control.Inactive ProcessException
>
> at
> org.eclipse.hyades.execution.harness.TestExecutionHarnessExe cutorStub.launch(TestExecutionHarnessExecutorStub.java:417)
>
> at
> org.eclipse.hyades.execution.harness.TestExecutionHarness.la unchTestExecution(TestExecutionHarness.java:2058)
>
> at
> org.eclipse.hyades.execution.harness.TestExecutionHarness.ac cess$2(TestExecutionHarness.java:1856)
>
> at
> org.eclipse.hyades.execution.harness.TestExecutionHarness$2. run(TestExecutionHarness.java:692)
>
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)
>
> The session data of the exception is:
> eclipse.buildId=I20051215-1506
> java.version=1.5.0_05
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=bg_BG
> Command-line arguments: -data /home/kiril/work/workspace -os linux -ws gtk
> -arch x86
>
> I use eclipse3.2M5 and I have downloaded
> http://www.eclipse.org/tptp/home/downloads/drops/TPTP-4.2.0- 200603140100.html
>
>
> I use a remote Agent Controler.
>
>
Re: InactiveProcessException when starting TPTP JUnit Plugin [message #59373 is a reply to message #58689] Mon, 20 March 2006 17:11 Go to previous messageGo to next message
kiril mitov is currently offline kiril mitovFriend
Messages: 128
Registered: July 2009
Senior Member
I have downloaded the eclipse 3.2 M5a
and I could not make it work.

The same problem still occures.
Re: InactiveProcessException when starting TPTP JUnit Plugin [message #59458 is a reply to message #59373] Mon, 20 March 2006 23:45 Go to previous messageGo to next message
Randy D. Smith is currently offline Randy D. SmithFriend
Messages: 394
Registered: July 2009
Senior Member
If someone on the TPTP team that isn't tied up at EclipseCon this week
has an opportunity to look into this, Kiril has MUCH more extensive info
on the problem up at the end of the long chain entitled "TPTP crashes
eclipse help".
--
RDS


kiril mitov wrote:
> I have downloaded the eclipse 3.2 M5a and I could not make it work.
> The same problem still occures.
>
Re: InactiveProcessException when starting TPTP JUnit Plugin [message #64435 is a reply to message #59458] Wed, 05 April 2006 15:51 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: alberto.devega.thalesgroup.com

I have the same problem here. I record an HTTP test, generate the code and
so on, and when I try to Run the Test, I get this error:

!ENTRY org.eclipse.hyades.test.core 1 0 2006-04-05 17:28:36.687
!MESSAGE
org.eclipse.hyades.internal.execution.local.control.Inactive ProcessException
!STACK 0
org.eclipse.hyades.internal.execution.local.control.Inactive ProcessException
at
org.eclipse.hyades.execution.harness.TestExecutionHarnessExe cutorStub.launch(TestExecutionHarnessExecutorStub.java:417)
at
org.eclipse.hyades.execution.harness.TestExecutionHarness.la unchTestExecution(TestExecutionHarness.java:2058)
at
org.eclipse.hyades.execution.harness.TestExecutionHarness.ac cess$2(TestExecutionHarness.java:1856)
at
org.eclipse.hyades.execution.harness.TestExecutionHarness$2. run(TestExecutionHarness.java:692)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:76)

!ENTRY org.eclipse.hyades.test.core 1 0 2006-04-05 17:30:04.843
!MESSAGE
org.eclipse.hyades.internal.execution.local.control.Inactive ProcessException
!STACK 0
org.eclipse.hyades.internal.execution.local.control.Inactive ProcessException
at
org.eclipse.hyades.execution.harness.TestExecutionHarnessExe cutorStub.launch(TestExecutionHarnessExecutorStub.java:417)
at
org.eclipse.hyades.execution.harness.TestExecutionHarness.la unchTestExecution(TestExecutionHarness.java:2058)
at
org.eclipse.hyades.execution.harness.TestExecutionHarness.ac cess$2(TestExecutionHarness.java:1856)
at
org.eclipse.hyades.execution.harness.TestExecutionHarness$2. run(TestExecutionHarness.java:692)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:76)


My configuration:

eclipse.buildId=M20060118-1600
java.version=1.4.2_03
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=es_ES
Command-line arguments: -os win32 -ws win32 -arch x86

Eclipse 3.1.2
TPTP 4.1.0.1

Thanks in advance
Re: InactiveProcessException when starting TPTP JUnit Plugin [message #66358 is a reply to message #64435] Thu, 13 April 2006 16:50 Go to previous message
Eclipse UserFriend
Originally posted by: bharat51.hotmail.com

Hi Guys,
Did you manage to resolve this InactiveProcessExceptionIssue??
Cheers
Bharat
Previous Topic:AGR: Headless test run
Next Topic:GUI recorder - wait until job completed
Goto Forum:
  


Current Time: Mon Dec 22 15:06:05 GMT 2014

Powered by FUDForum. Page generated in 0.01827 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software