Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IMP » Problems with hyperlinking service
Problems with hyperlinking service [message #577249] Mon, 01 February 2010 15:11 Go to next message
Margus Freudenthal is currently offline Margus FreudenthalFriend
Messages: 12
Registered: February 2010
Junior Member
Hi,

I am trying to create an IDE for my language using IMP. In general everything works fine and is a joy to use. However, I cannot get the hyperlinking service to work. I added the hyperlinking service (as I understand, I do not need to do anything here) and reference resolving service. When I hover the mouse over a token, the reference resolver's getLinkTarget() method is called. I return an AST node for a definition of that identifier. When I hold down ctrl, the token becomes underlined, just like in JDT. However, when I click on the underlined link, nothing happens.

What can be the problem? I use a custom ANTLR-based parser and I have implemented my own ParseController and SourceLocator. Other services (outlining, folding, tooltips, content completion, syntax colouring) work fine, so I assume that these services should be correct.

Can you point me to some directions? The documentation doesn't say much about reference resolving and linking except that they do exist and give examples based on LEG. Are there some common errors that people typically make?

--
--
Margus


Margus
Re: Problems with hyperlinking service [message #577300 is a reply to message #577249] Wed, 24 February 2010 21:30 Go to previous message
Robert M. Fuhrer is currently offline Robert M. FuhrerFriend
Messages: 294
Registered: July 2009
Senior Member
On 2/1/10 10:11 AM, Margus Freudenthal wrote:
> Hi,
>
> I am trying to create an IDE for my language using IMP. In general
> everything works fine and is a joy to use. However, I cannot get the
> hyperlinking service to work. I added the hyperlinking service (as I
> understand, I do not need to do anything here) and reference resolving
> service. When I hover the mouse over a token, the reference resolver's
> getLinkTarget() method is called. I return an AST node for a definition
> of that identifier. When I hold down ctrl, the token becomes underlined,
> just like in JDT. However, when I click on the underlined link, nothing
> happens.
>
> What can be the problem? I use a custom ANTLR-based parser and I have
> implemented my own ParseController and SourceLocator. Other services
> (outlining, folding, tooltips, content completion, syntax colouring)
> work fine, so I assume that these services should be correct.

The SourceLocator has to understand whatever type of object the reference
resolver produces. Perhaps that's the problem?

--
Cheers,
-- Bob

--------------------------------
Robert M. Fuhrer
Research Staff Member
Programming Technologies Dept.
IBM T.J. Watson Research Center

IDE Meta-tooling Platform Project Lead (http://www.eclipse.org/imp)
X10: Productive High-Performance Parallel Programming (http://x10.sf.net)
Previous Topic:ide for a language embedded in java
Next Topic:Cannot uninstall IMP
Goto Forum:
  


Current Time: Mon Dec 22 06:29:18 GMT 2014

Powered by FUDForum. Page generated in 0.21851 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software