Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IMP » New installation doesn't create Ast package
New installation doesn't create Ast package [message #577143] Sat, 26 December 2009 21:09 Go to next message
Rosco  is currently offline Rosco
Messages: 12
Registered: December 2009
Junior Member
Hi All,

I'm a newbie to Eclipse and IMP, thought I'd give it a try to implement an IDE for NBC, a language for the LEGO Mindstorms NXT brick, see: http://bricxcc.sourceforge.net/nbc/

This is mostly an exercise in learning the tools, but I don't seem to be able to get IMP up and running.

I've installed Galileo 3.5.1, IMP 0.1.88, LPG 2.0.17 and Polyglot 2.4.0, and I'm trying to follow the user guide. I created a new plugin, added a Prgramming Languge Descriptor, all seems to work fine, but when I create a LPG Grammar with Parser Wrapper for IMP, It creates skeleton .g and .gi files, NbcASTNodeLocater and NbcParseController classes, but no Ast package, so the classes don't work. In the Eclipse error log it has errors like:

Failed to create extension: astAdapter
org.eclipse.imp.utils.ExtensionException: No such language service extension point defined: org.eclipse.imp.runtime.astAdapter
at org.eclipse.imp.utils.ExtensionFactory.createServiceExtensio nForPlugin(ExtensionFactory.java:115)
at org.eclipse.imp.utils.ExtensionFactory.createServiceExtensio nForPlugin(ExtensionFactory.java:156)
at org.eclipse.imp.utils.ExtensionFactory.createServiceExtensio n(ExtensionFactory.java:53)
....

and

An internal error occurred during: "LPG ParserScheduler for NbcParser.g".
java.lang.NullPointerException
at org.eclipse.imp.parser.SimpleLPGParseController.isKeyword(Si mpleLPGParseController.java:186)
at org.eclipse.imp.lpg.editor.TokenColorer.getColoring(TokenCol orer.java:58)
...

and

Error running parser for language LPG and input NbcParser.g:
java.lang.NullPointerException
at org.eclipse.core.internal.runtime.Activator.getURLConverter( Activator.java:313)
at org.eclipse.core.runtime.FileLocator.toFileURL(FileLocator.j ava:205)
at org.eclipse.imp.lpg.builder.LPGBuilder.getDefaultIncludePath (LPGBuilder.java:392)
...

Note, I had to import lpg.generator.win32_x86 into my workspace to get the lpgexe to work, but it now seems to work fine, I can run it from the command line. Running it on the skeleton .g & .gi files creates a whole bunch of classes, but still no Ast package.

Can anyone point me in the right direction?

Thanks in advance

ROSCO
Re: New installation doesn't create Ast package [message #577354 is a reply to message #577143] Wed, 24 February 2010 21:35 Go to previous messageGo to next message
Robert M. Fuhrer is currently offline Robert M. Fuhrer
Messages: 294
Registered: July 2009
Senior Member
Hi,

I just noticed that no one responded to this message. [Sorry! Thought I
had already...]

The version of IMP you're using is pretty old. Have you given this a try
with something more recent?

On 12/26/09 4:09 PM, Rosco wrote:
> Hi All,
>
> I'm a newbie to Eclipse and IMP, thought I'd give it a try to implement
> an IDE for NBC, a language for the LEGO Mindstorms NXT brick, see:
> http://bricxcc.sourceforge.net/nbc/
>
> This is mostly an exercise in learning the tools, but I don't seem to be
> able to get IMP up and running.
>
> I've installed Galileo 3.5.1, IMP 0.1.88, LPG 2.0.17 and Polyglot 2.4.0,
> and I'm trying to follow the user guide. I created a new plugin, added a
> Prgramming Languge Descriptor, all seems to work fine, but when I create
> a LPG Grammar with Parser Wrapper for IMP, It creates skeleton .g and
> .gi files, NbcASTNodeLocater and NbcParseController classes, but no Ast
> package, so the classes don't work. In the Eclipse error log it has
> errors like:
>
> Failed to create extension: astAdapter
> org.eclipse.imp.utils.ExtensionException: No such language service
> extension point defined: org.eclipse.imp.runtime.astAdapter
> at org.eclipse.imp.utils.ExtensionFactory.createServiceExtensio
> nForPlugin(ExtensionFactory.java:115)
> at org.eclipse.imp.utils.ExtensionFactory.createServiceExtensio
> nForPlugin(ExtensionFactory.java:156)
> at org.eclipse.imp.utils.ExtensionFactory.createServiceExtensio
> n(ExtensionFactory.java:53)
> ...
>
> and
> An internal error occurred during: "LPG ParserScheduler for NbcParser.g".
> java.lang.NullPointerException
> at org.eclipse.imp.parser.SimpleLPGParseController.isKeyword(Si
> mpleLPGParseController.java:186)
> at org.eclipse.imp.lpg.editor.TokenColorer.getColoring(TokenCol
> orer.java:58)
> ..
>
> and
>
> Error running parser for language LPG and input NbcParser.g:
> java.lang.NullPointerException
> at org.eclipse.core.internal.runtime.Activator.getURLConverter(
> Activator.java:313)
> at org.eclipse.core.runtime.FileLocator.toFileURL(FileLocator.j ava:205)
> at org.eclipse.imp.lpg.builder.LPGBuilder.getDefaultIncludePath
> (LPGBuilder.java:392)
> ..
>
> Note, I had to import lpg.generator.win32_x86 into my workspace to get
> the lpgexe to work, but it now seems to work fine, I can run it from the
> command line. Running it on the skeleton .g & .gi files creates a whole
> bunch of classes, but still no Ast package.
>
> Can anyone point me in the right direction?

--
Cheers,
-- Bob

--------------------------------
Robert M. Fuhrer
Research Staff Member
Programming Technologies Dept.
IBM T.J. Watson Research Center

IDE Meta-tooling Platform Project Lead (http://www.eclipse.org/imp)
X10: Productive High-Performance Parallel Programming (http://x10.sf.net)
Re: New installation doesn't create Ast package [message #577583 is a reply to message #577143] Fri, 12 March 2010 22:04 Go to previous messageGo to next message
Rosco  is currently offline Rosco
Messages: 12
Registered: December 2009
Junior Member
Hi Bob, thanks for the response.

Yes I am using the Update Manager. I reverted back to before I started all this, and tried again.

BTW I'm using the update site at http://download.eclipse.org/technology/imp/updates/ is that correct?

I chose the IMP IDE runtime, but expanded it and de-selected the IMP support for java hosted languages, as my project is not based on Java. The confirmation screen showed only the runtime and source formatting packages. I confirmed, it got to the end but then got another dependency error:

Cannot complete the install because one or more required items could not be found.
Software currently installed: IMP Source Formatting Support (Incubation) 0.1.5 (org.eclipse.imp.formatting.feature.group 0.1.5)
Missing requirement: Box Formatting Plug-in (Incubation) 0.1.14 (org.eclipse.imp.box 0.1.14) requires 'bundle org.eclipse.imp.smapifier 0.0.0' but it could not be found
Cannot satisfy dependency:
From: IMP Source Formatting Support (Incubation) 0.1.5 (org.eclipse.imp.formatting.feature.group 0.1.5)
To: org.eclipse.imp.box [0.1.14]

ROSCO
Re: New installation doesn't create Ast package [message #577602 is a reply to message #577583] Sat, 13 March 2010 21:19 Go to previous message
Robert M. Fuhrer is currently offline Robert M. Fuhrer
Messages: 294
Registered: July 2009
Senior Member
On 3/12/10 5:04 PM, Rosco wrote:
> Hi Bob, thanks for the response.
>
> Yes I am using the Update Manager. I reverted back to before I started
> all this, and tried again.
>
> BTW I'm using the update site at
> http://download.eclipse.org/technology/imp/updates/ is that correct?

Yes, that's the right update site URL.

> I chose the IMP IDE runtime, but expanded it and de-selected the IMP
> support for java hosted languages, as my project is not based on Java.
> The confirmation screen showed only the runtime and source formatting
> packages. I confirmed, it got to the end but then got another dependency
> error:

Are you saying that the source formatting feature was automatically selected
for you, or that you selected it? If you selected it, do you need the source
formatting support?

> Cannot complete the install because one or more required items could not
> be found.
> Software currently installed: IMP Source Formatting Support (Incubation)
> 0.1.5 (org.eclipse.imp.formatting.feature.group 0.1.5)
> Missing requirement: Box Formatting Plug-in (Incubation) 0.1.14
> (org.eclipse.imp.box 0.1.14) requires 'bundle org.eclipse.imp.smapifier
> 0.0.0' but it could not be found
> Cannot satisfy dependency:
> From: IMP Source Formatting Support (Incubation) 0.1.5
> (org.eclipse.imp.formatting.feature.group 0.1.5)
> To: org.eclipse.imp.box [0.1.14]

Hmmm... I didn't think box should depend on smapifier (which is in the
java-hosted language support feature). I'll have to look into that.

--
Cheers,
-- Bob

--------------------------------
Robert M. Fuhrer
Research Staff Member
Programming Technologies Dept.
IBM T.J. Watson Research Center

IDE Meta-tooling Platform Project Lead (http://www.eclipse.org/imp)
X10: Productive High-Performance Parallel Programming (http://x10.sf.net)
Previous Topic:Deployment of IMP based IDE
Next Topic:New release of IMP available on update site and downloads page
Goto Forum:
  


Current Time: Wed Sep 17 23:41:01 GMT 2014

Powered by FUDForum. Page generated in 0.01787 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software