Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Extensions broken in e4?
Extensions broken in e4? [message #577116] Fri, 04 June 2010 07:39
David Wynter is currently offline David Wynter
Messages: 4547
Registered: July 2009
Senior Member
Hi,

Followed this tutorial here - http://www.vogella.de/articles/EclipseExtensionPoint/article .html using e4 M6

The extension point creation works fine. But when I go to create the extension itself instead of the extension point id showing in the Extensions dialog after hitting the Add... button I get a listing that shows the plugin name (where the EP is defined) concatenated with the extension point id. If I select this to Add, then that works, but then clicking on the "Open extension point schema" link throws


at org.eclipse.pde.internal.core.schema.SchemaDescriptor.<init >(SchemaDescriptor.java:46)
at org.eclipse.pde.internal.ui.editor.schema.SchemaInputContext .createExternalModel(SchemaInputContext.java:76)
at org.eclipse.pde.internal.ui.editor.schema.SchemaInputContext .createModel(SchemaInputContext.java:57)
at org.eclipse.pde.internal.ui.editor.context.InputContext.crea te(InputContext.java:134)
at org.eclipse.pde.internal.ui.editor.schema.SchemaInputContext . <init>(SchemaInputContext.java:42)
at org.eclipse.pde.internal.ui.editor.schema.SchemaEditor.creat eSystemFileContexts(SchemaEditor.java:103)
at org.eclipse.pde.internal.ui.editor.PDEFormEditor.createInput Contexts(PDEFormEditor.java:206)


If I edit the plugin.xml directly to use the proper EP Id then it says it does not exist. Looks to me like the plugin publishing the EP is using the concatenated plugin mae and EP Id and the plugin providing the Extension expects just the EP Id.

Thx.

David
Previous Topic:Opening the e4 workbench designer distorts the screen
Next Topic:Dynamic Part
Goto Forum:
  


Current Time: Fri Aug 22 07:52:07 EDT 2014

Powered by FUDForum. Page generated in 0.01560 seconds