Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » P2 » Update Eclipse-based product
Update Eclipse-based product [message #576234] Fri, 10 September 2010 20:40
Marcelo Bossoni is currently offline Marcelo BossoniFriend
Messages: 3
Registered: July 2009
Junior Member
Hi there,

I'm trying to update my Eclipse-based product without success.

The scenario is the following:

I have a "feature A" that depends on "org.eclipse.platform"
I have a product configuration that includes only the "feature A"

I've installed the org.eclipse.platform as top feature of my product after the installation of my product to allow me search for updates for "org.eclipse.platform" but when i try to find updates I get the following:


Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse Platform 3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L (org.eclipse.platform.feature.group 3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L)
Software currently installed: My Product 2.0.0 (com.myproduct 2.0.0)
Only one of the following can be installed at once:
Equinox Launcher Win32 X86_64 Fragment 1.1.0.v20100503 (org.eclipse.equinox.launcher.win32.win32.x86_64 1.1.0.v20100503)
Equinox Launcher Win32 X86_64 Fragment 1.1.1.R36x_v20100810 (org.eclipse.equinox.launcher.win32.win32.x86_64 1.1.1.R36x_v20100810)
Cannot satisfy dependency:
From: My Product 2.0.0 (com.myproduct 2.0.0)
To: org.eclipse.equinox.launcher.win32.win32.x86_64 [1.1.0.v20100503]
Cannot satisfy dependency:
From: Eclipse Platform 3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L (org.eclipse.platform.feature.group 3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L)
To: org.eclipse.rcp.feature.group [3.6.1.r361_v20100827-9OArFLdFjY-ThSQXmKvKz0_T]
Cannot satisfy dependency:
From: Eclipse RCP 3.6.1.r361_v20100827-9OArFLdFjY-ThSQXmKvKz0_T (org.eclipse.rcp.feature.group 3.6.1.r361_v20100827-9OArFLdFjY-ThSQXmKvKz0_T)
To: org.eclipse.equinox.launcher.win32.win32.x86_64 [1.1.1.R36x_v20100810]



Anything I can do to make my Eclipse base updateable?
Previous Topic:Update Eclipse-based product
Next Topic:p2 can't find a bundle in repo, if both jar and pack.gz form is available
Goto Forum:
  


Current Time: Fri Dec 19 21:52:21 GMT 2014

Powered by FUDForum. Page generated in 0.01768 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software