Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » OSEE » Problem Trying a New Installation
Problem Trying a New Installation [message #575622] Tue, 22 September 2009 06:55
Ray Joseph is currently offline Ray Joseph
Messages: 87
Registered: July 2009
Member
I could sure use some help. I would like to use the newest builds and instructions.

When I go to the download page, I only see the old version .7, similar with the documentation wiki.

Where can I get the new build and instructions?
__________________

So I am taking a new path for me. I am currently following the instructions from: http://wiki.eclipse.org/OSEE/Developers_Guide

Everything seems to progress until I get to installing Xtext. The installation fails. I have restarted Eclipse a couple times with no luck. Xtext has four components so I attempted to install each individually with no luck. Here are the errors for each of the four components:

TMF: instructions say TMF XText SDK, Eclipse says TMF XTEXT SDK (Incubation) 0.7.2RC1 S200908110347
Cannot complete the install because one or more required items could not be found.
Software being installed: Xtext Runtime (Incubation) 0.7.2.v200908110347 (org.eclipse.xtext.runtime.feature.group 0.7.2.v200908110347)
Missing requirement: Xtext (Incubation) 0.7.2.v200908110347 (org.eclipse.xtext 0.7.2.v200908110347) requires 'bundle org.eclipse.emf.ecore 2.5.0' but it could not be found
Cannot satisfy dependency:
From: Xtext Runtime (Incubation) 0.7.2.v200908110347 (org.eclipse.xtext.runtime.feature.group 0.7.2.v200908110347)
To: org.eclipse.xtext [0.7.2.v200908110347]

Xtext:
Cannot complete the install because one or more required items could not be found.
Software being installed: Xtext Antlr Feature 0.7.2.200908111925 (de.itemis.xtext.antlr.feature.feature.group 0.7.2.200908111925)
Missing requirement: Xtext (Incubation) 0.7.2.v200908110347 (org.eclipse.xtext 0.7.2.v200908110347) requires 'bundle org.eclipse.emf.ecore 2.5.0' but it could not be found
Cannot satisfy dependency:
From: Antlr-Tool Connector for Xtext 0.7.2.200908111925 (de.itemis.xtext.antlr 0.7.2.200908111925)
To: bundle org.eclipse.xtext 0.7.2
Cannot satisfy dependency:
From: Xtext Antlr Feature 0.7.2.200908111925 (de.itemis.xtext.antlr.feature.feature.group 0.7.2.200908111925)
To: de.itemis.xtext.antlr [0.7.2.200908111925]

EMFT:
Cannot complete the install because one or more required items could not be found.
Software being installed: MWE Core (Incubation) 0.7.2.v200908101326 (org.eclipse.emf.mwe.core.feature.group 0.7.2.v200908101326)
Missing requirement: MWE Core (Incubation) 0.7.2.v200908101326 (org.eclipse.emf.mwe.core.feature.group 0.7.2.v200908101326) requires 'org.apache.commons.lang [2.1.0.v200803061811]' but it could not be found

M2T: Instructions say M2T XPAND SDK 0.7.2RC1, Eclipse says TMF XTEXT SDK (Incubation) 0.7.2RC1 S200908110347
Cannot complete the install because one or more required items could not be found.
Software being installed: Xtext Runtime (Incubation) 0.7.2.v200908110347 (org.eclipse.xtext.runtime.feature.group 0.7.2.v200908110347)
Missing requirement: Xtext (Incubation) 0.7.2.v200908110347 (org.eclipse.xtext 0.7.2.v200908110347) requires 'bundle org.eclipse.emf.ecore 2.5.0' but it could not be found
Cannot satisfy dependency:
From: Xtext Runtime (Incubation) 0.7.2.v200908110347 (org.eclipse.xtext.runtime.feature.group 0.7.2.v200908110347)
To: org.eclipse.xtext [0.7.2.v200908110347]
__________________

Is there a fix? Am I going down the wrong path? How can I proceed from here?

I would appreciate all suggestions.

Thanks,
ray
Previous Topic:Moving to a new version - can you mix OSEE client/server versions?
Next Topic:Keeping branches for merge to other projects/variants
Goto Forum:
  


Current Time: Mon Sep 15 02:14:33 GMT 2014

Powered by FUDForum. Page generated in 0.02646 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software