Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Albireo » SWT AWT Bridge showView results in org.eclipse.swt.SWTError: Item not added
SWT AWT Bridge showView results in org.eclipse.swt.SWTError: Item not added [message #574789] Sun, 16 November 2008 09:08
Rahul Kamdar is currently offline Rahul Kamdar
Messages: 63
Registered: July 2009
Member
Hi,

I am using the SWT_AWT Bridge framework for bring panels from my Swing
application into Eclipse/SWT. One of the issues I was encountering earlier
was about views not getting refreshed appropriately whenever there was a
change in the underlying Swing content. The way to workaround this was
recommended to use the "showView" and "hideView" methods to explicitly
remove and add these views again, as a result of which their
createPartControl methods would be invoked - ensuring the refresh.

As a side-effect of using these methods, there are some inconsistent cases
where I encounter the following:

org.eclipse.swt.SWTError: Item not added
at org.eclipse.swt.SWT.error(SWT.java:3400)
at org.eclipse.swt.SWT.error(SWT.java:3297)
at org.eclipse.swt.SWT.error(SWT.java:3268)
at org.eclipse.swt.widgets.Widget.error(Widget.java:435)
at org.eclipse.swt.widgets.Menu.createItem(Menu.java:484)
at org.eclipse.swt.widgets.MenuItem.<init>(MenuItem.java:129)
at org.eclipse.jface.action.MenuManager.fill(MenuManager.java:2 18)
at org.eclipse.jface.action.MenuManager.update(MenuManager.java :662)
at org.eclipse.jface.action.MenuManager.update(MenuManager.java :581)
at org.eclipse.jface.action.MenuManager.fill(MenuManager.java:2 35)
at org.eclipse.jface.action.MenuManager.update(MenuManager.java :662)
at org.eclipse.jface.action.MenuManager.update(MenuManager.java :581)
at org.eclipse.jface.action.MenuManager.fill(MenuManager.java:2 35)
at org.eclipse.jface.action.MenuManager.update(MenuManager.java :662)
at org.eclipse.jface.action.MenuManager.update(MenuManager.java :581)
at org.eclipse.jface.action.MenuManager.fill(MenuManager.java:2 35)
at org.eclipse.jface.action.MenuManager.update(MenuManager.java :662)
at org.eclipse.jface.action.MenuManager.updateAll(MenuManager.j ava:762)
at
org.eclipse.ui.internal.WorkbenchWindow.updateActionBars(Wor kbenchWindow.java:2753)
at
org.eclipse.ui.internal.WorkbenchPage.updateActionBars(Workb enchPage.java:3685)
at
org.eclipse.ui.internal.WorkbenchPage$ActionSwitcher.updateA ctivePart(WorkbenchPage.java:361)
at
org.eclipse.ui.internal.WorkbenchPage.setActivePart(Workbenc hPage.java:3205)
at org.eclipse.ui.internal.WorkbenchPage.activate(WorkbenchPage .java:588)
at
org.eclipse.ui.internal.WorkbenchPage.busyShowView(Workbench Page.java:1008)
at
org.eclipse.ui.internal.WorkbenchPage.busyShowView(Workbench Page.java:989)
at org.eclipse.ui.internal.WorkbenchPage.access$13(WorkbenchPag e.java:968)
at org.eclipse.ui.internal.WorkbenchPage$13.run(WorkbenchPage.j ava:3514)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:67)
at org.eclipse.ui.internal.WorkbenchPage.showView(WorkbenchPage .java:3511)
at org.eclipse.ui.internal.WorkbenchPage.showView(WorkbenchPage .java:3487)

I am not sure why this is happening and what to do to avoid this problem.
Any help would be highly appreciated.

Thanks,
Rahul
Previous Topic:New milestone available
Next Topic:SWT AWT Bridge showView results in org.eclipse.swt.SWTError: Item not added
Goto Forum:
  


Current Time: Sun Sep 21 16:12:12 GMT 2014

Powered by FUDForum. Page generated in 0.01691 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software