Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IMP » Using IMP for LPG in non-IMP target
Using IMP for LPG in non-IMP target [message #574602] Thu, 15 January 2009 20:34
Mike Gering is currently offline Mike Gering
Messages: 41
Registered: July 2009
Member
I need to use LPG for parsing data within my application, and I would
like to use the IMP tooling to help me build it. The application, in one
of its forms, is not even eclipse, so I have to embed the lpg runtime in
my application. It looks like IMP might be helpful for developing my
parser, but I'm not so sure. The default grammar created by the New LPG
Grammar (non-IMP) generates an example lexer.gi file that cannot resolve
its reference to LexerVeryBasicMapF.gi. It is defined in the
org.eclipse.imp.lpg.metatooling_0.1.79/templates directory which is the
value of the LPG include path, so why does it generate the "could not be
read" error? Even when I copy the .gi file into the same directory as
the generated FoobarLexer.gi, it doesn't get found. The LPG preferences
let me override the include path, but I really would like to use a
relative path to my workspace or project. That doesn't seem to work either.

I'm simultaneously trying to learn LPG, so I'm sure there is a simple
solution. I would expect the generated grammar to compile without change.

Mike Gering
Previous Topic:What is a ModelTreeNode category?
Next Topic:contentProposer on current writing
Goto Forum:
  


Current Time: Fri Sep 19 07:55:48 GMT 2014

Powered by FUDForum. Page generated in 0.32197 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software