Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » Problem with generated wizards
Problem with generated wizards [message #574155] Sat, 15 August 2009 09:03
St is currently offline St
Messages: 77
Registered: July 2009
Member
Hi list,
I have a project with wizards and operations files plus plugin.xml
declaration of wizards for my metamodel, but it doesn't work as it should
: there is only one eclass for which wizards work.

Here is the tar.gz of the workspace:
http://stephaneerard.fr/workspaces-epsilon-tools.tar.gz

The project in question is eclipse-project-0.1.
The working wizard is src/eclipse_project/Project/Project.ewl

I think the problem comes from the plugin.xml declarations as I tested the
ewl files using epsilon prefs and it worked.
I have tried two different nsURI declarations, like:
"http://eclipse-project/0.1"
and
"http://eclipse-project/0.1/Project/Building/Command"
for the eclipse_project::Project::Building::Command eclass as example.

There are no error or warning markers nowhere regarding this problem
(existing errors correspond to generated and copied files from
epsilonTools to eclipse-project, didn't clean the workspace, just delete
epsilonTools/src/src and actions dir somewhere else within to get them
away) :(

Thank you !
Previous Topic:ClassCastException when assigning enum literal to attribute
Next Topic:[EuGENia | EOL] GMFMap Link mapping manipulation
Goto Forum:
  


Current Time: Fri Aug 29 12:16:44 EDT 2014

Powered by FUDForum. Page generated in 0.01527 seconds