Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » Unable to login to Bugzilla
Unable to login to Bugzilla [message #5168] Fri, 29 June 2007 17:42 Go to next message
Joshua Harris is currently offline Joshua Harris
Messages: 4
Registered: July 2009
Junior Member
I'm using the final Eclipse 3.3 with Mylyn 2.0 and I'm trying to connect it to my company Bugzilla account. In the Task Repositories view, I can enter in the server URL and my authentication info, when I click the Validate Settings button it says "Authentication credentials are valid", but as soon as I try to do a query I get a dialog that says

Unable to login to https://<my bugzilla URL>.

log in to bugzilla

Please validate credentials via Task Repositories view.

How do I fix this issue? I've never used the Mylyn plugin before, but it seems really interesting and I'd love to get it working. Thanks for any help!
Re: Unable to login to Bugzilla [message #5237 is a reply to message #5168] Fri, 29 June 2007 19:34 Go to previous messageGo to next message
Eclipse User
Originally posted by: rob.elves.eclipse.org

Joshua,

The Bugzilla connector does have shortcomings when dealing with some
customized Bugzilla installs. One side effect can be failure to
authenticate (or recognize successful authentication). A few things to try:

- If using a proxy ensure it is set either in your Workspace preferences
or within the Task Repository settings page.
- If the company Bugzilla site is protected via http authentication,
ensure your username and password are set in the Task Repository
settings page.

If this doesn't result in success, please open a bug report
(https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Mylyn) and we can
continue debugging there.

Thanks,

-Rob


Joshua Harris wrote:
> I'm using the final Eclipse 3.3 with Mylyn 2.0 and I'm trying to connect it to my company Bugzilla account. In the Task Repositories view, I can enter in the server URL and my authentication info, when I click the Validate Settings button it says "Authentication credentials are valid", but as soon as I try to do a query I get a dialog that says
>
> Unable to login to https://<my bugzilla URL>.
>
> log in to bugzilla
>
> Please validate credentials via Task Repositories view.
>
> How do I fix this issue? I've never used the Mylyn plugin before, but it seems really interesting and I'd love to get it working. Thanks for any help!
Re: Unable to login to Bugzilla [message #6696 is a reply to message #5237] Fri, 29 June 2007 21:30 Go to previous messageGo to next message
Joshua Harris is currently offline Joshua Harris
Messages: 4
Registered: July 2009
Junior Member
Thank you for the feedback. I am not using a proxy, it's not using any HTTP authentication and it's not a customized Bugzilla install. It is a stock 2.22.2 installation. The only thing I can think of is that it is using a self-signed SSL certificate (HTTPS), though that will be changing shortly. If this scenario should work, then I'll file a bug report. Thanks again for your help.
Re: Unable to login to Bugzilla [message #6737 is a reply to message #5237] Mon, 02 July 2007 07:50 Go to previous message
Tobias F is currently offline Tobias F
Messages: 35
Registered: July 2009
Member
I'm facing the same Problem. Bugzilla 2.22.1 with a self signed certificate.
There was never a question for accepting the certificate like in subclipse.
No http authentication.
Tried with and without proxy from two different places. Both resulted in an
error.
I switched in 'additional settings' to repository version 2.22

Now I changed to a free test certificate from radpidssl that is fully
functional. Still the same error.
Anonymous access to https://bugs.eclipse.org/bugs works fine.

I filled in a bug report:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=195113

Thanks,
Tobias

"Robert Elves" <rob.elves@eclipse.org> schrieb im Newsbeitrag
news:f644ue$582$1@build.eclipse.org...
> Joshua,
>
> The Bugzilla connector does have shortcomings when dealing with some
> customized Bugzilla installs. One side effect can be failure to
> authenticate (or recognize successful authentication). A few things to
> try:
>
> - If using a proxy ensure it is set either in your Workspace preferences
> or within the Task Repository settings page.
> - If the company Bugzilla site is protected via http authentication,
> ensure your username and password are set in the Task Repository settings
> page.
>
> If this doesn't result in success, please open a bug report
> (https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Mylyn) and we can
> continue debugging there.
>
> Thanks,
>
> -Rob
>
>
> Joshua Harris wrote:
>> I'm using the final Eclipse 3.3 with Mylyn 2.0 and I'm trying to connect
>> it to my company Bugzilla account. In the Task Repositories view, I can
>> enter in the server URL and my authentication info, when I click the
>> Validate Settings button it says "Authentication credentials are valid",
>> but as soon as I try to do a query I get a dialog that says Unable to
>> login to https://&lt;my bugzilla URL&gt;. log in to bugzilla
>>
>> Please validate credentials via Task Repositories view.
>>
>> How do I fix this issue? I've never used the Mylyn plugin before, but it
>> seems really interesting and I'd love to get it working. Thanks for any
>> help!
Re: Unable to login to Bugzilla [message #569043 is a reply to message #5168] Fri, 29 June 2007 19:34 Go to previous message
Robert Elves is currently offline Robert Elves
Messages: 87
Registered: July 2009
Member
Joshua,

The Bugzilla connector does have shortcomings when dealing with some
customized Bugzilla installs. One side effect can be failure to
authenticate (or recognize successful authentication). A few things to try:

- If using a proxy ensure it is set either in your Workspace preferences
or within the Task Repository settings page.
- If the company Bugzilla site is protected via http authentication,
ensure your username and password are set in the Task Repository
settings page.

If this doesn't result in success, please open a bug report
(https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Mylyn) and we can
continue debugging there.

Thanks,

-Rob


Joshua Harris wrote:
> I'm using the final Eclipse 3.3 with Mylyn 2.0 and I'm trying to connect it to my company Bugzilla account. In the Task Repositories view, I can enter in the server URL and my authentication info, when I click the Validate Settings button it says "Authentication credentials are valid", but as soon as I try to do a query I get a dialog that says
>
> Unable to login to https://&lt;my bugzilla URL&gt;.
>
> log in to bugzilla
>
> Please validate credentials via Task Repositories view.
>
> How do I fix this issue? I've never used the Mylyn plugin before, but it seems really interesting and I'd love to get it working. Thanks for any help!
Re: Unable to login to Bugzilla [message #569164 is a reply to message #5237] Fri, 29 June 2007 21:30 Go to previous message
Joshua Harris is currently offline Joshua Harris
Messages: 4
Registered: July 2009
Junior Member
Thank you for the feedback. I am not using a proxy, it's not using any HTTP authentication and it's not a customized Bugzilla install. It is a stock 2.22.2 installation. The only thing I can think of is that it is using a self-signed SSL certificate (HTTPS), though that will be changing shortly. If this scenario should work, then I'll file a bug report. Thanks again for your help.
Re: Unable to login to Bugzilla [message #569353 is a reply to message #5237] Mon, 02 July 2007 07:50 Go to previous message
Tobias F is currently offline Tobias F
Messages: 35
Registered: July 2009
Member
I'm facing the same Problem. Bugzilla 2.22.1 with a self signed certificate.
There was never a question for accepting the certificate like in subclipse.
No http authentication.
Tried with and without proxy from two different places. Both resulted in an
error.
I switched in 'additional settings' to repository version 2.22

Now I changed to a free test certificate from radpidssl that is fully
functional. Still the same error.
Anonymous access to https://bugs.eclipse.org/bugs works fine.

I filled in a bug report:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=195113

Thanks,
Tobias

"Robert Elves" <rob.elves@eclipse.org> schrieb im Newsbeitrag
news:f644ue$582$1@build.eclipse.org...
> Joshua,
>
> The Bugzilla connector does have shortcomings when dealing with some
> customized Bugzilla installs. One side effect can be failure to
> authenticate (or recognize successful authentication). A few things to
> try:
>
> - If using a proxy ensure it is set either in your Workspace preferences
> or within the Task Repository settings page.
> - If the company Bugzilla site is protected via http authentication,
> ensure your username and password are set in the Task Repository settings
> page.
>
> If this doesn't result in success, please open a bug report
> (https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Mylyn) and we can
> continue debugging there.
>
> Thanks,
>
> -Rob
>
>
> Joshua Harris wrote:
>> I'm using the final Eclipse 3.3 with Mylyn 2.0 and I'm trying to connect
>> it to my company Bugzilla account. In the Task Repositories view, I can
>> enter in the server URL and my authentication info, when I click the
>> Validate Settings button it says "Authentication credentials are valid",
>> but as soon as I try to do a query I get a dialog that says Unable to
>> login to https://&lt;my bugzilla URL&gt;. log in to bugzilla
>>
>> Please validate credentials via Task Repositories view.
>>
>> How do I fix this issue? I've never used the Mylyn plugin before, but it
>> seems really interesting and I'd love to get it working. Thanks for any
>> help!
Previous Topic:minor annoyance with change method signature refactor
Next Topic:What happened to the generic web connector?
Goto Forum:
  


Current Time: Tue Jul 29 00:51:33 EDT 2014

Powered by FUDForum. Page generated in 0.01724 seconds