Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » Mylyn performance on network drives?
Mylyn performance on network drives? [message #573243] Wed, 18 July 2007 19:53
Kim Sullivan is currently offline Kim Sullivan
Messages: 44
Registered: July 2009
Member
I've been having performance problems using Mylyn with my workspace
placed on a network drive (I assume that those problems come from having
a remote workspace, I might be mistaken).

First, there was an issue with tooltips (I had them accidentally set to
wait for 0ms before showing, and Mylyn was trying to load too many
tooltips at once - over the network, which caused some lag). Setting a
more reasonable tooltip delay time fixed this
(https://bugs.eclipse.org/bugs/show_bug.cgi?id=196109)

But Eclipse was still quite unresponsive - I even deleted all the
queries to bugs.eclipse.org so the system wouldn't spent time
synchronizing them, without success (and it was still spending
considerable time "synchronizing 0 queries").

The weird thing was that I kept getting change notifications for
tasks/bugs that I had already deleted from the task list (or so I presumed).

So I used Total Commander to look into the offline folder of mylin
metadata - and lo and behold, even getting a directory listing for all
of the 3300 stored bugs took a few seconds. No wonder Eclipse was so
sluggish (I assume it was going through the list of 3300 offline bugs
every time and looking for changes... even though I had none of those
bugs or queries in my task list). I even had to increase the VM size,
because I was getting heap space errors from Mylyn (last time I checked,
eclipse had about 500MB in memory and about 700MB virtual memory total).

So I manually deleted all of the 3k files in the offline directory. Now
Mylyn still spends some time "synchronizing" but at least Eclipse stays
responsive.

My question is - can something be done about this, maybe limiting the
amount of files stored offline? Or is it just an issue of me having my
workspace on a network drive? Is there something I can do to diagnose
the problem further?

Regards,
Kim Sullivan
Previous Topic:dev build and XPlanner connector preview
Next Topic:How does Mylyn determine the email addresses available when completing Bugzilla fields?
Goto Forum:
  


Current Time: Sun Sep 21 02:08:32 GMT 2014

Powered by FUDForum. Page generated in 0.01630 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software