Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMT (Generative Modeling Technologies) » [GEMS] JPLException?
[GEMS] JPLException? [message #572118] Sun, 04 March 2007 22:16
No real name is currently offline No real nameFriend
Messages: 8
Registered: September 2009
Junior Member
Hi,

I am playing around with GEMS currently. Unfortunately I seem to make
a mistake that I am unable to figure out.

I followed the instructions for installing GEMS that I found on the
sourceforge website and in the users guide. Then, for testing: I
created a small metamodel, just an entity named Foo which is the root
and contains another entity named Bar.

I generate a DSML tool from the model and see - almost - what I would
expect: on the right two types, Foo and Bar. And I can place the Bar
in a new Model (which is a Foo). The interesting thing is that when I
select the Bar type in my editor and place it into the model I can see
in the eclipse instance from which I am running my generated modelling
tool a number of JPLExceptions stating

jpl.JPLException: jpl_do_pvm_init(): called while jpl_status !=
JPL_INIT_PVM_MAYBE.

I think this is also the reason which leads to another problem, when
putting a third entity Baz in the metamodel that is contained by Bar.
I can't place it anywhere in the generated tool which is likely due to
the failed prolog query. The javadoc documentation of the JPLException
says that it denotes an error in the (Java-Prolog?-)interface code, so
I suspect this is not a gems problem.

The tools I am using are Eclipse 3.2.2, EMF 2.2.2, GEF 3.2.2, the GEMS
support plugins from Jules' website (kent OCL), GEMS 2.0.5_01 and
SWI-Prolog 5.6.29

Any hints or recommendations what I could try to figure out what the
problem is are very welcome.


Thanks in advance

Lars
Previous Topic:[AM3] New Mirror Zoo available: Atlantic OWL zoo
Next Topic:[MOFScript] Java Api howto
Goto Forum:
  


Current Time: Wed Nov 26 08:11:12 GMT 2014

Powered by FUDForum. Page generated in 0.01737 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software