Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Faceted Project Framework » Is Faceted Project Framework supported in Ganymede?
Is Faceted Project Framework supported in Ganymede? [message #572100] Mon, 28 September 2009 15:49 Go to next message
Gabriel Petrovay is currently offline Gabriel PetrovayFriend
Messages: 42
Registered: July 2009
Member
Hi,

Can you please tell me if FPF is compatible with Ganymede? If yes, how can one install it? I tried to find it in the Ganymede and Eclipse update sites on the "Software Updates..." page, but there was no "facet" plug-in found.

I want to recommend our users (xqdt.org) how to install it in 3.4.

Thanks!

Gabriel
Re: Is Faceted Project Framework supported in Ganymede? [message #572131 is a reply to message #572100] Mon, 05 October 2009 20:24 Go to previous message
Konstantin Komissarchik is currently offline Konstantin KomissarchikFriend
Messages: 950
Registered: July 2009
Senior Member
If you want to use Faceted Project Framework with Ganymede, you will have to consume it from Eclipse Web Tools project. It was not broken out into it's own installable feature in that release.

The easiest way to get started is to download Eclipse IDE for Java EE developers. Alternatively, you should be able to find and install Web Standard Tools features on the Ganymede update site. Those features contain the framework plugins among other things.

In WTP, the plugins have the following IDs:

org.eclipse.wst.common.project.facet.core
org.eclipse.wst.common.project.facet.ui

Note that the framework plugins do not have any WTP dependencies even in Ganymede, so if you need to, you can always package these plugins separately.

- Konstantin
Previous Topic:Is Faceted Project Framework supported in Ganymede?
Next Topic:modifying facet constraints programmatically
Goto Forum:
  


Current Time: Fri Nov 21 02:51:16 GMT 2014

Powered by FUDForum. Page generated in 0.03012 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software